summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-07-03 15:24:01 +0200
committerJeroen Roovers <jer@gentoo.org>2020-07-03 15:25:37 +0200
commit68e3a812fcf447ed894111f8aad8c580bf041f30 (patch)
tree56f5587bfe95e0ec662b50e4e17b9f22d9c2bbb9 /net-analyzer/multipath-tcp-tools/multipath-tcp-tools-999999.ebuild
parentnet-analyzer/multipath-tcp-tools: Initial commit (diff)
downloadgentoo-68e3a812fcf447ed894111f8aad8c580bf041f30.tar.gz
gentoo-68e3a812fcf447ed894111f8aad8c580bf041f30.tar.bz2
gentoo-68e3a812fcf447ed894111f8aad8c580bf041f30.zip
net-analyzer/multipath-tcp-tools: Add live ebuild
Package-Manager: Portage-2.3.103, Repoman-2.3.23 Bug: https://bugs.gentoo.org/730608 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/multipath-tcp-tools/multipath-tcp-tools-999999.ebuild')
-rw-r--r--net-analyzer/multipath-tcp-tools/multipath-tcp-tools-999999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/net-analyzer/multipath-tcp-tools/multipath-tcp-tools-999999.ebuild b/net-analyzer/multipath-tcp-tools/multipath-tcp-tools-999999.ebuild
new file mode 100644
index 000000000000..60d3b27244e8
--- /dev/null
+++ b/net-analyzer/multipath-tcp-tools/multipath-tcp-tools-999999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit git-r3 toolchain-funcs
+
+DESCRIPTION="Analysis tools for Multipath Transmission Control Protocol (MPTCP)"
+HOMEPAGE="https://github.com/nasa/multipath-tcp-tools"
+EGIT_REPO_URI="https://github.com/nasa/multipath-tcp-tools/"
+
+LICENSE="NOSA"
+SLOT="0"
+KEYWORDS=""
+
+DEPEND="
+ dev-libs/openssl:*
+ net-libs/libpcap
+"
+RDEPEND="
+ ${DEPEND}
+"
+S=${WORKDIR}/${P}/network-traffic-analysis-tools
+
+src_prepare() {
+ sed -i \
+ -e 's|/man/man1|/share&|g' \
+ Makefile || die
+
+ default
+}
+
+src_compile() {
+ emake \
+ CXX="$(tc-getCXX)" \
+ CXXFLAGS="${CXXFLAGS}"
+}
+
+src_install() {
+ emake PREFIX="${D}/${EPREFIX}/usr" install
+
+ dodoc README
+}