summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/nagios-plugins-flameeyes/nagios-plugins-flameeyes-9999.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/nagios-plugins-flameeyes/nagios-plugins-flameeyes-9999.ebuild')
-rw-r--r--net-analyzer/nagios-plugins-flameeyes/nagios-plugins-flameeyes-9999.ebuild50
1 files changed, 50 insertions, 0 deletions
diff --git a/net-analyzer/nagios-plugins-flameeyes/nagios-plugins-flameeyes-9999.ebuild b/net-analyzer/nagios-plugins-flameeyes/nagios-plugins-flameeyes-9999.ebuild
new file mode 100644
index 000000000000..ed36b23f811a
--- /dev/null
+++ b/net-analyzer/nagios-plugins-flameeyes/nagios-plugins-flameeyes-9999.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit git-2 multilib
+
+EGIT_REPO_URI="https://github.com/Flameeyes/${PN}.git"
+SRC_URI=""
+KEYWORDS=""
+
+DESCRIPTION="Flameeyes's custom Nagios/Icinga plugins"
+HOMEPAGE="https://github.com/Flameeyes/nagios-plugins-flameeyes"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="smart samba"
+
+RDEPEND="
+ dev-perl/Nagios-Plugin
+ sys-apps/portage
+ dev-perl/Time-Duration
+ dev-perl/TimeDate
+ smart? (
+ sys-apps/smartmontools
+ app-admin/sudo
+ )
+ samba? ( dev-perl/Filesys-SmbClient )"
+DEPEND=""
+
+src_compile() {
+ cat - > "${T}"/50${PN} <<EOF
+Cmnd_Alias NAGIOS_PLUGINS_FLAMEEYES_CMDS = /usr/sbin/smartctl
+User_Alias NAGIOS_PLUGINS_FLAMEEYES_USERS = nagios, icinga
+
+NAGIOS_PLUGINS_FLAMEEYES_USERS ALL=(root) NOPASSWD: NAGIOS_PLUGINS_FLAMEEYES_CMDS
+EOF
+}
+
+src_install() {
+ insinto /etc/sudoers.d
+ doins "${T}"/50${PN}
+
+ dodir /usr/$(get_libdir)/nagios/plugins/flameeyes
+ cp -Rp $(find . -type d -mindepth 1 -maxdepth 1 -not -name .git) \
+ "${D}/usr/$(get_libdir)/nagios/plugins/flameeyes" || die
+
+ dodoc README.md
+}