summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2020-10-24 19:18:38 +0200
committerDavid Seifert <soap@gentoo.org>2020-10-24 19:18:38 +0200
commit07f4ad3b1e8912358e540bd059fb44f48c0be640 (patch)
treee9fc198c24b38c50481d2cf99a32c57dc2a776eb /net-analyzer/nagios-plugins-snmp
parentnet-analyzer/nagios-check_glsa2: Port to EAPI 7 (diff)
downloadgentoo-07f4ad3b1e8912358e540bd059fb44f48c0be640.tar.gz
gentoo-07f4ad3b1e8912358e540bd059fb44f48c0be640.tar.bz2
gentoo-07f4ad3b1e8912358e540bd059fb44f48c0be640.zip
net-analyzer/nagios-plugins-snmp: Port to EAPI 7
Closes: https://bugs.gentoo.org/742215 Package-Manager: Portage-3.0.8, Repoman-3.0.2 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-analyzer/nagios-plugins-snmp')
-rw-r--r--net-analyzer/nagios-plugins-snmp/nagios-plugins-snmp-0.6.0-r2.ebuild29
1 files changed, 13 insertions, 16 deletions
diff --git a/net-analyzer/nagios-plugins-snmp/nagios-plugins-snmp-0.6.0-r2.ebuild b/net-analyzer/nagios-plugins-snmp/nagios-plugins-snmp-0.6.0-r2.ebuild
index c89ed52c8249..6eb4daae21ea 100644
--- a/net-analyzer/nagios-plugins-snmp/nagios-plugins-snmp-0.6.0-r2.ebuild
+++ b/net-analyzer/nagios-plugins-snmp/nagios-plugins-snmp-0.6.0-r2.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=4
+EAPI=7
-inherit autotools user
+inherit autotools
DESCRIPTION="Additional Nagios plugins for monitoring SNMP capable devices"
HOMEPAGE="http://nagios.manubulon.com"
@@ -12,31 +12,28 @@ SRC_URI="http://nagios.manubulon.com/${P}.tgz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ~ppc ppc64 ~sparc x86"
-IUSE=""
-DEPEND="net-analyzer/net-snmp"
+DEPEND="
+ acct-group/nagios
+ acct-user/nagios
+ net-analyzer/net-snmp"
RDEPEND="${DEPEND}"
-S=${WORKDIR}/nagios-plugins-snmp
-
-pkg_setup() {
- enewgroup nagios
- enewuser nagios -1 /bin/bash /var/nagios/home nagios
-}
+S="${WORKDIR}/nagios-plugins-snmp"
src_prepare() {
- sed -i -e '/^CFLAGS=""/d' configure.in
+ default
+ sed -i -e '/^CFLAGS=""/d' configure.in || die
+ mv configure.{in,ac} || die
eautoreconf
}
src_configure() {
econf \
- --sysconfdir=/etc/nagios \
- --libexec=/usr/$(get_libdir)/nagios/plugins
+ --sysconfdir="${EPREFIX}"/etc/nagios \
+ --libexec="${EPREFIX}"/usr/$(get_libdir)/nagios/plugins
}
-DOCS=( README NEWS AUTHORS )
-
src_install() {
default