summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/ntop/ntop-4.0.3.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/ntop/ntop-4.0.3.ebuild')
-rw-r--r--net-analyzer/ntop/ntop-4.0.3.ebuild126
1 files changed, 126 insertions, 0 deletions
diff --git a/net-analyzer/ntop/ntop-4.0.3.ebuild b/net-analyzer/ntop/ntop-4.0.3.ebuild
new file mode 100644
index 000000000000..04220a638c36
--- /dev/null
+++ b/net-analyzer/ntop/ntop-4.0.3.ebuild
@@ -0,0 +1,126 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+
+inherit autotools eutils user
+
+DESCRIPTION="Network traffic analyzer with web interface"
+HOMEPAGE="http://www.ntop.org/products/ntop/"
+SRC_URI="mirror://sourceforge/ntop/${P}.tgz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="amd64 arm hppa ia64 ppc ppc64 s390 sh sparc x86"
+IUSE="ipv6 ssl"
+#snmp support is disabled
+
+#snmp? ( net-analyzer/net-snmp )
+COMMON_DEPEND="virtual/awk
+ dev-lang/perl
+ sys-libs/gdbm
+ dev-libs/libevent
+ net-libs/libpcap
+ media-libs/gd
+ media-libs/libpng
+ net-analyzer/rrdtool[graph]
+ ssl? ( dev-libs/openssl )
+ sys-libs/zlib
+ >=dev-libs/geoip-1.4.5
+ >=dev-lang/lua-5.1.4"
+DEPEND="${COMMON_DEPEND}
+ >=sys-devel/libtool-1.4"
+
+# Needed by xmldumpPlugin - couldn't get it to work
+# dev-libs/gdome2
+# >=dev-libs/glib-2"
+RDEPEND="${COMMON_DEPEND}
+ media-fonts/corefonts
+ media-gfx/graphviz
+ net-misc/wget
+ app-arch/gzip"
+
+pkg_setup() {
+ # snmp doesn't compile in this release, disabled for now
+ #if use snmp ; then
+ # ewarn "snmp plugin is under development and upstream does not recommend"
+ # ewarn "it for usage in production environment."
+ # if ! use ipv6 ; then
+ # echo
+ # eerror "snmp plugin has compilation problems without ipv6 support."
+ # eerror "For additional information see bug #121497."
+ # die "snmp without ipv6 is broken"
+ # else
+ # if ! built_with_use net-analyzer/net-snmp ipv6 ; then
+ # echo
+ # eerror "You have both ipv6 and snmp enabled."
+ # eerror "This require ipv6 support in net-analyzer/net-snmp."
+ # eerror "However, net-analyzer/net-snmp was compiled with ipv6 flag disabled."
+ # eerror "Please, re-emerge net-analyzer/net-snmp with USE=\"ipv6\"."
+ # die "net-analyzer/net-snmp was build without ipv6."
+ # fi
+ # fi
+ #fi
+
+ enewgroup ntop
+ enewuser ntop -1 -1 /var/lib/ntop ntop
+}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+ cat acinclude.m4.in acinclude.m4.ntop > acinclude.m4
+ eautoreconf
+}
+
+src_configure() {
+ # force disable xmldumpPlugin
+ export \
+ ac_cv_header_glib_h=no \
+ ac_cv_header_glibconfig_h=no \
+ ac_cv_header_gdome_h=no \
+ ac_cv_lib_glib_g_date_julian=no \
+ ac_cv_lib_xml2_xmlCheckVersion=no \
+ ac_cv_lib_gdome_gdome_di_saveDocToFile=no
+
+ econf \
+ $(use_enable ipv6) \
+ $(use_with ssl) \
+ --with-rrd-home=/usr/lib \
+ --disable-snmp \
+ || die "configure problem"
+ # $(use_enable snmp)
+}
+
+src_install() {
+ LC_ALL=C # apparently doesn't work with some locales (#191576 and #205382)
+ emake DESTDIR="${D}" install || die "install problem"
+
+ keepdir /var/lib/ntop &&
+ fowners ntop:ntop /var/lib/ntop &&
+ fperms 750 /var/lib/ntop ||
+ die "failed to prepare /var/lib/ntop dir"
+ insinto /var/lib/ntop
+ local f
+ for f in GeoIPASNum.dat GeoLiteCity.dat; do
+ # Don't install included GeoIP files if newer versions are available
+ [ -f "${ROOT}/var/lib/ntop/${f}" ] ||
+ doins "3rd_party/${f}" ||
+ die "failed to install ${f}"
+ done
+
+ dodoc AUTHORS CONTENTS ChangeLog MANIFESTO NEWS
+ dodoc PORTING README SUPPORT_NTOP.txt THANKS $(find docs -type f)
+
+ newinitd "${FILESDIR}"/ntop-initd ntop
+ newconfd "${FILESDIR}"/ntop-confd ntop
+
+ exeinto /etc/cron.monthly
+ doexe "${FILESDIR}"/ntop-update-geoip-db
+}
+
+pkg_postinst() {
+ elog "If this is the first time you install ntop, you need to run"
+ elog "following command before starting ntop service:"
+ elog " ntop --set-admin-password"
+}