summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-12-28 11:13:06 +0100
committerJeroen Roovers <jer@gentoo.org>2019-12-28 11:14:09 +0100
commit10f1982d276738ad4f4f48d2805eb1ed5b30e713 (patch)
treefc9e20f283b07335a6086dcb3230c0c76875d6ab /net-analyzer/ntopng
parentnet-libs/nDPI: Set sub-SLOT for >3.0 (diff)
downloadgentoo-10f1982d276738ad4f4f48d2805eb1ed5b30e713.tar.gz
gentoo-10f1982d276738ad4f4f48d2805eb1ed5b30e713.tar.bz2
gentoo-10f1982d276738ad4f4f48d2805eb1ed5b30e713.zip
net-analyzer/ntopng: Version 3.8.1
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Closes: https://bugs.gentoo.org/show_bug.cgi?id=704058 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/ntopng')
-rw-r--r--net-analyzer/ntopng/Manifest1
-rw-r--r--net-analyzer/ntopng/files/ntopng-3.8.1-parallel-make.patch15
-rw-r--r--net-analyzer/ntopng/ntopng-3.8.1.ebuild85
3 files changed, 101 insertions, 0 deletions
diff --git a/net-analyzer/ntopng/Manifest b/net-analyzer/ntopng/Manifest
index 8d3e6828dfd8..ecc686e168d7 100644
--- a/net-analyzer/ntopng/Manifest
+++ b/net-analyzer/ntopng/Manifest
@@ -1,3 +1,4 @@
DIST ntopng-2.4.tar.gz 134074662 BLAKE2B dbf654e5cd1f9eddb5ae325bdf0ac2e7ce22c08f55363b10723bde2cb5fd86cf3b0c7fef0f55dc7fcce0341f5fbb9a7132f26e29649bcf66020b640975c0e6da SHA512 515dd7889ae3aaf2482371bb2c55ab7300cf4207fe07f37029b7529bfb710379c19a54f58cf6df87e42454c0c99d15291af334adff676252301d9edd0acf3c7a
DIST ntopng-3.0.tar.gz 23017655 BLAKE2B f791690118a5ecfb1be5ad791229f2438354a0c2271350aa1a2f0fee05886c54d181a669e6e1b27657c5bfe4b68db24b06d91adfb89e803a154a7a4bbff146b7 SHA512 d5e310d5dba7fe696d38d9d8251ffa4077182200e41c3f0b6034e68cf6623220ec47ba9d9fd5d2392a7b65a6de770e330821169c7ec06b4952f68c3f5f738eb1
+DIST ntopng-3.8.1.tar.gz 33914341 BLAKE2B 3b0df382e938af78d10e71282e863ccb7ba1da3dc7e2bf90b45f1e6e4670052a8c61a16cb8547f119f0dc753a2e31273b41f40aa26919480cbaecf43b6d59742 SHA512 4cb613881e36b435f97dcc25dfaa505d9c552f63ad8334d5c9d47ec06376d47124c65e6d782546d36f6d27b34b037cc73df7129f459f290ac51e270bb7453970
DIST ntopng-3.8.tar.gz 33910329 BLAKE2B a5aaed2244516b92e4b8c7364817ea66eb2f446fe814a96622cbbf5d851d79e8049b75da009d0f80f07c1fae90f8dc294794b76ed14450d8e0e6685a1b1ce8f2 SHA512 2236f9931fc606e4d0a6da379c480a48bacd441cf199a310ea690a03d74d08f369825ea02e3c13828a10f716a5531d4e6774876f253ab348a52bcf8bd8d5107f
diff --git a/net-analyzer/ntopng/files/ntopng-3.8.1-parallel-make.patch b/net-analyzer/ntopng/files/ntopng-3.8.1-parallel-make.patch
new file mode 100644
index 000000000000..9089c0a9b04d
--- /dev/null
+++ b/net-analyzer/ntopng/files/ntopng-3.8.1-parallel-make.patch
@@ -0,0 +1,15 @@
+--- a/configure.seed
++++ b/configure.seed
+@@ -526,11 +520,7 @@
+
+ AC_DEFINE_UNQUOTED(_CRT_SECURE_NO_WARNINGS, 1, [Disable warning on windows])
+
+-GMAKE=`which gmake`
+-if test x$GMAKE = x
+-then
+- GMAKE="make"
+-fi
++GMAKE='$(MAKE)'
+
+ GIT=`which git`
+ if test x$GIT = x
diff --git a/net-analyzer/ntopng/ntopng-3.8.1.ebuild b/net-analyzer/ntopng/ntopng-3.8.1.ebuild
new file mode 100644
index 000000000000..0e41d4cf7c9f
--- /dev/null
+++ b/net-analyzer/ntopng/ntopng-3.8.1.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools user toolchain-funcs
+
+DESCRIPTION="Network traffic analyzer with web interface"
+HOMEPAGE="https://www.ntop.org/"
+SRC_URI="https://github.com/ntop/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="
+ dev-db/sqlite:3
+ dev-python/pyzmq
+ dev-lang/luajit:2
+ dev-libs/json-c:=
+ dev-libs/geoip
+ dev-libs/glib:2
+ dev-libs/hiredis
+ dev-libs/libsodium:=
+ dev-libs/libxml2
+ dev-libs/libmaxminddb
+ net-analyzer/rrdtool
+ net-libs/libpcap
+ >=net-libs/nDPI-3.0
+ net-misc/curl
+ sys-libs/binutils-libs
+ dev-db/mysql-connector-c:=
+"
+RDEPEND="
+ ${DEPEND}
+ dev-db/redis
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.8-mysqltool.patch
+ "${FILESDIR}"/${PN}-3.8-ndpi-includes.patch
+ "${FILESDIR}"/${PN}-3.8-missing-min.patch
+ "${FILESDIR}"/${PN}-3.8.1-parallel-make.patch
+)
+
+pkg_setup() {
+ enewuser ntopng
+}
+
+src_prepare() {
+ default
+
+ sed \
+ -e "s/@VERSION@/${PV}.$(date +%y%m%d)/g" \
+ -e "s/@SHORT_VERSION@/${PV}/g" \
+ < "${S}/configure.seed" \
+ > "${S}/configure.ac" || die
+
+ eautoreconf
+}
+
+src_install() {
+ SHARE_NTOPNG_DIR="${EPREFIX}/usr/share/${PN}"
+ dodir ${SHARE_NTOPNG_DIR}
+ insinto ${SHARE_NTOPNG_DIR}
+ doins -r httpdocs
+ doins -r scripts
+
+ dodir ${SHARE_NTOPNG_DIR}/third-party
+ insinto ${SHARE_NTOPNG_DIR}/third-party
+ doins -r third-party/i18n.lua-master
+ doins -r third-party/lua-resty-template-master
+
+ exeinto /usr/bin
+ doexe ${PN}
+ doman ${PN}.8
+
+ newinitd "${FILESDIR}"/ntopng.init.d ntopng
+ newconfd "${FILESDIR}"/ntopng.conf.d ntopng
+
+ keepdir /var/lib/ntopng
+ fowners ntopng /var/lib/ntopng
+}
+
+pkg_postinst() {
+ elog "ntopng default credentials are user='admin' password='admin'"
+}