summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawomir Lis <slis@gentoo.org>2017-12-07 07:44:02 +0100
committerSlawomir Lis <slis@gentoo.org>2017-12-07 07:44:02 +0100
commit357253b38a46dce4aa13a6b419eed78b486ea350 (patch)
tree0b83538be3c48ac8660df933abb23284906f3471 /net-analyzer/ntopng
parentapp-arch/pax: Remove -Werror (bug #640076). (diff)
downloadgentoo-357253b38a46dce4aa13a6b419eed78b486ea350.tar.gz
gentoo-357253b38a46dce4aa13a6b419eed78b486ea350.tar.bz2
gentoo-357253b38a46dce4aa13a6b419eed78b486ea350.zip
net-analyzer/ntopng: fixed bug 634104
Applying patch sent by zoltan@sinustrom.info This patch is solving problem with pointer comparison Reported by: fkrogh@mathalacarte.com Package-Manager: Portage-2.3.16, Repoman-2.3.6
Diffstat (limited to 'net-analyzer/ntopng')
-rw-r--r--net-analyzer/ntopng/files/pointer-cmp.patch12
-rw-r--r--net-analyzer/ntopng/ntopng-3.0-r1.ebuild1
2 files changed, 13 insertions, 0 deletions
diff --git a/net-analyzer/ntopng/files/pointer-cmp.patch b/net-analyzer/ntopng/files/pointer-cmp.patch
new file mode 100644
index 000000000000..11fb47ca3853
--- /dev/null
+++ b/net-analyzer/ntopng/files/pointer-cmp.patch
@@ -0,0 +1,12 @@
+diff -Naur ntopng-3.0-orig/src/AddressResolution.cpp ntopng-3.0/src/AddressResolution.cpp
+--- ntopng-3.0-orig/src/AddressResolution.cpp 2017-06-01 00:18:57.000000000 -0700
++++ ntopng-3.0/src/AddressResolution.cpp 2017-11-27 23:13:50.158163187 -0800
+@@ -52,7 +52,7 @@
+ u_int numeric_ip_len;
+
+ snprintf(query, sizeof(query), "%s", _numeric_ip);
+- if((at = strchr(query, '@')) != '\0') at[0] = '\0';
++ if((at = strchr(query, '@')) != NULL) at[0] = '\0';
+ numeric_ip = query;
+ numeric_ip_len = strlen(numeric_ip)-1;
+
diff --git a/net-analyzer/ntopng/ntopng-3.0-r1.ebuild b/net-analyzer/ntopng/ntopng-3.0-r1.ebuild
index 3fe29fa78180..3470ef4dea27 100644
--- a/net-analyzer/ntopng/ntopng-3.0-r1.ebuild
+++ b/net-analyzer/ntopng/ntopng-3.0-r1.ebuild
@@ -30,6 +30,7 @@ RDEPEND="${DEPEND}
PATCHES=(
"${FILESDIR}"/${P}-gentoo.patch
"${FILESDIR}"/${P}-mysqltool.patch
+ "${FILESDIR}"/${P}-pointer-cmp.patch
)
src_prepare() {