summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSlawomir Lis <slis@gentoo.org>2019-08-27 05:42:07 +0200
committerSlawomir Lis <slis@gentoo.org>2019-08-27 05:42:20 +0200
commite4e99e0656d0339ffff8959b89cccdd9d1ec8211 (patch)
treea75a0812ec3c06551defa93fe1a3e1d4118f4f51 /net-analyzer/ntopng
parentsys-apps/nvme-cli: keyword on ~ppc64 (diff)
downloadgentoo-e4e99e0656d0339ffff8959b89cccdd9d1ec8211.tar.gz
gentoo-e4e99e0656d0339ffff8959b89cccdd9d1ec8211.tar.bz2
gentoo-e4e99e0656d0339ffff8959b89cccdd9d1ec8211.zip
net-analyzer/ntopng: version bump to 3.8
Package-Manager: Portage-2.3.72, Repoman-2.3.17 Signed-off-by: Slawek Lis <slis@gentoo.org>
Diffstat (limited to 'net-analyzer/ntopng')
-rw-r--r--net-analyzer/ntopng/Manifest1
-rw-r--r--net-analyzer/ntopng/files/ntopng-3.8-missing-min.patch19
-rw-r--r--net-analyzer/ntopng/files/ntopng-3.8-mysqltool.patch17
-rw-r--r--net-analyzer/ntopng/files/ntopng-3.8-ndpi-call.patch12
-rw-r--r--net-analyzer/ntopng/files/ntopng-3.8-ndpi-includes.patch14
-rw-r--r--net-analyzer/ntopng/ntopng-3.8.ebuild76
6 files changed, 139 insertions, 0 deletions
diff --git a/net-analyzer/ntopng/Manifest b/net-analyzer/ntopng/Manifest
index 944ce61a6953..8d3e6828dfd8 100644
--- a/net-analyzer/ntopng/Manifest
+++ b/net-analyzer/ntopng/Manifest
@@ -1,2 +1,3 @@
DIST ntopng-2.4.tar.gz 134074662 BLAKE2B dbf654e5cd1f9eddb5ae325bdf0ac2e7ce22c08f55363b10723bde2cb5fd86cf3b0c7fef0f55dc7fcce0341f5fbb9a7132f26e29649bcf66020b640975c0e6da SHA512 515dd7889ae3aaf2482371bb2c55ab7300cf4207fe07f37029b7529bfb710379c19a54f58cf6df87e42454c0c99d15291af334adff676252301d9edd0acf3c7a
DIST ntopng-3.0.tar.gz 23017655 BLAKE2B f791690118a5ecfb1be5ad791229f2438354a0c2271350aa1a2f0fee05886c54d181a669e6e1b27657c5bfe4b68db24b06d91adfb89e803a154a7a4bbff146b7 SHA512 d5e310d5dba7fe696d38d9d8251ffa4077182200e41c3f0b6034e68cf6623220ec47ba9d9fd5d2392a7b65a6de770e330821169c7ec06b4952f68c3f5f738eb1
+DIST ntopng-3.8.tar.gz 33910329 BLAKE2B a5aaed2244516b92e4b8c7364817ea66eb2f446fe814a96622cbbf5d851d79e8049b75da009d0f80f07c1fae90f8dc294794b76ed14450d8e0e6685a1b1ce8f2 SHA512 2236f9931fc606e4d0a6da379c480a48bacd441cf199a310ea690a03d74d08f369825ea02e3c13828a10f716a5531d4e6774876f253ab348a52bcf8bd8d5107f
diff --git a/net-analyzer/ntopng/files/ntopng-3.8-missing-min.patch b/net-analyzer/ntopng/files/ntopng-3.8-missing-min.patch
new file mode 100644
index 000000000000..303826a918df
--- /dev/null
+++ b/net-analyzer/ntopng/files/ntopng-3.8-missing-min.patch
@@ -0,0 +1,19 @@
+--- a/third-party/zeromq-4.1.3/src/tcp_connecter.cpp
++++ b/third-party/zeromq-4.1.3/src/tcp_connecter.cpp
+@@ -31,6 +31,7 @@
+
+ #include <new>
+ #include <string>
++#include <algorithm>
+
+ #include "tcp_connecter.hpp"
+ #include "stream_engine.hpp"
+@@ -207,7 +208,7 @@
+ options.reconnect_ivl_max > options.reconnect_ivl)
+ // Calculate the next interval
+ current_reconnect_ivl =
+- min (current_reconnect_ivl * 2, options.reconnect_ivl_max);
++ std::min(current_reconnect_ivl * 2, options.reconnect_ivl_max);
+ return interval;
+ }
+
diff --git a/net-analyzer/ntopng/files/ntopng-3.8-mysqltool.patch b/net-analyzer/ntopng/files/ntopng-3.8-mysqltool.patch
new file mode 100644
index 000000000000..62c328a3505e
--- /dev/null
+++ b/net-analyzer/ntopng/files/ntopng-3.8-mysqltool.patch
@@ -0,0 +1,17 @@
+--- a/configure.seed
++++ b/configure.seed
+@@ -355,13 +355,7 @@
+ if test "x$ac_cv_prog_ac_ct_MARIADB" = "xmariadb_config"; then
+ MYSQLTOOL="mariadb_config"
+ else
+- PATH=$PATH:/usr/local/mysql/bin
+- AC_CHECK_TOOL(MYSQL, mysql_config)
+- if test "x$ac_cv_prog_ac_ct_MYSQL" = "xmysql_config"; then
+- MYSQLTOOL="mysql_config"
+- else
+- MYSQLTOOL=""
+- fi
++ MYSQLTOOL="mysql_config"
+ fi
+
+ if test -n "$MYSQLTOOL"; then
diff --git a/net-analyzer/ntopng/files/ntopng-3.8-ndpi-call.patch b/net-analyzer/ntopng/files/ntopng-3.8-ndpi-call.patch
new file mode 100644
index 000000000000..1308a5c2c03f
--- /dev/null
+++ b/net-analyzer/ntopng/files/ntopng-3.8-ndpi-call.patch
@@ -0,0 +1,12 @@
+--- a/src/NetworkInterface.cpp
++++ b/src/NetworkInterface.cpp
+@@ -1604,7 +1604,8 @@
+ ndpi_protocol icmp_proto = flow->get_detected_protocol();
+
+ if(icmp_proto.category == NDPI_PROTOCOL_CATEGORY_UNSPECIFIED) {
+- ndpi_fill_ip_protocol_category(ndpi_struct, (struct ndpi_iphdr *)ip, &icmp_proto);
++ ndpi_fill_ip_protocol_category(ndpi_struct, ((struct ndpi_iphdr *)ip)->saddr,
++ ((struct ndpi_iphdr*)ip)->daddr, &icmp_proto);
+ flow->setDetectedProtocol(icmp_proto, false);
+ }
+ }
diff --git a/net-analyzer/ntopng/files/ntopng-3.8-ndpi-includes.patch b/net-analyzer/ntopng/files/ntopng-3.8-ndpi-includes.patch
new file mode 100644
index 000000000000..068f1e9fa9b9
--- /dev/null
+++ b/net-analyzer/ntopng/files/ntopng-3.8-ndpi-includes.patch
@@ -0,0 +1,14 @@
+--- a/configure.seed 2018-10-08 21:33:09.403001834 -0600
++++ b/configure.seed 2018-10-08 21:35:47.404002203 -0600
+@@ -129,9 +129,9 @@
+ fi
+
+ PKG_CHECK_MODULES([NDPI], [libndpi >= 2.0], [
+- NDPI_INC=`echo $NDPI_CFLAGS | sed -e "s/[ ]*$//"`/libndpi
++ NDPI_INC=`echo $NDPI_CFLAGS | sed -e "s/[ ]*$//"`
+ # Use static libndpi library as building against the dynamic library fails
+- NDPI_LIB="-Wl,-Bstatic $NDPI_LIBS -Wl,-Bdynamic"
++ NDPI_LIB="$NDPI_LIBS"
+ NDPI_LIB_DEP=
+ ], [
+ AC_MSG_CHECKING(for nDPI source)
diff --git a/net-analyzer/ntopng/ntopng-3.8.ebuild b/net-analyzer/ntopng/ntopng-3.8.ebuild
new file mode 100644
index 000000000000..8a3edd124180
--- /dev/null
+++ b/net-analyzer/ntopng/ntopng-3.8.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools user toolchain-funcs
+
+DESCRIPTION="Network traffic analyzer with web interface"
+HOMEPAGE="https://www.ntop.org/"
+SRC_URI="https://github.com/ntop/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+DEPEND="dev-db/sqlite:3
+ dev-python/pyzmq
+ dev-lang/luajit:2
+ dev-libs/json-c:=
+ dev-libs/geoip
+ dev-libs/glib:2
+ dev-libs/hiredis
+ dev-libs/libsodium:=
+ dev-libs/libxml2
+ dev-libs/libmaxminddb
+ net-analyzer/rrdtool
+ net-libs/libpcap
+ >=net-libs/nDPI-2.4
+ net-misc/curl
+ sys-libs/binutils-libs
+ virtual/libmysqlclient"
+RDEPEND="${DEPEND}
+ dev-db/redis"
+PATCHES=(
+ "${FILESDIR}"/${P}-mysqltool.patch
+ "${FILESDIR}"/${P}-ndpi-includes.patch
+ "${FILESDIR}"/${P}-missing-min.patch
+ "${FILESDIR}"/${P}-ndpi-call.patch
+)
+
+src_prepare() {
+ default
+ sed -e "s/@VERSION@/${PV}/g" -e "s/@SHORT_VERSION@/${PV}/g" < "${S}/configure.seed" > "${S}/configure.ac" > configure.ac
+ eapply_user
+ eautoreconf
+}
+
+src_install() {
+ SHARE_NTOPNG_DIR="${EPREFIX}/usr/share/${PN}"
+ dodir ${SHARE_NTOPNG_DIR}
+ insinto ${SHARE_NTOPNG_DIR}
+ doins -r httpdocs
+ doins -r scripts
+
+ dodir ${SHARE_NTOPNG_DIR}/third-party
+ insinto ${SHARE_NTOPNG_DIR}/third-party
+ doins -r third-party/i18n.lua-master
+ doins -r third-party/lua-resty-template-master
+
+ exeinto /usr/bin
+ doexe ${PN}
+ doman ${PN}.8
+
+ newinitd "${FILESDIR}/ntopng.init.d" ntopng
+ newconfd "${FILESDIR}/ntopng.conf.d" ntopng
+
+ dodir "/var/lib/ntopng"
+ fowners ntopng "${EPREFIX}/var/lib/ntopng"
+}
+
+pkg_setup() {
+ enewuser ntopng
+}
+
+pkg_postinst() {
+ elog "ntopng default credentials are user='admin' password='admin'"
+}