summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-01-01 14:47:37 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2020-01-01 14:50:45 +0100
commit49611aa58c65f16f3252421baf3bf548a5ae02a7 (patch)
tree276acf6831345cdb6ed0209987625e00613e18b0 /net-analyzer/openvas-scanner
parentacct-user/geneweb: remove default shell (diff)
downloadgentoo-49611aa58c65f16f3252421baf3bf548a5ae02a7.tar.gz
gentoo-49611aa58c65f16f3252421baf3bf548a5ae02a7.tar.bz2
gentoo-49611aa58c65f16f3252421baf3bf548a5ae02a7.zip
net-analyzer: Switch hsntgm's packages to cmake.eclass
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'net-analyzer/openvas-scanner')
-rw-r--r--net-analyzer/openvas-scanner/openvas-scanner-6.0.1.ebuild18
1 files changed, 9 insertions, 9 deletions
diff --git a/net-analyzer/openvas-scanner/openvas-scanner-6.0.1.ebuild b/net-analyzer/openvas-scanner/openvas-scanner-6.0.1.ebuild
index b1ba0ec555db..aeedaa6e04f9 100644
--- a/net-analyzer/openvas-scanner/openvas-scanner-6.0.1.ebuild
+++ b/net-analyzer/openvas-scanner/openvas-scanner-6.0.1.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
CMAKE_MAKEFILE_GENERATOR="emake"
-inherit cmake-utils flag-o-matic systemd toolchain-funcs
+inherit cmake flag-o-matic systemd toolchain-funcs
MY_PN="openvas"
MY_DN="openvassd"
@@ -53,7 +53,7 @@ PATCHES=(
)
src_prepare() {
- cmake-utils_src_prepare
+ cmake_src_prepare
# QA-Fix | Correct FHS/Gentoo policy paths for 6.0.1
sed -i -e "s*/doc/openvas-scanner/*/doc/openvas-scanner-${PV}/*g" "$S"/src/CMakeLists.txt || die
# QA-Fix | Remove !CLANG doxygen warnings for 6.0.1
@@ -80,21 +80,21 @@ src_configure() {
# Add release hardening flags for 6.0.1
append-cflags -Wno-format-truncation -Wformat -Wformat-security -D_FORTIFY_SOURCE=2 -fstack-protector
append-ldflags -Wl,-z,relro -Wl,-z,now
- cmake-utils_src_configure
+ cmake_src_configure
}
src_compile() {
- cmake-utils_src_compile
+ cmake_src_compile
if use extras; then
- cmake-utils_src_make -C "${BUILD_DIR}" doc
- cmake-utils_src_make doc-full -C "${BUILD_DIR}" doc
+ cmake_build -C "${BUILD_DIR}" doc
+ cmake_build doc-full -C "${BUILD_DIR}" doc
HTML_DOCS=( "${BUILD_DIR}"/doc/generated/html/. )
fi
- cmake-utils_src_make rebuild_cache
+ cmake_build rebuild_cache
}
src_install() {
- cmake-utils_src_install
+ cmake_src_install
dodir /etc/openvas
insinto /etc/openvas