summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/openvas
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/openvas')
-rw-r--r--net-analyzer/openvas/files/README.gentoo34
-rw-r--r--net-analyzer/openvas/metadata.xml13
-rw-r--r--net-analyzer/openvas/openvas-7.0.10.ebuild44
-rw-r--r--net-analyzer/openvas/openvas-7.0.11.ebuild44
-rw-r--r--net-analyzer/openvas/openvas-8.0.3.ebuild44
-rw-r--r--net-analyzer/openvas/openvas-8.0.4.ebuild44
6 files changed, 223 insertions, 0 deletions
diff --git a/net-analyzer/openvas/files/README.gentoo b/net-analyzer/openvas/files/README.gentoo
new file mode 100644
index 000000000000..71dbf185b472
--- /dev/null
+++ b/net-analyzer/openvas/files/README.gentoo
@@ -0,0 +1,34 @@
+To allow openvasmd to work, you need to do the following
+
+# Generate a Server Certificate
+openvas-mkcert
+
+# Generate a Client Certificate
+openvas-mkcert-client -n -i
+
+# get nvt feed
+openvas-nvt-sync (free) or greenbone-nvt-sync (commercial)
+
+# get scap feed
+openvas-scapdata-sync (free) or greenbone-scapdata-sync (commercial)
+
+# get cert feed
+openvas-certdata-sync (free) or greenbone-certdata-sync (commercial)
+
+# Generate initial NVT cache (takes some minutes)
+rc-service openvassd create_cache or openvassd --foreground --only-cache
+
+# Start the OpenVAS Scanner
+rc-service openvassd start or systemctl start openvassd.service
+
+# Initialize the Database (This is going to take some time, perhaps time to get coffee?)
+openvasmd --rebuild --progress -v
+
+# Create an admin user and note down the initial password
+openvasmd --create-user=admin --role=Admin
+
+# Start the OpenVAS Manager
+rc-service openvasmd start or systemctl start openvasmd
+
+# Start the Greenbone Security Assistant
+rc-service gsad start or systemctl start gsad
diff --git a/net-analyzer/openvas/metadata.xml b/net-analyzer/openvas/metadata.xml
new file mode 100644
index 000000000000..cc63063afac4
--- /dev/null
+++ b/net-analyzer/openvas/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>hanno@gentoo.org</email>
+ </maintainer>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <use>
+ <flag name="pdf">Enable pdf report creation</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-analyzer/openvas/openvas-7.0.10.ebuild b/net-analyzer/openvas/openvas-7.0.10.ebuild
new file mode 100644
index 000000000000..9a4373914a35
--- /dev/null
+++ b/net-analyzer/openvas/openvas-7.0.10.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo
+
+DESCRIPTION="A remote security scanner"
+HOMEPAGE="http://www.openvas.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+pdf"
+
+DEPEND="
+ >=net-analyzer/openvas-libraries-7.0.10
+ >=net-analyzer/openvas-scanner-4.0.6
+ >=net-analyzer/openvas-manager-5.0.10
+ >=net-analyzer/openvas-cli-1.3.1
+ net-analyzer/openvas-tools
+ pdf? (
+ app-text/htmldoc
+ dev-texlive/texlive-latexextra
+ virtual/latex-base
+ )"
+# greenbone-security-desktop is broken and unsupported upstream
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+pkg_postinst() {
+ elog "Additional support for extra checks can be get from"
+ optfeature "Nikto — a web server scanning and testing tool" net-analyzer/nikto
+ optfeature "NMAP — a portscanner" net-analyzer/nmap
+ optfeature "ike-scan - an IPsec VPN scanning, fingerprinting and testing tool" net-analyzer/ike-scan
+ optfeature "amap — an application protocol detection tool" net-analyzer/amap
+ optfeature "ldapsearch from OpenLDAP utilities — retrieves information from LDAP dictionaries" net-nds/openldap
+ optfeature "ovaldi (OVAL) — an OVAL Interpreter" app-forensics/ovaldi
+ optfeature "portbunny — a Linux-kernel-based portscanner" net-analyzer/portbunny
+ optfeature "w3af — a web application attack and audit framework" net-analyzer/w3af
+ optfeature "The Greenbone Security Assistant as alternative to the plain scanner" net-analyzer/greenbone-security-assistant
+}
diff --git a/net-analyzer/openvas/openvas-7.0.11.ebuild b/net-analyzer/openvas/openvas-7.0.11.ebuild
new file mode 100644
index 000000000000..f7fcb2fe4b75
--- /dev/null
+++ b/net-analyzer/openvas/openvas-7.0.11.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo
+
+DESCRIPTION="A remote security scanner"
+HOMEPAGE="http://www.openvas.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+pdf"
+
+DEPEND="
+ >=net-analyzer/openvas-libraries-7.0.10
+ >=net-analyzer/openvas-scanner-4.0.7
+ >=net-analyzer/openvas-manager-5.0.11
+ >=net-analyzer/openvas-cli-1.3.1
+ net-analyzer/openvas-tools
+ pdf? (
+ app-text/htmldoc
+ dev-texlive/texlive-latexextra
+ virtual/latex-base
+ )"
+# greenbone-security-desktop is broken and unsupported upstream
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+pkg_postinst() {
+ elog "Additional support for extra checks can be get from"
+ optfeature "Nikto — a web server scanning and testing tool" net-analyzer/nikto
+ optfeature "NMAP — a portscanner" net-analyzer/nmap
+ optfeature "ike-scan - an IPsec VPN scanning, fingerprinting and testing tool" net-analyzer/ike-scan
+ optfeature "amap — an application protocol detection tool" net-analyzer/amap
+ optfeature "ldapsearch from OpenLDAP utilities — retrieves information from LDAP dictionaries" net-nds/openldap
+ optfeature "ovaldi (OVAL) — an OVAL Interpreter" app-forensics/ovaldi
+ optfeature "portbunny — a Linux-kernel-based portscanner" net-analyzer/portbunny
+ optfeature "w3af — a web application attack and audit framework" net-analyzer/w3af
+ optfeature "The Greenbone Security Assistant as alternative to the plain scanner" net-analyzer/greenbone-security-assistant
+}
diff --git a/net-analyzer/openvas/openvas-8.0.3.ebuild b/net-analyzer/openvas/openvas-8.0.3.ebuild
new file mode 100644
index 000000000000..18539bc803b5
--- /dev/null
+++ b/net-analyzer/openvas/openvas-8.0.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo
+
+DESCRIPTION="A remote security scanner"
+HOMEPAGE="http://www.openvas.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="+pdf"
+
+DEPEND="
+ >=net-analyzer/openvas-libraries-8.0.3
+ >=net-analyzer/openvas-scanner-5.0.3
+ >=net-analyzer/openvas-manager-6.0.3
+ >=net-analyzer/openvas-cli-1.4.0
+ net-analyzer/openvas-tools
+ pdf? (
+ app-text/htmldoc
+ dev-texlive/texlive-latexextra
+ virtual/latex-base
+ )"
+# greenbone-security-desktop is broken and unsupported upstream
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+pkg_postinst() {
+ elog "Additional support for extra checks can be get from"
+ optfeature "Nikto — a web server scanning and testing tool" net-analyzer/nikto
+ optfeature "NMAP — a portscanner" net-analyzer/nmap
+ optfeature "ike-scan - an IPsec VPN scanning, fingerprinting and testing tool" net-analyzer/ike-scan
+ optfeature "amap — an application protocol detection tool" net-analyzer/amap
+ optfeature "ldapsearch from OpenLDAP utilities — retrieves information from LDAP dictionaries" net-nds/openldap
+ optfeature "ovaldi (OVAL) — an OVAL Interpreter" app-forensics/ovaldi
+ optfeature "portbunny — a Linux-kernel-based portscanner" net-analyzer/portbunny
+ optfeature "w3af — a web application attack and audit framework" net-analyzer/w3af
+ optfeature "The Greenbone Security Assistant as alternative to the plain scanner" net-analyzer/greebone-security-assistant
+}
diff --git a/net-analyzer/openvas/openvas-8.0.4.ebuild b/net-analyzer/openvas/openvas-8.0.4.ebuild
new file mode 100644
index 000000000000..edd5f44da525
--- /dev/null
+++ b/net-analyzer/openvas/openvas-8.0.4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit readme.gentoo
+
+DESCRIPTION="A remote security scanner"
+HOMEPAGE="http://www.openvas.org/"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS=" ~amd64 ~x86"
+IUSE="+pdf"
+
+DEPEND="
+ >=net-analyzer/openvas-libraries-8.0.4
+ >=net-analyzer/openvas-scanner-5.0.4
+ >=net-analyzer/openvas-manager-6.0.4
+ >=net-analyzer/openvas-cli-1.4.2
+ net-analyzer/openvas-tools
+ pdf? (
+ app-text/htmldoc
+ dev-texlive/texlive-latexextra
+ virtual/latex-base
+ )"
+# greenbone-security-desktop is broken and unsupported upstream
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}"
+
+pkg_postinst() {
+ elog "Additional support for extra checks can be get from"
+ optfeature "Nikto — a web server scanning and testing tool" net-analyzer/nikto
+ optfeature "NMAP — a portscanner" net-analyzer/nmap
+ optfeature "ike-scan - an IPsec VPN scanning, fingerprinting and testing tool" net-analyzer/ike-scan
+ optfeature "amap — an application protocol detection tool" net-analyzer/amap
+ optfeature "ldapsearch from OpenLDAP utilities — retrieves information from LDAP dictionaries" net-nds/openldap
+ optfeature "ovaldi (OVAL) — an OVAL Interpreter" app-forensics/ovaldi
+ optfeature "portbunny — a Linux-kernel-based portscanner" net-analyzer/portbunny
+ optfeature "w3af — a web application attack and audit framework" net-analyzer/w3af
+ optfeature "The Greenbone Security Assistant as alternative to the plain scanner" net-analyzer/greebone-security-assistant
+}