summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-01-15 12:31:17 -0500
committerZero_Chaos <zerochaos@gentoo.org>2018-01-15 12:31:33 -0500
commitfb9a37adac6db645eaa9b788184ca1e41b983153 (patch)
treeda4af756ed75c8c1c58fb8cc0d59d7a4ce9b0b9e /net-analyzer/ostinato
parentnet-libs/libpcap: import fix from debian for bug#602098 (diff)
downloadgentoo-fb9a37adac6db645eaa9b788184ca1e41b983153.tar.gz
gentoo-fb9a37adac6db645eaa9b788184ca1e41b983153.tar.bz2
gentoo-fb9a37adac6db645eaa9b788184ca1e41b983153.zip
net-analyzer/ostinato: bump and bug #602098
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-analyzer/ostinato')
-rw-r--r--net-analyzer/ostinato/Manifest1
-rw-r--r--net-analyzer/ostinato/ostinato-0.9.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/net-analyzer/ostinato/Manifest b/net-analyzer/ostinato/Manifest
index c4a288492383..3a6268e8809f 100644
--- a/net-analyzer/ostinato/Manifest
+++ b/net-analyzer/ostinato/Manifest
@@ -1,2 +1,3 @@
DIST ostinato-0.8.tar.gz 424104 BLAKE2B 5244ac9577da3fc99b714044a349e4003f0e64034fad04e241b43288a234f86f282ba0169c7e27c358d7ee3f4dc255b2408ef23f030d25f1edfec891e8ae17f7 SHA512 ecb3581736bd8dff44fe21082c270febc2ead4530cfb57997f218bd0b61a85993208937729374dd09c67fdc24eb2b9adfe5b3750ee6daef90b1e7dac2ea0737b
+DIST ostinato-0.9.tar.gz 413756 BLAKE2B cc1cb6d4db614b1968c27d7cdbebb977f39e6be8ec1a39b08f7e34d9a1a4d6b7c0c034f245b6b562c72b5dbdba9fc04c03b1cfc0c01044c249bcc2bc67af357d SHA512 a50f6e20d8a2a4d76ca43a89feaa774778981377ce1f4c731ad8b1a97aa658013082fb85cc3f4dfdd888d708c45c8093e55facaa7f02cecbd2ce5228f57e2e14
DIST ostinato-src-0.5.1.tar.gz 291529 BLAKE2B 207a3b423040e82042e7e68e2c7ffaf304a0c7e7d1578a994caf090ee934e10f169b9fce96724c0527268fb9f656b25bf3baa19b5f1ab6a06ffc2b8925b1c952 SHA512 d06b59dc2129aba01e5a42a677339d6e8f353f9c7c027226e66c8a5af94ecb48e8450e7770ae5e179131fa4cfeefcc827fb9a18be4294ddfcd7a471ec26ee06a
diff --git a/net-analyzer/ostinato/ostinato-0.9.ebuild b/net-analyzer/ostinato/ostinato-0.9.ebuild
new file mode 100644
index 000000000000..fa2db04b283b
--- /dev/null
+++ b/net-analyzer/ostinato/ostinato-0.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit qmake-utils
+
+DESCRIPTION="A packet generator and analyzer"
+HOMEPAGE="http://ostinato.org/"
+SRC_URI="https://github.com/pstavirs/ostinato/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE=""
+
+#https://github.com/pstavirs/ostinato/issues/173
+# libpcap dep is versioned to pull in the fix for #602098
+DEPEND="dev-libs/protobuf:=
+ >=net-libs/libpcap-1.8.1-r2
+ dev-qt/qtscript:4
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4"
+RDEPEND="${DEPEND}"
+
+src_configure(){
+ eqmake4 PREFIX="${ED}/usr" ost.pro
+}