summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/pinger
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/pinger')
-rw-r--r--net-analyzer/pinger/Manifest2
-rw-r--r--net-analyzer/pinger/files/gtk-2.0.m4196
-rw-r--r--net-analyzer/pinger/files/pinger-0.32e-tinfo.patch21
-rw-r--r--net-analyzer/pinger/files/pinger-0.33-gentoo.patch73
-rw-r--r--net-analyzer/pinger/metadata.xml9
-rw-r--r--net-analyzer/pinger/pinger-0.32e.ebuild49
-rw-r--r--net-analyzer/pinger/pinger-0.33.ebuild59
7 files changed, 409 insertions, 0 deletions
diff --git a/net-analyzer/pinger/Manifest b/net-analyzer/pinger/Manifest
new file mode 100644
index 000000000000..6dce048bcadb
--- /dev/null
+++ b/net-analyzer/pinger/Manifest
@@ -0,0 +1,2 @@
+DIST pinger-0.32e.tar.gz 239002 SHA256 73edc85b1b45d6f7721e619b62e4dc7303306297a90f2ffd292d7fe9578321b2 SHA512 8a6cebe9b37399e2e84eead3b386b999212904ecffb1fc951b4165295b278690217f35d20830e1f1440b94567d9d5d3423d37ee6e9200173be9aacefb68a87f7 WHIRLPOOL 08c2549c4d8361cc5dd97fe2498769b9c40f59b574bd04d40c6d1183699fa535c23388ff3de6f41f92faa19f9a62e36a58f46acaf06d3a1e1a6d5a18f31f80d6
+DIST pinger-0.33.tar.gz 247827 SHA256 c092f972529f1038b6eac87195b87c2a308891db7f1db18b1a8cbe0df84b6569 SHA512 fff07599ef91fbdcff9be7806eca57a71e8e6fac7e9afc67c4147e6246b0bcdadf379de28f87054dbe7c409955c0e0ddeae7f529e954231bea0cfb39e4e29bc1 WHIRLPOOL e16f1eb1d7dc9f26a7eea7f6b47971388243cfee5d35557c24483c610c1292640c1068fda9ae34b575ec324ffe309ed2d4b67a696c227c3485cd0cb3d0ac7c68
diff --git a/net-analyzer/pinger/files/gtk-2.0.m4 b/net-analyzer/pinger/files/gtk-2.0.m4
new file mode 100644
index 000000000000..88596a969e19
--- /dev/null
+++ b/net-analyzer/pinger/files/gtk-2.0.m4
@@ -0,0 +1,196 @@
+# Configure paths for GTK+
+# Owen Taylor 1997-2001
+
+dnl AM_PATH_GTK_2_0([MINIMUM-VERSION, [ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND [, MODULES]]]])
+dnl Test for GTK+, and define GTK_CFLAGS and GTK_LIBS, if gthread is specified in MODULES,
+dnl pass to pkg-config
+dnl
+AC_DEFUN([AM_PATH_GTK_2_0],
+[dnl
+dnl Get the cflags and libraries from pkg-config
+dnl
+AC_ARG_ENABLE(gtktest, [ --disable-gtktest do not try to compile and run a test GTK+ program],
+ , enable_gtktest=yes)
+
+ pkg_config_args=gtk+-2.0
+ for module in . $4
+ do
+ case "$module" in
+ gthread)
+ pkg_config_args="$pkg_config_args gthread-2.0"
+ ;;
+ esac
+ done
+
+ no_gtk=""
+
+ AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
+
+ if test x$PKG_CONFIG != xno ; then
+ if pkg-config --atleast-pkgconfig-version 0.7 ; then
+ :
+ else
+ echo "*** pkg-config too old; version 0.7 or better required."
+ no_gtk=yes
+ PKG_CONFIG=no
+ fi
+ else
+ no_gtk=yes
+ fi
+
+ min_gtk_version=ifelse([$1], ,2.0.0,$1)
+ AC_MSG_CHECKING(for GTK+ - version >= $min_gtk_version)
+
+ if test x$PKG_CONFIG != xno ; then
+ ## don't try to run the test against uninstalled libtool libs
+ if $PKG_CONFIG --uninstalled $pkg_config_args; then
+ echo "Will use uninstalled version of GTK+ found in PKG_CONFIG_PATH"
+ enable_gtktest=no
+ fi
+
+ if $PKG_CONFIG --atleast-version $min_gtk_version $pkg_config_args; then
+ :
+ else
+ no_gtk=yes
+ fi
+ fi
+
+ if test x"$no_gtk" = x ; then
+ GTK_CFLAGS=`$PKG_CONFIG $pkg_config_args --cflags`
+ GTK_LIBS=`$PKG_CONFIG $pkg_config_args --libs`
+ gtk_config_major_version=`$PKG_CONFIG --modversion gtk+-2.0 | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\1/'`
+ gtk_config_minor_version=`$PKG_CONFIG --modversion gtk+-2.0 | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\2/'`
+ gtk_config_micro_version=`$PKG_CONFIG --modversion gtk+-2.0 | \
+ sed 's/\([[0-9]]*\).\([[0-9]]*\).\([[0-9]]*\)/\3/'`
+ if test "x$enable_gtktest" = "xyes" ; then
+ ac_save_CFLAGS="$CFLAGS"
+ ac_save_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $GTK_CFLAGS"
+ LIBS="$GTK_LIBS $LIBS"
+dnl
+dnl Now check if the installed GTK+ is sufficiently new. (Also sanity
+dnl checks the results of pkg-config to some extent)
+dnl
+ rm -f conf.gtktest
+ AC_TRY_RUN([
+#include <gtk/gtk.h>
+#include <stdio.h>
+#include <stdlib.h>
+
+int
+main ()
+{
+ int major, minor, micro;
+ char *tmp_version;
+
+ fclose (fopen ("conf.gtktest", "w"));
+
+ /* HP/UX 9 (%@#!) writes to sscanf strings */
+ tmp_version = g_strdup("$min_gtk_version");
+ if (sscanf(tmp_version, "%d.%d.%d", &major, &minor, &micro) != 3) {
+ printf("%s, bad version string\n", "$min_gtk_version");
+ exit(1);
+ }
+
+ if ((gtk_major_version != $gtk_config_major_version) ||
+ (gtk_minor_version != $gtk_config_minor_version) ||
+ (gtk_micro_version != $gtk_config_micro_version))
+ {
+ printf("\n*** 'pkg-config --modversion gtk+-2.0' returned %d.%d.%d, but GTK+ (%d.%d.%d)\n",
+ $gtk_config_major_version, $gtk_config_minor_version, $gtk_config_micro_version,
+ gtk_major_version, gtk_minor_version, gtk_micro_version);
+ printf ("*** was found! If pkg-config was correct, then it is best\n");
+ printf ("*** to remove the old version of GTK+. You may also be able to fix the error\n");
+ printf("*** by modifying your LD_LIBRARY_PATH enviroment variable, or by editing\n");
+ printf("*** /etc/ld.so.conf. Make sure you have run ldconfig if that is\n");
+ printf("*** required on your system.\n");
+ printf("*** If pkg-config was wrong, set the environment variable PKG_CONFIG_PATH\n");
+ printf("*** to point to the correct configuration files\n");
+ }
+ else if ((gtk_major_version != GTK_MAJOR_VERSION) ||
+ (gtk_minor_version != GTK_MINOR_VERSION) ||
+ (gtk_micro_version != GTK_MICRO_VERSION))
+ {
+ printf("*** GTK+ header files (version %d.%d.%d) do not match\n",
+ GTK_MAJOR_VERSION, GTK_MINOR_VERSION, GTK_MICRO_VERSION);
+ printf("*** library (version %d.%d.%d)\n",
+ gtk_major_version, gtk_minor_version, gtk_micro_version);
+ }
+ else
+ {
+ if ((gtk_major_version > major) ||
+ ((gtk_major_version == major) && (gtk_minor_version > minor)) ||
+ ((gtk_major_version == major) && (gtk_minor_version == minor) && (gtk_micro_version >= micro)))
+ {
+ return 0;
+ }
+ else
+ {
+ printf("\n*** An old version of GTK+ (%d.%d.%d) was found.\n",
+ gtk_major_version, gtk_minor_version, gtk_micro_version);
+ printf("*** You need a version of GTK+ newer than %d.%d.%d. The latest version of\n",
+ major, minor, micro);
+ printf("*** GTK+ is always available from ftp://ftp.gtk.org.\n");
+ printf("***\n");
+ printf("*** If you have already installed a sufficiently new version, this error\n");
+ printf("*** probably means that the wrong copy of the pkg-config shell script is\n");
+ printf("*** being found. The easiest way to fix this is to remove the old version\n");
+ printf("*** of GTK+, but you can also set the PKG_CONFIG environment to point to the\n");
+ printf("*** correct copy of pkg-config. (In this case, you will have to\n");
+ printf("*** modify your LD_LIBRARY_PATH enviroment variable, or edit /etc/ld.so.conf\n");
+ printf("*** so that the correct libraries are found at run-time))\n");
+ }
+ }
+ return 1;
+}
+],, no_gtk=yes,[echo $ac_n "cross compiling; assumed OK... $ac_c"])
+ CFLAGS="$ac_save_CFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+ fi
+ if test "x$no_gtk" = x ; then
+ AC_MSG_RESULT(yes (version $gtk_config_major_version.$gtk_config_minor_version.$gtk_config_micro_version))
+ ifelse([$2], , :, [$2])
+ else
+ AC_MSG_RESULT(no)
+ if test "$PKG_CONFIG" = "no" ; then
+ echo "*** A new enough version of pkg-config was not found."
+ echo "*** See http://pkgconfig.sourceforge.net"
+ else
+ if test -f conf.gtktest ; then
+ :
+ else
+ echo "*** Could not run GTK+ test program, checking why..."
+ ac_save_CFLAGS="$CFLAGS"
+ ac_save_LIBS="$LIBS"
+ CFLAGS="$CFLAGS $GTK_CFLAGS"
+ LIBS="$LIBS $GTK_LIBS"
+ AC_TRY_LINK([
+#include <gtk/gtk.h>
+#include <stdio.h>
+], [ return ((gtk_major_version) || (gtk_minor_version) || (gtk_micro_version)); ],
+ [ echo "*** The test program compiled, but did not run. This usually means"
+ echo "*** that the run-time linker is not finding GTK+ or finding the wrong"
+ echo "*** version of GTK+. If it is not finding GTK+, you'll need to set your"
+ echo "*** LD_LIBRARY_PATH environment variable, or edit /etc/ld.so.conf to point"
+ echo "*** to the installed location Also, make sure you have run ldconfig if that"
+ echo "*** is required on your system"
+ echo "***"
+ echo "*** If you have an old version installed, it is best to remove it, although"
+ echo "*** you may also be able to get things to work by modifying LD_LIBRARY_PATH" ],
+ [ echo "*** The test program failed to compile or link. See the file config.log for the"
+ echo "*** exact error that occured. This usually means GTK+ is incorrectly installed."])
+ CFLAGS="$ac_save_CFLAGS"
+ LIBS="$ac_save_LIBS"
+ fi
+ fi
+ GTK_CFLAGS=""
+ GTK_LIBS=""
+ ifelse([$3], , :, [$3])
+ fi
+ AC_SUBST(GTK_CFLAGS)
+ AC_SUBST(GTK_LIBS)
+ rm -f conf.gtktest
+])
diff --git a/net-analyzer/pinger/files/pinger-0.32e-tinfo.patch b/net-analyzer/pinger/files/pinger-0.32e-tinfo.patch
new file mode 100644
index 000000000000..f9175b22540f
--- /dev/null
+++ b/net-analyzer/pinger/files/pinger-0.32e-tinfo.patch
@@ -0,0 +1,21 @@
+--- a/configure.in
++++ b/configure.in
+@@ -65,8 +65,18 @@
+ AC_DEFINE([HAVE_GTK_2], 1, Found GTK 2),
+ HAVE_GTK_2=0)
+ fi
++AC_ARG_ENABLE(ncurses, [ --enable-ncurses enable ncurses support],
++ [if test "$enableval" = no; then no_ncurses=yes; fi])
++if test x$no_ncurses != xyes; then
++PKG_CHECK_MODULES(ncurses, ncurses,[
++ AC_DEFINE([HAVE_LIBNCURSES], [1], found ncurses library)
++ HAVE_CURSES=1
++ LIBS="$LIBS $ncurses_LIBS"
++ CFLAGS="$CFLAGS $ncurses_CFLAGS"],
+ AC_CHECK_LIB(ncurses, initscr, HAVE_CURSES=1; LIBS="$LIBS -lncurses";
+ AC_DEFINE([HAVE_LIBNCURSES], [1], found ncurses library))
++ )
++fi
+ AC_CHECK_LIB(intl, libintl_gettext, LIBS="$LIBS -lintl")
+ AC_CHECK_LIB(pthread, pthread_create, LIBS="$LIBS -lpthread", AC_MSG_ERROR(Pthread required and not found. Please check if you have libpthread in your system and specify using CFLAGS and LDFLAGS when configure))
+
diff --git a/net-analyzer/pinger/files/pinger-0.33-gentoo.patch b/net-analyzer/pinger/files/pinger-0.33-gentoo.patch
new file mode 100644
index 000000000000..76ef052a4a2d
--- /dev/null
+++ b/net-analyzer/pinger/files/pinger-0.33-gentoo.patch
@@ -0,0 +1,73 @@
+--- a/src/Makefile.am
++++ b/src/Makefile.am
+@@ -2,7 +2,12 @@
+
+ bin_PROGRAMS = pinger
+ man_MANS = pinger.1
++if HAVE_GTK_2
+ bin_SCRIPTS = gtkpinger
++endif
++if HAVE_GTK_3
++bin_SCRIPTS = gtkpinger
++endif
+
+ P_SOURCES = timefunc.c parse.c ping.c pinger.c dns.c log.c timefunc.h parse.h ping.h globals.h fake_gtk.h dns.h log.h
+ if HAVE_CURSES
+--- a/configure.in
++++ b/configure.in
+@@ -54,34 +54,46 @@
+ AC_HEADER_TIME
+ AM_INADDRT
+
++PKG_PROG_PKG_CONFIG()
++
+ dnl GTK3/GTK2 tests
+ dnl Note: PKG_CHECK_MODULES cannot be used conditionaly due to sharing the tests and depending on it
+ AC_ARG_ENABLE([gtk], AS_HELP_STRING([--enable-gtk[[[=version]]]], [Build with GTK+ interface. Supported versions are gtk2 and gtk3. Default is gtk2.]))
+-PKG_CHECK_MODULES(GTK, [ gtk+-2.0 >= 2.4 ], HAVE_GTK_2=1; )
+-AC_SUBST(GTK_CFLAGS)
+-AC_SUBST(GTK_LIBS)
+-PKG_CHECK_MODULES(GTK3, [ gtk+-3.0 >= 3.12 ], HAVE_GTK_3=1)
+-AC_SUBST(GTK3_CFLAGS)
+-AC_SUBST(GTK3_LIBS)
+
+ if test "x$enableval" = "x" || test "x$enableval" = "xgtk2"; then
++PKG_CHECK_MODULES(GTK, [ gtk+-2.0 >= 2.4 ], HAVE_GTK_2=1,[])
++AC_SUBST(GTK_CFLAGS)
++AC_SUBST(GTK_LIBS)
+ CFLAGS="$CFLAGS $GTK_CFLAGS"
+ LIBS="$LIBS $GTK_LIBS"
+ HAVE_GTK_3=0
+ AC_DEFINE(HAVE_GTK_2, 1, Found GTK+ 2.x support)
+ elif test "x$enableval" = "xgtk3"; then
++PKG_CHECK_MODULES(GTK3, [ gtk+-3.0 >= 3.12 ], HAVE_GTK_3=1,[])
++AC_SUBST(GTK3_CFLAGS)
++AC_SUBST(GTK3_LIBS)
+ CFLAGS="$CFLAGS $GTK3_CFLAGS"
+ LIBS="$LIBS $GTK3_LIBS"
+ HAVE_GTK_2=0
+ AC_DEFINE(HAVE_GTK_3, 1, Found GTK+ 3.x support)
+ else
+-echo "Sorry, the value $enableval is not supported as argument of --enable-gtk."
+-exit 1
++HAVE_GTK_2=0
++HAVE_GTK_3=0
+ fi
+
+-dnl Check for additional external libraries etc..
++AC_ARG_ENABLE(ncurses, [ --enable-ncurses enable ncurses support],
++ [if test "$enableval" = no; then no_ncurses=yes; fi])
++if test x$no_ncurses != xyes; then
++PKG_CHECK_MODULES(ncurses, ncurses,[
++ AC_DEFINE([HAVE_LIBNCURSES], [1], found ncurses library)
++ HAVE_CURSES=1
++ LIBS="$LIBS $ncurses_LIBS"
++ CFLAGS="$CFLAGS $ncurses_CFLAGS"],
+ AC_CHECK_LIB(ncurses, initscr, HAVE_CURSES=1; LIBS="$LIBS -lncurses";
+ AC_DEFINE([HAVE_LIBNCURSES], [1], found ncurses library))
++ )
++fi
++dnl Check for additional external libraries etc..
+ AC_CHECK_LIB(intl, libintl_gettext, LIBS="$LIBS -lintl")
+ AC_CHECK_LIB(pthread, pthread_create, LIBS="$LIBS -lpthread", AC_MSG_ERROR(Pthread required and not found. Please check if you have libpthread in your system and specify using CFLAGS and LDFLAGS when configure))
+
diff --git a/net-analyzer/pinger/metadata.xml b/net-analyzer/pinger/metadata.xml
new file mode 100644
index 000000000000..56ad93e19831
--- /dev/null
+++ b/net-analyzer/pinger/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+<use>
+<flag name='gtk2'>Install the gtkpinger GUI utility based on <pkg>x11-libs/gtk:2</pkg></flag>
+<flag name='gtk3'>Install the gtkpinger GUI utility based on <pkg>x11-libs/gtk:3</pkg></flag>
+</use>
+</pkgmetadata>
diff --git a/net-analyzer/pinger/pinger-0.32e.ebuild b/net-analyzer/pinger/pinger-0.32e.ebuild
new file mode 100644
index 000000000000..46185885c6d5
--- /dev/null
+++ b/net-analyzer/pinger/pinger-0.32e.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Cyclic multi ping utility for selected adresses using GTK/ncurses"
+HOMEPAGE="http://aa.vslib.cz/silk/projekty/pinger/index.php"
+SRC_URI="http://aa.vslib.cz/silk/projekty/pinger/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="gtk ncurses nls"
+
+REQUIRED_USE="
+ !gtk? ( ncurses )
+ !ncurses? ( gtk )
+"
+
+RDEPEND="
+ gtk? ( >=x11-libs/gtk+-2.4:2 )
+ ncurses? ( sys-libs/ncurses )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS BUGS ChangeLog NEWS README )
+
+src_prepare() {
+ # bug #494636
+ cp "${FILESDIR}"/gtk-2.0.m4 m4/ || die
+
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+
+ sed -i -e '/Root privileges/d' src/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags -D_GNU_SOURCE
+
+ econf $(use_enable gtk) $(use_enable ncurses) $(use_enable nls)
+}
diff --git a/net-analyzer/pinger/pinger-0.33.ebuild b/net-analyzer/pinger/pinger-0.33.ebuild
new file mode 100644
index 000000000000..7e4a980e24d6
--- /dev/null
+++ b/net-analyzer/pinger/pinger-0.33.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils flag-o-matic
+
+DESCRIPTION="Cyclic multi ping utility for selected adresses using GTK/ncurses"
+HOMEPAGE="http://aa.vslib.cz/silk/projekty/pinger/"
+SRC_URI="${HOMEPAGE}download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="gtk2 gtk3 ncurses nls"
+
+REQUIRED_USE="
+ || ( gtk2 gtk3 ncurses )
+ ?? ( gtk2 gtk3 )
+"
+GTK_DEPEND="
+ dev-libs/glib:2
+"
+RDEPEND="
+ gtk2? (
+ ${GTK_DEPEND}
+ >=x11-libs/gtk+-2.4:2
+ )
+ gtk3? (
+ ${GTK_DEPEND}
+ >=x11-libs/gtk+-3.12:3
+ )
+ ncurses? ( sys-libs/ncurses )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS BUGS ChangeLog NEWS README )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gentoo.patch
+
+ sed -i -e '/Root privileges/d' src/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cppflags -D_GNU_SOURCE
+
+ econf \
+ $(usex gtk2 --enable-gtk=gtk2 '') \
+ $(usex gtk3 --enable-gtk=gtk3 '') \
+ $(use_enable ncurses) \
+ $(use_enable nls)
+}