summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/pktstat
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/pktstat')
-rw-r--r--net-analyzer/pktstat/Manifest1
-rw-r--r--net-analyzer/pktstat/files/pktstat-1.8.5-smtp_line.patch46
-rw-r--r--net-analyzer/pktstat/files/pktstat-1.8.5-tinfo.patch10
-rw-r--r--net-analyzer/pktstat/metadata.xml5
-rw-r--r--net-analyzer/pktstat/pktstat-1.8.5-r1.ebuild35
5 files changed, 97 insertions, 0 deletions
diff --git a/net-analyzer/pktstat/Manifest b/net-analyzer/pktstat/Manifest
new file mode 100644
index 000000000000..ccef1c0a1a80
--- /dev/null
+++ b/net-analyzer/pktstat/Manifest
@@ -0,0 +1 @@
+DIST pktstat-1.8.5.tar.gz 133404 SHA256 140b07120eb48f139d588f0d8db792a91227fc7d6e690f0fcad1328dfcafd2c9 SHA512 0401b34646b3e6238a9fe032fa4c2afb70a3a009850bc85c043ff4bba7da6fab0dcf20b963c62ba4db5ba15a7508241dba4f4789ea59b12193928b4c4ec7f0c7 WHIRLPOOL 2e9d4a4c603080999afa0fa3b50b70d09586212c1e69305fb05974756d779e033822c87d8f809ef72582b4078893ca10fe126c84929c183e3289a31a614645e8
diff --git a/net-analyzer/pktstat/files/pktstat-1.8.5-smtp_line.patch b/net-analyzer/pktstat/files/pktstat-1.8.5-smtp_line.patch
new file mode 100644
index 000000000000..67ea9e9181e8
--- /dev/null
+++ b/net-analyzer/pktstat/files/pktstat-1.8.5-smtp_line.patch
@@ -0,0 +1,46 @@
+--- a/tcp_smtp.c
++++ b/tcp_smtp.c
+@@ -149,13 +149,9 @@
+ struct smtp_state *state;
+ const char *s;
+ int addr_changed = 0;
+-FILE*log;
+
+ state = (struct smtp_state *)f->udata;
+
+-if ((log = fopen("/tmp/smtp.log", "a")))
+- fprintf(log, "smpt_line [%s]\n", line);
+-
+ if (state->in_data) {
+ if (strcmp(line, ".") == 0) {
+ state->in_data = 0;
+@@ -180,18 +176,15 @@
+ } else {
+ /* Normalize the command line */
+ normalize_line(line);
+-if (log)fprintf(log, "normalized to [%s]\n", line);
+ if ((s = strip_prefix(line, "MAIL FROM:"))) {
+ snprintf(state->from_addr, sizeof state->from_addr, "%s", s);
+ normalize_addr(state->from_addr);
+ addr_changed = 1;
+-if (log)fprintf(log, "from_addr = [%s]\n", state->from_addr);
+ }
+ else if ((s = strip_prefix(line, "RCPT TO:"))) {
+ snprintf(state->to_addr, sizeof state->to_addr, "%s", s);
+ normalize_addr(state->to_addr);
+ addr_changed = 1;
+-if (log)fprintf(log, "to_addr = [%s]\n", state->to_addr);
+ }
+ else if (strcmp(line, "DATA") == 0) {
+ state->in_data = 1;
+@@ -213,10 +206,7 @@
+ if (strcmp(line, "QUIT") != 0)
+ snprintf(f->desc, sizeof f->desc, "%s", line);
+ }
+-if (log)fprintf(log, "set desc to: [%s]\n", f->desc);
+ }
+-
+-if (log)fclose(log);
+ }
+
+ /*
diff --git a/net-analyzer/pktstat/files/pktstat-1.8.5-tinfo.patch b/net-analyzer/pktstat/files/pktstat-1.8.5-tinfo.patch
new file mode 100644
index 000000000000..5181124b8053
--- /dev/null
+++ b/net-analyzer/pktstat/files/pktstat-1.8.5-tinfo.patch
@@ -0,0 +1,10 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -18,6 +18,7 @@
+ AC_SEARCH_LIBS(gethostbyname, [nsl]) dnl for Solaris
+ AC_SEARCH_LIBS(pcap_open_live, [pcap])
+ AC_SEARCH_LIBS(exp, [m])
++PKG_CHECK_MODULES(ncurses,ncurses,LIBS="$LIBS $ncurses_LIBS",AC_MSG_ERROR[ncurses is required])
+ AC_SEARCH_LIBS(tgoto, [termlib termcap curses ncurses ocurses])
+ AC_SEARCH_LIBS(initscr, [curses ncurses ocurses])
+ AC_SEARCH_LIBS(nanosleep, [posix4])
diff --git a/net-analyzer/pktstat/metadata.xml b/net-analyzer/pktstat/metadata.xml
new file mode 100644
index 000000000000..03aa50bab7e3
--- /dev/null
+++ b/net-analyzer/pktstat/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>netmon</herd>
+</pkgmetadata>
diff --git a/net-analyzer/pktstat/pktstat-1.8.5-r1.ebuild b/net-analyzer/pktstat/pktstat-1.8.5-r1.ebuild
new file mode 100644
index 000000000000..f9436c35b6cb
--- /dev/null
+++ b/net-analyzer/pktstat/pktstat-1.8.5-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="A network monitoring tool with bandwidth tracking"
+HOMEPAGE="http://www.adaptive-enterprises.com.au/~d/software/pktstat/"
+SRC_URI="http://www.adaptive-enterprises.com.au/~d/software/pktstat/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+
+RDEPEND="
+ net-libs/libpcap
+ >=sys-libs/ncurses-5.3-r1
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-tinfo.patch
+ epatch "${FILESDIR}"/${P}-smtp_line.patch
+ eautoreconf
+}
+
+src_install() {
+ dosbin pktstat
+ doman pktstat.1
+ dodoc ChangeLog NEWS README TODO
+}