summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-02 11:03:32 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-02 11:05:58 +0100
commit84ac28a74a30b86533c0bdd21a40f7cd10549000 (patch)
tree3cae6b4808cf6556726c42abc3b61a0aff940ae6 /net-analyzer/pmacct
parentdev-python/twisted: keyworded 19.10.0 for sparc, bug #661320 (diff)
downloadgentoo-84ac28a74a30b86533c0bdd21a40f7cd10549000.tar.gz
gentoo-84ac28a74a30b86533c0bdd21a40f7cd10549000.tar.bz2
gentoo-84ac28a74a30b86533c0bdd21a40f7cd10549000.zip
net-analyzer/pmacct: Version 1.7.4
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/pmacct')
-rw-r--r--net-analyzer/pmacct/Manifest1
-rw-r--r--net-analyzer/pmacct/files/pmacct-1.7.4--Werror.patch14
-rw-r--r--net-analyzer/pmacct/pmacct-1.7.4.ebuild101
3 files changed, 116 insertions, 0 deletions
diff --git a/net-analyzer/pmacct/Manifest b/net-analyzer/pmacct/Manifest
index e576e2af9f99..e2625e381fbb 100644
--- a/net-analyzer/pmacct/Manifest
+++ b/net-analyzer/pmacct/Manifest
@@ -2,3 +2,4 @@ DIST pmacct-1.6.2.tar.gz 1311678 BLAKE2B 123629ca2e5e58bb4e684001b1c6d2d510e1845
DIST pmacct-1.7.1.tar.gz 1392360 BLAKE2B 75a4dda461c2fe643c24a901c19efacf325d1922bcda503a1ff41fe0b6c4178732d476b479875e9e0ba34872dbd86b8d8b2087471148f10e202f57c4a212f2fd SHA512 6a5d75522b9197b324907598ee4ba22bbda96b45e10f62df2ae507e23faac927af5468f587deab08d1e0f3f6422c609d106dcf30fa7bf16eb215bb35ea6aa08c
DIST pmacct-1.7.2.tar.gz 1416302 BLAKE2B 5d6f9c5849c07c7bdd3b6251b2611935ff558ca393d2cc0d21e5e681b0069b3a5bb4a985a9dc59b62b8b4ed697ecbd4cbb71f0aba42ce8d1527187b98d2e90d3 SHA512 ffdc63e96fc6af6f5d531243bc0aec0925663d8e91e83ada275f8e9a969dcf85cebd06b17ae2c796722bb209602d5b2bc487757ec736a740a8f33698d93a8675
DIST pmacct-1.7.3.tar.gz 1467237 BLAKE2B a2fb627df9f61f91c69a9333a968485695b45c8ebe812e11ba250185a5e93f262954290d7ee41789fb13f7f5c5ef336294be83c8d91adcd0fc3c348485e515af SHA512 09d0e6721760035112cb0c7936fe177f7858b19fa1df2c7da84822dc816413e7c6bace35fe45ad32930961183d61f9e4f3a4879747be45f47ab658a3e0f055b2
+DIST pmacct-1.7.4.tar.gz 1581213 BLAKE2B 3835abc91947af083932e01b828c2324f90595c973fdde9d9f4034dc7d03e12fad6bbe6e91e1462ec36963ccb41a5a740159f531d7e1929f4cd8d994b89a58a1 SHA512 780b6cc25562fb7b5a1f55b48ce9719b36c1ee0d9ee2b6db8d7f238cd5d9f204938313b13e3ff3f62c7b9b179279f18314eba38ad787ffc346a4b217da239ca1
diff --git a/net-analyzer/pmacct/files/pmacct-1.7.4--Werror.patch b/net-analyzer/pmacct/files/pmacct-1.7.4--Werror.patch
new file mode 100644
index 000000000000..e2e9685e1326
--- /dev/null
+++ b/net-analyzer/pmacct/files/pmacct-1.7.4--Werror.patch
@@ -0,0 +1,14 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1109,9 +1109,9 @@
+ AC_MSG_RESULT(yes)
+ tmp_CFLAGS=`echo $CFLAGS | sed 's/O2/O0/g'`
+ CFLAGS="$tmp_CFLAGS"
+- CFLAGS="$CFLAGS -g -Wall -Werror"
++ CFLAGS="$CFLAGS -g -Wall"
+ else
+- CFLAGS="$CFLAGS -Wall -Werror"
++ CFLAGS="$CFLAGS -Wall"
+ AC_MSG_RESULT(no)
+ fi
+ ],
diff --git a/net-analyzer/pmacct/pmacct-1.7.4.ebuild b/net-analyzer/pmacct/pmacct-1.7.4.ebuild
new file mode 100644
index 000000000000..159a6edac6d8
--- /dev/null
+++ b/net-analyzer/pmacct/pmacct-1.7.4.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic toolchain-funcs
+
+DESCRIPTION="A network tool to gather IP traffic information"
+HOMEPAGE="http://www.pmacct.net/"
+SRC_URI="http://www.pmacct.net/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="
+ 64bit +bgp-bins +bmp-bins geoip geoipv2 jansson kafka +l2 mongodb mysql
+ ndpi nflog plabel postgres rabbitmq sqlite +st-bins +traffic-bins zmq
+"
+REQUIRED_USE="
+ ?? ( geoip geoipv2 )
+ kafka? ( jansson )
+ rabbitmq? ( jansson )
+"
+
+RDEPEND="
+ net-libs/libpcap
+ geoip? ( dev-libs/geoip )
+ geoipv2? ( dev-libs/libmaxminddb )
+ jansson? ( dev-libs/jansson )
+ kafka? ( dev-libs/librdkafka )
+ mongodb? (
+ >=dev-libs/mongo-c-driver-0.8.1-r1
+ <dev-libs/mongo-c-driver-0.98
+ )
+ mysql? ( dev-db/mysql-connector-c:0= )
+ ndpi? ( >=net-libs/nDPI-2.4:= )
+ nflog? ( net-libs/libnetfilter_log )
+ postgres? ( dev-db/postgresql:* )
+ rabbitmq? ( net-libs/rabbitmq-c )
+ sqlite? ( =dev-db/sqlite-3* )
+ zmq? ( >=net-libs/zeromq-4.2.0:= )
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-1.7.3-nDPI-3.0.patch
+ "${FILESDIR}"/${PN}-1.7.4--Werror.patch
+)
+
+DOCS=(
+ CONFIG-KEYS ChangeLog FAQS QUICKSTART UPGRADE
+ docs/INTERNALS docs/PLUGINS docs/SIGNALS
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ tc-export CC AR RANLIB
+ append-cppflags -DMYSQL_SERVER_VERSION=99999999
+
+ econf \
+ $(use_enable 64bit) \
+ $(use_enable bgp-bins) \
+ $(use_enable bmp-bins) \
+ $(use_enable geoip) \
+ $(use_enable geoipv2) \
+ $(use_enable jansson) \
+ $(use_enable kafka) \
+ $(use_enable l2) \
+ $(use_enable plabel) \
+ $(use_enable mongodb) \
+ $(use_enable mysql) \
+ $(use_enable ndpi) \
+ $(use_enable nflog) \
+ $(use_enable postgres pgsql) \
+ $(use_enable rabbitmq) \
+ $(use_enable sqlite sqlite3) \
+ $(use_enable st-bins) \
+ $(use_enable traffic-bins) \
+ $(use_enable zmq) \
+ --disable-debug
+}
+
+src_install() {
+ default
+
+ for dirname in examples sql telemetry; do
+ docinto ${dirname}
+ dodoc -r ${dirname}/*
+ done
+
+ newinitd "${FILESDIR}"/pmacctd-init.d pmacctd
+ newconfd "${FILESDIR}"/pmacctd-conf.d pmacctd
+
+ insinto /etc/pmacctd
+ newins examples/pmacctd-imt.conf.example pmacctd.conf
+}