summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/poink
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/poink')
-rw-r--r--net-analyzer/poink/Manifest1
-rw-r--r--net-analyzer/poink/files/poink-2.03-signed-char-fixup.patch13
-rw-r--r--net-analyzer/poink/metadata.xml7
-rw-r--r--net-analyzer/poink/poink-2.03.ebuild29
4 files changed, 50 insertions, 0 deletions
diff --git a/net-analyzer/poink/Manifest b/net-analyzer/poink/Manifest
new file mode 100644
index 000000000000..13a607bd97d2
--- /dev/null
+++ b/net-analyzer/poink/Manifest
@@ -0,0 +1 @@
+DIST poink-2.03.tar.gz 11427 RMD160 331a22526b678696ffc8a7e73a58fe1945583b70 SHA1 36bb16cbfb4b4ca6b99e8ac85fbacdbe47d729d1 SHA256 545150921086da2bbb01225d38d4445b318ebeae8958d2bee53fd806ddb237cc
diff --git a/net-analyzer/poink/files/poink-2.03-signed-char-fixup.patch b/net-analyzer/poink/files/poink-2.03-signed-char-fixup.patch
new file mode 100644
index 000000000000..543e58bb184e
--- /dev/null
+++ b/net-analyzer/poink/files/poink-2.03-signed-char-fixup.patch
@@ -0,0 +1,13 @@
+diff -Nuar poink-2.03.orig/poink.c poink-2.03/poink.c
+--- poink-2.03.orig/poink.c 2002-11-03 03:12:56.000000000 -0800
++++ poink-2.03/poink.c 2007-06-11 11:59:09.763490735 -0700
+@@ -109,7 +109,8 @@
+ SOCKADDR_IN s;
+ struct timeval ping_start, ping_end;
+ struct sigaction siga;
+- char ch, pingerror[100];
++ signed char ch; // EOF is -1
++ char pingerror[100];
+ int delay=DEF_DELAY,timeout=DEF_TIMEOUT;
+ int suck, tmp, port=65535;
+
diff --git a/net-analyzer/poink/metadata.xml b/net-analyzer/poink/metadata.xml
new file mode 100644
index 000000000000..c6d862855eb5
--- /dev/null
+++ b/net-analyzer/poink/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer>
+ <email>robbat2@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/net-analyzer/poink/poink-2.03.ebuild b/net-analyzer/poink/poink-2.03.ebuild
new file mode 100644
index 000000000000..356775514c51
--- /dev/null
+++ b/net-analyzer/poink/poink-2.03.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="TCP/IP-based ping implementation"
+HOMEPAGE="http://directory.fsf.org/security/system/poink.html"
+SRC_URI="http://ep09.pld-linux.org/~mmazur/poink/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+DEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/${PN}-2.03-signed-char-fixup.patch
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS} ${LDFLAGS}" CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ dobin poink poink6
+ newman ping.1 poink.1
+ dodoc README* ChangeLog COPYING
+}