summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-11-19 07:52:31 +0100
committerJeroen Roovers <jer@gentoo.org>2019-11-19 07:57:07 +0100
commit8b4639236d4d4b11089e8fc285514d7602ecc40f (patch)
tree0ced24f6a1299a79b665382fb308867481895a86 /net-analyzer/pypacker
parentnet-analyzer/bwping: Version 1.16 (diff)
downloadgentoo-8b4639236d4d4b11089e8fc285514d7602ecc40f.tar.gz
gentoo-8b4639236d4d4b11089e8fc285514d7602ecc40f.tar.bz2
gentoo-8b4639236d4d4b11089e8fc285514d7602ecc40f.zip
net-analyzer/pypacker: Version 4.9
Package-Manager: Portage-2.3.79, Repoman-2.3.18 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/pypacker')
-rw-r--r--net-analyzer/pypacker/Manifest1
-rw-r--r--net-analyzer/pypacker/pypacker-4.9.ebuild27
2 files changed, 28 insertions, 0 deletions
diff --git a/net-analyzer/pypacker/Manifest b/net-analyzer/pypacker/Manifest
index e41e4e063758..9447b134219d 100644
--- a/net-analyzer/pypacker/Manifest
+++ b/net-analyzer/pypacker/Manifest
@@ -2,3 +2,4 @@ DIST pypacker-2.9.tar.gz 276080 BLAKE2B 3bab4b4c7879fea10accbd3fb2bcb4a8e27096a2
DIST pypacker-4.6.tar.gz 592362 BLAKE2B 41fc63f1fc40ab1cfc007db9dfc6d18cedb51cc8525dc2b467bc03babe03c49f9f0771b8146aacf80f74c511619da85e1f7d56667bcda350710e4c0bafb89351 SHA512 c55205b35f653903149517aad0e2d055745edd6c1a28b1b49aeaa435ca327693b20ed6f851011fa80df1fcc5281ac8b92fbffa3b1381cb3d4507ef7d45d49545
DIST pypacker-4.7.tar.gz 595975 BLAKE2B 95f29bf88347df5c4673a225049337c053cc4833a13767a3fce700a911fb7b744a61ea745f3d3ac4a14cc93288504e190c9cda228000b8a41b924b23805efcf3 SHA512 9c874af28887e942f62a7f540961f7e31af3b35e52f960ec99ed53e6a5ea29d36f20a6dbcf652125ac6b72849502a30e5d11ee1f795c90c7efd5702a0d34b2b3
DIST pypacker-4.8.tar.gz 600508 BLAKE2B e9cdf07ed7d92aecad24e2bea9d18f67eca4477bccc273d77b82701f3110b7b71db5f35bc29ee45d33ac8ba02e8c8d1d36b31e326f21a443f6fc2b2375678330 SHA512 729a55e745f645b874bc6a868afcff543a26aae74b5241204c8e7103f754c296204c43b9db5b64b4a3423f735e2c658e9f0d97f7c84f0f8b134b29c5a2e55227
+DIST pypacker-4.9.tar.gz 602068 BLAKE2B 1ddc16e361ba0aa57b4dab62c38c37aabeffe2cab5cb819e627aeaac5452201117c2f806f2f443cad96d673f93bf0f0a159fa6a7d59564879d038524a2de1eb1 SHA512 804bb32eda76a00121c88d38722a6fb51a9fcff0a5625bd46bda68329e39139624c4fb8e2736208733a6b97ec0df02f173d304fcf3bb39549f3fa119fcf0ae2f
diff --git a/net-analyzer/pypacker/pypacker-4.9.ebuild b/net-analyzer/pypacker/pypacker-4.9.ebuild
new file mode 100644
index 000000000000..5d76249812e6
--- /dev/null
+++ b/net-analyzer/pypacker/pypacker-4.9.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Fast and simple packet creation and parsing library for Python"
+HOMEPAGE="https://gitlab.com/mike01/pypacker"
+SRC_URI="${HOMEPAGE}/-/archive/v${PV}/pypacker-v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+DOCS=( AUTHORS CHANGES HACKING README.md )
+
+python_test() {
+ "${EPYTHON}" tests/test_pypacker.py || die
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ use examples && dodoc -r examples
+}