summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Quinn <code@danielquinn.org>2015-12-16 15:37:08 +0000
committerDaniel Quinn <code@danielquinn.org>2015-12-17 01:11:35 +0000
commit9f6c17070484a72f17b2bed39dec36c06c0e918c (patch)
treec3d06aa9b2c3a2883c27d5c141df8b2be2618ce4 /net-analyzer/ripe-atlas-tools/ripe-atlas-tools-1.2.1.ebuild
parentsys-kernel/hardened-sources: version bump to 4.3.3 (diff)
downloadgentoo-9f6c17070484a72f17b2bed39dec36c06c0e918c.tar.gz
gentoo-9f6c17070484a72f17b2bed39dec36c06c0e918c.tar.bz2
gentoo-9f6c17070484a72f17b2bed39dec36c06c0e918c.zip
net-analyzer/ripe-atlas-tools: Initial commit
Diffstat (limited to 'net-analyzer/ripe-atlas-tools/ripe-atlas-tools-1.2.1.ebuild')
-rw-r--r--net-analyzer/ripe-atlas-tools/ripe-atlas-tools-1.2.1.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/net-analyzer/ripe-atlas-tools/ripe-atlas-tools-1.2.1.ebuild b/net-analyzer/ripe-atlas-tools/ripe-atlas-tools-1.2.1.ebuild
new file mode 100644
index 000000000000..de5991c67a3f
--- /dev/null
+++ b/net-analyzer/ripe-atlas-tools/ripe-atlas-tools-1.2.1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+MY_PN=${PN//-/.}
+DESCRIPTION="The official command-line client for RIPE Atlas"
+HOMEPAGE="https://atlas.ripe.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/ripe.atlas.tools/ripe.atlas.tools-${PVR}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+S="${WORKDIR}/${MY_PN}-${PVR}"
+
+RDEPEND="
+ >=net-libs/ripe-atlas-sagan-1.1.8[${PYTHON_USEDEP}]
+ >=www-client/ripe-atlas-cousteau-1.0.6[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ "${RDEPEND}"
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
+
+python_test() {
+ nosetests --verbose || die "Tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+ echo "RIPE Atlas Tools (Magellan) [Gentoo Linux] ${PVR}" > \
+ ${D}$(python_get_sitedir)/ripe/atlas/tools/user-agent
+} \ No newline at end of file