summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Quinn <code@danielquinn.org>2016-04-15 17:21:52 +0100
committerPatrice Clement <monsieurp@gentoo.org>2016-04-15 18:55:13 +0000
commit5026a7bc4ba43678571ae0227a86482eed244fc0 (patch)
tree9492b94e7652a03190ccd2b67b17c095dcb70f1f /net-analyzer/ripe-atlas-tools/ripe-atlas-tools-1.2.3.ebuild
parentwww-client/ripe-atlas-cousteau: Version bump to 1.2 (diff)
downloadgentoo-5026a7bc4ba43678571ae0227a86482eed244fc0.tar.gz
gentoo-5026a7bc4ba43678571ae0227a86482eed244fc0.tar.bz2
gentoo-5026a7bc4ba43678571ae0227a86482eed244fc0.zip
net-analyzer/ripe-atlas-tools: Version bump to 1.2.3
Closes: https://github.com/gentoo/gentoo/pull/1265 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-analyzer/ripe-atlas-tools/ripe-atlas-tools-1.2.3.ebuild')
-rw-r--r--net-analyzer/ripe-atlas-tools/ripe-atlas-tools-1.2.3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/net-analyzer/ripe-atlas-tools/ripe-atlas-tools-1.2.3.ebuild b/net-analyzer/ripe-atlas-tools/ripe-atlas-tools-1.2.3.ebuild
new file mode 100644
index 000000000000..aa6355e7af84
--- /dev/null
+++ b/net-analyzer/ripe-atlas-tools/ripe-atlas-tools-1.2.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_4 )
+
+inherit distutils-r1
+
+MY_PN=${PN//-/.}
+DESCRIPTION="The official command-line client for RIPE Atlas"
+HOMEPAGE="https://atlas.ripe.net/"
+SRC_URI="mirror://pypi/${PN:0:1}/ripe.atlas.tools/ripe.atlas.tools-${PV}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+S="${WORKDIR}/${MY_PN}-${PVR}"
+
+DOCS=( CHANGES.rst README.rst )
+
+RDEPEND="
+ >=net-libs/ripe-atlas-sagan-1.1.8[${PYTHON_USEDEP}]
+ >=www-client/ripe-atlas-cousteau-1.0.7[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pyopenssl-0.13[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/tzlocal[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/ujson[${PYTHON_USEDEP}]"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7) )"
+
+python_test() {
+ nosetests --verbose || die "Tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+ echo "RIPE Atlas Tools (Magellan) [Gentoo Linux] ${PVR}" > \
+ ${D}$(python_get_sitedir)/ripe/atlas/tools/user-agent
+}