summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-01-20 15:00:44 +0100
committerJeroen Roovers <jer@gentoo.org>2018-01-20 15:00:44 +0100
commitdc241b7f41b36ed9af1c0df692938a76d370c18c (patch)
tree1adcc3efd0089f3752af45bb3c47215414a78f8e /net-analyzer/sarg/sarg-2.3.11-r1.ebuild
parentnet-analyzer/sarg: Fix more compiler warnings (bug #645006). (diff)
downloadgentoo-dc241b7f41b36ed9af1c0df692938a76d370c18c.tar.gz
gentoo-dc241b7f41b36ed9af1c0df692938a76d370c18c.tar.bz2
gentoo-dc241b7f41b36ed9af1c0df692938a76d370c18c.zip
net-analyzer/sarg: Revision bump (bug #645006).
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-analyzer/sarg/sarg-2.3.11-r1.ebuild')
-rw-r--r--net-analyzer/sarg/sarg-2.3.11-r1.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/net-analyzer/sarg/sarg-2.3.11-r1.ebuild b/net-analyzer/sarg/sarg-2.3.11-r1.ebuild
new file mode 100644
index 000000000000..82677c354812
--- /dev/null
+++ b/net-analyzer/sarg/sarg-2.3.11-r1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit autotools
+
+DESCRIPTION="Squid Analysis Report Generator"
+HOMEPAGE="http://sarg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE="+gd ldap pcre"
+
+DEPEND="
+ gd? ( media-libs/gd[png,truetype] )
+ ldap? ( net-nds/openldap )
+ pcre? ( dev-libs/libpcre )
+"
+RDEPEND="
+ ${DEPEND}
+"
+DOCS=( BETA-TESTERS CONTRIBUTORS DONATIONS README ChangeLog htaccess )
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.3.10-config.patch
+ "${FILESDIR}"/${PN}-2.3.11-configure.patch
+ "${FILESDIR}"/${PN}-2.3.11-format.patch
+)
+
+src_prepare() {
+ default
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_with gd) \
+ $(use_with ldap) \
+ $(use_with pcre) \
+ --sysconfdir="${EPREFIX}/etc/sarg/"
+}