summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-05-16 09:48:29 +0200
committerJeroen Roovers <jer@gentoo.org>2019-05-16 09:48:45 +0200
commit7a18b0c98614601d688a8df50bd7d13bc494f45f (patch)
treec514e6fe80347145f08234d980184dbc3d2cfcfe /net-analyzer/scapy
parentdev-util/cmake: Bump to version 3.14.4 (diff)
downloadgentoo-7a18b0c98614601d688a8df50bd7d13bc494f45f.tar.gz
gentoo-7a18b0c98614601d688a8df50bd7d13bc494f45f.tar.bz2
gentoo-7a18b0c98614601d688a8df50bd7d13bc494f45f.zip
net-analyzer/scapy: Version 2.4.3_rc1
Package-Manager: Portage-2.3.66, Repoman-2.3.12 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/scapy')
-rw-r--r--net-analyzer/scapy/Manifest1
-rw-r--r--net-analyzer/scapy/scapy-2.4.3_rc1.ebuild42
-rw-r--r--net-analyzer/scapy/scapy-9999.ebuild4
3 files changed, 45 insertions, 2 deletions
diff --git a/net-analyzer/scapy/Manifest b/net-analyzer/scapy/Manifest
index d5967a0f3053..7214248b56f3 100644
--- a/net-analyzer/scapy/Manifest
+++ b/net-analyzer/scapy/Manifest
@@ -1,3 +1,4 @@
DIST scapy-2.3.2.tar.gz 1166056 BLAKE2B bce5f37bd833dc457089cdfebd2dc019c4f7bed636935b4a6b51a2cf7355f5761fadaa304e93c276daa2200c48ab0e1c0a08bd278e30dfea1faa01321a0b957e SHA512 6b15e102708d1bd0ca0c910e2d82416cd172634409f93c506542a7dc6b69ddc9c9afef6ec07929f70cc0f8f4c455cdc84d9b35bc2c5b72f79dd7e6785306dc7a
DIST scapy-2.4.0.tar.gz 3182131 BLAKE2B af591b103c90736a5e62801f4c0ebd495e2e71c79ee81f04fdd194739b460c9940b8fcf0c6e279701095979144eff25ca4734926c0251721b37dc63fe8dd9e89 SHA512 0fe80150cd83db7735c9d0b70ec832a4e68eb5160ad8559e9b1bd79c52a9950ef7c9555ea2a1ee1dc8df1f055a885c52552c29e304faf40250ce9c502a5f870a
DIST scapy-2.4.2.tar.gz 3330071 BLAKE2B a40074594cd561b33d04364fba743fa5fe741b06b2ad8f8f9ebe9dfb0b9a3bc4f641cd16d99a4ba070fc0763d7cfeb8d3ecd056f162d509070cdd57d55d6ad9c SHA512 980f708a849ae26edca3eb6618a41668818c5883bca699f347f47a8964b3ee44a6ceefe4a12cb7d5fe6c13f5cbe2b7547938e53139f4ec9e6ef384e30c9bb6db
+DIST scapy-2.4.3_rc1.tar.gz 2455703 BLAKE2B 7db2af39afad694b49296d0e02a7e649c31023fbb12d66faccb777e297240b84e39558dd0ba56dab159e8412cec93d868ec02542afa385e2ec49d1a80b8788d4 SHA512 29996996521d5802b435c27dee5ad91fdd3e974dc86a3ba1377c67eb5c81a639fdfa18790ca2275df54685a963f7c69bde10b01887ba54315ddef6d2c002f8d8
diff --git a/net-analyzer/scapy/scapy-2.4.3_rc1.ebuild b/net-analyzer/scapy/scapy-2.4.3_rc1.ebuild
new file mode 100644
index 000000000000..25877178edf3
--- /dev/null
+++ b/net-analyzer/scapy/scapy-2.4.3_rc1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
+inherit distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="A Python interactive packet manipulation program for mastering the network"
+HOMEPAGE="https://scapy.net/ https://github.com/secdev/scapy"
+SRC_URI="https://github.com/secdev/${PN}/archive/v${PV/_/}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="
+ net-analyzer/tcpdump
+"
+S=${WORKDIR}/${P/_/}
+DOC_CONTENTS="
+Scapy has optional support for the following packages:
+
+ dev-python/cryptography
+ dev-python/gnuplot-py
+ dev-python/ipython
+ dev-python/pyx
+ media-gfx/graphviz
+ net-analyzer/tcpreplay
+ virtual/imagemagick-tools
+
+ See also ""${EPREFIX}/usr/share/doc/${PF}/installation.rst""
+"
+
+src_prepare() {
+ echo ${PV/_/} > ${PN}/VERSION
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc -r doc/${PN}/*
+ DISABLE_AUTOFORMATTING=plz readme.gentoo_create_doc
+}
diff --git a/net-analyzer/scapy/scapy-9999.ebuild b/net-analyzer/scapy/scapy-9999.ebuild
index ee534593de55..55240a18ff01 100644
--- a/net-analyzer/scapy/scapy-9999.ebuild
+++ b/net-analyzer/scapy/scapy-9999.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_{5,6}} )
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{5,6,7}} )
inherit distutils-r1 git-r3 readme.gentoo-r1
DESCRIPTION="A Python interactive packet manipulation program for mastering the network"