summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-05-09 23:52:19 +0000
committerSam James <sam@gentoo.org>2021-05-09 23:53:16 +0000
commitbe5688bbcfe8eb7b6ac06192dda990067aa5bcae (patch)
tree5c4f8c4d882328f675e46d870c6924d047c621db /net-analyzer/scapy
parentsys-devel/binutils-config: Stabilize 5.4 arm, #785391 (diff)
downloadgentoo-be5688bbcfe8eb7b6ac06192dda990067aa5bcae.tar.gz
gentoo-be5688bbcfe8eb7b6ac06192dda990067aa5bcae.tar.bz2
gentoo-be5688bbcfe8eb7b6ac06192dda990067aa5bcae.zip
net-analyzer/scapy: add 2.4.5
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/scapy')
-rw-r--r--net-analyzer/scapy/Manifest1
-rw-r--r--net-analyzer/scapy/scapy-2.4.5.ebuild48
-rw-r--r--net-analyzer/scapy/scapy-9999.ebuild5
3 files changed, 52 insertions, 2 deletions
diff --git a/net-analyzer/scapy/Manifest b/net-analyzer/scapy/Manifest
index 60e58090c7cc..271529673f52 100644
--- a/net-analyzer/scapy/Manifest
+++ b/net-analyzer/scapy/Manifest
@@ -1 +1,2 @@
DIST scapy-2.4.4.tar.gz 3240890 BLAKE2B 38b4fc0c34f229bb33f4d488ae9ba20905db572e3dd3caa15a92e8a33ba7305ba86a2b32a2664779c5085e53d44b4c55336d7afa8d65b90ffa3babcdc94bff25 SHA512 b8ad138ae2563967af07d123339ac73468fadb8f7687123aed364ad6d45198e9039314e17a155c37d01ef084e25571c587330dfd21777527110342c01821a389
+DIST scapy-2.4.5.tar.gz 3323309 BLAKE2B af94b3ec6324c4544aca25f63bcca8aa60a3b1cbbf132d3ed07b5bc73b95e4298bf250e65157bdb7851226fd0ac039367892a9a14d844e5815832ad4ab556819 SHA512 b5ccd689f7bd4fbbb86921a35360b94ec7a738b494f16e4764828689835296016bc476825add798406e4d32761d8df90b41ce7e38049afdabf98397b1bf5982a
diff --git a/net-analyzer/scapy/scapy-2.4.5.ebuild b/net-analyzer/scapy/scapy-2.4.5.ebuild
new file mode 100644
index 000000000000..2c8170223ff8
--- /dev/null
+++ b/net-analyzer/scapy/scapy-2.4.5.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+inherit distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="A Python interactive packet manipulation program for mastering the network"
+HOMEPAGE="https://scapy.net/ https://github.com/secdev/scapy"
+SRC_URI="https://github.com/secdev/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+DOC_CONTENTS="
+Scapy has optional support for the following packages:
+
+ dev-python/cryptography
+ dev-python/ipython
+ dev-python/matplotlib
+ dev-python/pyx
+ media-gfx/graphviz
+ net-analyzer/tcpdump
+ net-analyzer/tcpreplay
+ net-libs/libpcap
+ virtual/imagemagick-tools
+
+ See also ""${EPREFIX}/usr/share/doc/${PF}/installation.rst""
+"
+
+src_prepare() {
+ if ! [[ -f ${PN}/VERSION ]]; then
+ echo ${PV} > ${PN}/VERSION || die
+ else
+ die
+ fi
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc -r doc/${PN}/*
+ DISABLE_AUTOFORMATTING=plz readme.gentoo_create_doc
+}
diff --git a/net-analyzer/scapy/scapy-9999.ebuild b/net-analyzer/scapy/scapy-9999.ebuild
index ec171fbddec3..ac3fd1dccb9d 100644
--- a/net-analyzer/scapy/scapy-9999.ebuild
+++ b/net-analyzer/scapy/scapy-9999.ebuild
@@ -2,6 +2,7 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
+
PYTHON_COMPAT=( python3_{7,8,9} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1 git-r3 readme.gentoo-r1
@@ -9,11 +10,11 @@ inherit distutils-r1 git-r3 readme.gentoo-r1
DESCRIPTION="A Python interactive packet manipulation program for mastering the network"
HOMEPAGE="https://scapy.net/ https://github.com/secdev/scapy"
EGIT_REPO_URI="https://github.com/secdev/${PN}"
+S="${WORKDIR}"/${P/_/}
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS=""
-S=${WORKDIR}/${P/_/}
+
DOC_CONTENTS="
Scapy has optional support for the following packages: