summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/scli
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/scli')
-rw-r--r--net-analyzer/scli/Manifest1
-rw-r--r--net-analyzer/scli/files/scli-0.4.0-configure.patch44
-rw-r--r--net-analyzer/scli/metadata.xml5
-rw-r--r--net-analyzer/scli/scli-0.4.0-r1.ebuild36
4 files changed, 86 insertions, 0 deletions
diff --git a/net-analyzer/scli/Manifest b/net-analyzer/scli/Manifest
new file mode 100644
index 000000000000..7bc68a6e821c
--- /dev/null
+++ b/net-analyzer/scli/Manifest
@@ -0,0 +1 @@
+DIST scli-0.4.0.tar.gz 953401 SHA256 308511589260d3da9bc5817ace363180070ac83ccba9231b7b9a01e1b0c29fe1 SHA512 ceb81e51049def64cb6f2428263709802380f7f712575e327a71d8cc120d284a7d9c57679d76e22cfcaf5b160d0d46af0cefa1133c56972b43002cb94f120dcc WHIRLPOOL 29f72af56e1a934a30b147858cd3e7e5acd638546b46b275693b0241bb0006edb1e66fa8af5a7074d23125c02780f129d1c7df6356da45fce3c083a390886aeb
diff --git a/net-analyzer/scli/files/scli-0.4.0-configure.patch b/net-analyzer/scli/files/scli-0.4.0-configure.patch
new file mode 100644
index 000000000000..d942da0adcc5
--- /dev/null
+++ b/net-analyzer/scli/files/scli-0.4.0-configure.patch
@@ -0,0 +1,44 @@
+--- a/configure.in
++++ b/configure.in
+@@ -20,6 +20,8 @@
+ AC_CHECK_PROG(SMIDUMP, smidump, smidump)
+ AC_SUBST(SMIDUMP)
+
++PKG_PROG_PKG_CONFIG
++
+ AC_DEFINE_UNQUOTED(SCLI_PLUGIN_PATH, "${pkglibdir}")
+
+ AC_MSG_CHECKING([whether to enable -Wall])
+@@ -33,19 +35,24 @@
+
+ dnl Checks for libraries.
+
+-AM_PATH_GLIB_2_0(2.0.0, [], AC_MSG_ERROR(scli needs GLIB), gmodule)
+-AM_PATH_GNET_2_0(2.0.0, [], AC_MSG_ERROR(scli needs GNET))
++PKG_CHECK_MODULES(GLIB, glib-2.0 gmodule-2.0 gthread-2.0,[
++ LIBS="$LIBS $GLIB_LIBS"
++ CPPFLAGS="$CPPFLAGS $GLIB_CFLAGS"
++ ], AC_MSG_ERROR(scli needs GLIB))
++PKG_CHECK_MODULES(GNET, gnet-2.0 >= 2.0.0,[
++ LIBS="$LIBS $GNET_LIBS"
++ CPPFLAGS="$CPPFLAGS $GNET_CFLAGS"
++ ], AC_MSG_ERROR(scli needs GNET))
+ dnl AM_PATH_GLIB(1.2.0, [], AC_MSG_ERROR(scli needs GLIB), gmodule)
+ dnl AM_PATH_GTK(1.2.0, [], AC_MSG_ERROR(scli needs GTK))
+-AM_PATH_XML2(2.0.0, [], AC_MSG_ERROR(scli needs libxml2))
++PKG_CHECK_MODULES(XML2, libxml-2.0 >= 2.0.0,[
++ LIBS="$LIBS $XML2_LIBS"
++ CPPFLAGS="$CPPFLAGS $XML2_CFLAGS"
++ ], AC_MSG_ERROR(scli needs libxml2))
+ PKG_CHECK_MODULES(GSNMP, gsnmp, have_gsnmp=true, have_gsnmp=false)
+ AC_SUBST(GSNMP_CFLAGS)
+ AC_SUBST(GSNMP_LIBS)
+-AC_CHECK_LIB(ncurses, initscr, [],
+- AC_CHECK_LIB(curses, initscr, [],
+- AC_MSG_ERROR([scli requires curses functions; install curses first])
+- )
+-)
++PKG_CHECK_MODULES(ncurses,ncurses,LIBS="$LIBS $ncurses_LIBS",AC_MSG_ERROR([ncurses is required]))
+ AC_CHECK_LIB(readline, readline, [],
+ AC_MSG_ERROR([scli requires readline functions; install libreadline first])
+ )
diff --git a/net-analyzer/scli/metadata.xml b/net-analyzer/scli/metadata.xml
new file mode 100644
index 000000000000..78692635ad22
--- /dev/null
+++ b/net-analyzer/scli/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+</pkgmetadata>
diff --git a/net-analyzer/scli/scli-0.4.0-r1.ebuild b/net-analyzer/scli/scli-0.4.0-r1.ebuild
new file mode 100644
index 000000000000..292f4e282218
--- /dev/null
+++ b/net-analyzer/scli/scli-0.4.0-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="SNMP Command Line Interface"
+HOMEPAGE="http://cnds.eecs.jacobs-university.de/users/schoenw/articles/software/index.html"
+SRC_URI="ftp://ftp.ibr.cs.tu-bs.de/pub/local/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/libxml2
+ net-libs/gnet
+ net-libs/gsnmp
+ sys-libs/ncurses
+ sys-libs/readline
+ sys-libs/zlib
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS ChangeLog NEWS PORTING README TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-configure.patch
+
+ eautoreconf
+}