summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2020-12-12 14:35:09 +0100
committerDavid Seifert <soap@gentoo.org>2020-12-12 14:35:09 +0100
commitf3b1a80f9736c6ea5c4845703409baebad6b35e8 (patch)
tree943a110008a2625ef171a625381c5998de317992 /net-analyzer/sniffit
parentnet-analyzer/smokeping: remove unused patches (diff)
downloadgentoo-f3b1a80f9736c6ea5c4845703409baebad6b35e8.tar.gz
gentoo-f3b1a80f9736c6ea5c4845703409baebad6b35e8.tar.bz2
gentoo-f3b1a80f9736c6ea5c4845703409baebad6b35e8.zip
net-analyzer/sniffit: remove unused patches
Package-Manager: Portage-3.0.11, Repoman-3.0.2 Signed-off-by: Michael Mair-Keimberger <m.mairkeimberger@gmail.com> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-analyzer/sniffit')
-rw-r--r--net-analyzer/sniffit/files/sniffit-0.3.7-gentoo.patch31
-rw-r--r--net-analyzer/sniffit/files/sniffit-0.3.7-misc.patch120
-rw-r--r--net-analyzer/sniffit/files/sniffit-0.3.7-tinfo.patch38
-rw-r--r--net-analyzer/sniffit/files/sniffit-0.4.0-fno-common.patch181
4 files changed, 0 insertions, 370 deletions
diff --git a/net-analyzer/sniffit/files/sniffit-0.3.7-gentoo.patch b/net-analyzer/sniffit/files/sniffit-0.3.7-gentoo.patch
deleted file mode 100644
index c226b6f00d45..000000000000
--- a/net-analyzer/sniffit/files/sniffit-0.3.7-gentoo.patch
+++ /dev/null
@@ -1,31 +0,0 @@
---- a/Makefile.in
-+++ b/Makefile.in
-@@ -10,13 +10,13 @@
- LIBS = @LIBS@
- DEFS = @DEFS@
- OS_OPT = @OS_OPT@
--OBJ_FLAG = -w -O2 -c
--OBJ_OPT = -I./libpcap -L./libpcap
--EXE_FLAG = -w -O2 -o sniffit
--EXE_OPT = -I./libpcap -L./libpcap -lpcap
-+OBJ_FLAG = $(CFLAGS) -c
-+OBJ_OPT = -I/usr/include/pcap -L/usr/lib
-+EXE_FLAG = $(CFLAGS) $(LDFLAGS) -o sniffit
-+EXE_OPT = -I/usr/include/pcap -lpcap
- EXE_OBJ = sn_packets.o sn_generation.o sn_interface.o sn_cfgfile.o \
- sn_logfile.o sn_resolv.o
--DEP_FILES = sn_config.h ./libpcap/pcap.h sn_data.h sn_defines.h sn_plugins.h \
-+DEP_FILES = sn_config.h sn_data.h sn_defines.h sn_plugins.h \
- sn_analyse.c sn_conn_desc.c \
- sn_packets.o \
- sn_generation.o sn_interface.o sn_cfgfile.o sn_logfile.o \
-@@ -26,9 +26,7 @@
- @echo "Succesfull compilation..."
-
- sniffit: $(SNIFFIT) $(DEP_FILES)
-- cd libpcap; make; cd ..
- $(CC) $(EXE_FLAG) $(SNIFFIT) $(EXE_OBJ) $(EXE_OPT) $(LIBS) $(DEFS) $(OS_OPT)
-- strip sniffit
-
- sn_cfgfile.o: sn_cfgfile.h sn_cfgfile.c sn_defines.h sn_structs.h sn_config.h
- $(CC) $(OBJ_FLAG) sn_cfgfile.c $(OBJ_OPT) $(DEFS)
diff --git a/net-analyzer/sniffit/files/sniffit-0.3.7-misc.patch b/net-analyzer/sniffit/files/sniffit-0.3.7-misc.patch
deleted file mode 100644
index ff84cd7d2259..000000000000
--- a/net-analyzer/sniffit/files/sniffit-0.3.7-misc.patch
+++ /dev/null
@@ -1,120 +0,0 @@
---- a/sn_cfgfile.h
-+++ b/sn_cfgfile.h
-@@ -10,3 +10,4 @@
- void make_nr_dot (char *);
- void interprete_line (char *);
- void read_cfg_file (char *);
-+char *strlower (char *);
---- a/sn_structs.h
-+++ b/sn_structs.h
-@@ -67,7 +67,7 @@
- struct snif_mask /* struct for mask */
- {
- _32_bit source_ip, destination_ip;
-- _32_bit short source_port, destination_port;
-+ _32_bit source_port, destination_port;
- };
-
- /* (packet generation) */
---- a/sn_analyse.c
-+++ b/sn_analyse.c
-@@ -1,6 +1,9 @@
- /* Analyse traffic for logging mode */
- /* - by: Brecht Claerhout */
-
-+#include <stdlib.h>
-+#include <string.h>
-+
- const unsigned char *data;
- memcpy(&tcphead,header,sizeof(struct TCP_header));
-
---- a/sn_cfgfile.c
-+++ b/sn_cfgfile.c
-@@ -3,6 +3,11 @@
- /* - improvements: Shudoh Kazuyuki */
-
- #include <stdio.h>
-+#include <stdlib.h>
-+#include "sn_interface.h"
-+#include <string.h>
-+#include <ctype.h>
-+#include <time.h>
- #include <netdb.h> /* for getservbyname() */
-
- #include "sn_config.h"
---- a/sn_conn_desc.c
-+++ b/sn_conn_desc.c
-@@ -1,6 +1,8 @@
- /* Connection description detection file */
- /* - by: Brecht Claerhout */
-
-+#include <ctype.h>
-+#include <string.h>
-
- /* Simple PORT BASED detection */
-
---- a/sn_generation.c
-+++ b/sn_generation.c
-@@ -6,12 +6,16 @@
- #ifdef INCLUDE_INTERFACE
- #ifdef GENERATION
- #include <unistd.h>
-+#include <stdlib.h>
-+#include <string.h>
- #include <sys/socket.h>
- #include <netinet/in.h>
- #include "sn_curses.h"
- #include "sn_defines.h"
- #include "sn_structs.h"
- #include "sn_generation.h"
-+#include "sn_interface.h" /* input_field() */
-+#include "sn_packets.h" /* in_cksum() */
-
- extern volatile int screen_busy;
-
---- a/sniffit.0.3.7.c
-+++ b/sniffit.0.3.7.c
-@@ -4,6 +4,9 @@
- #include "sn_config.h" /* Config header file */
-
- #include <unistd.h>
-+#include <stdlib.h>
-+#include <string.h>
-+#include <ctype.h>
- #include <signal.h>
- #include <stdio.h>
- #include <fcntl.h>
---- a/sn_interface.c
-+++ b/sn_interface.c
-@@ -6,6 +6,9 @@
- #ifdef INCLUDE_INTERFACE
- #include <signal.h>
- #include <unistd.h>
-+#include <stdlib.h>
-+#include <string.h>
-+#include <ctype.h>
- #include <sys/ipc.h>
- #include <sys/shm.h>
- #include "sn_curses.h"
---- a/sn_logfile.c
-+++ b/sn_logfile.c
-@@ -4,6 +4,9 @@
- #include "sn_config.h"
-
- #include <stdio.h>
-+#include <stdlib.h> /* exit() */
-+#include <string.h> /* strcpy() */
-+#include <time.h> /* time() ctime() */
- #include <sys/stat.h>
- #include <sys/time.h>
- #include "sn_defines.h"
---- a/sn_packets.c
-+++ b/sn_packets.c
-@@ -5,6 +5,7 @@
- #include "sn_defines.h"
- #include "sn_structs.h"
- #include <netinet/in.h>
-+#include <string.h> /* memcpy() strcpy() */
-
- extern int PROTO_HEAD;
- extern char NO_CHKSUM;
diff --git a/net-analyzer/sniffit/files/sniffit-0.3.7-tinfo.patch b/net-analyzer/sniffit/files/sniffit-0.3.7-tinfo.patch
deleted file mode 100644
index b82835049687..000000000000
--- a/net-analyzer/sniffit/files/sniffit-0.3.7-tinfo.patch
+++ /dev/null
@@ -1,38 +0,0 @@
---- a/configure.in
-+++ b/configure.in
-@@ -5,30 +5,15 @@
-
- AC_INIT(sniffit.h)
-
--dnl Config of libpcap
--AC_CONFIG_SUBDIRS(libpcap)
--
- dnl Check the C compiler
- AC_PROG_CC
-
- dnl Check NCURSES availability
--NCURSES_PATH=/usr/include:/usr/include/ncurses:/usr/include/curses:/usr/local/include:/usr/local/include/ncurses:/usr/local/include/curses:./:./ncurses.h
--ncurses_warn=0
--AC_CHECK_LIB(ncurses,main,,ncurses_warn=1)
--
--AC_PATH_PROGS(NCURSES_LOCATION,ncurses.h,no,$NCURSES_PATH)
--if test "$NCURSES_LOCATION" != no; then
-- echo "#include \"$NCURSES_LOCATION\"" >sn_curses.h
-- AC_DEFINE(HAVE_NCURSES_H,1)
--else
-- ncurses_warn=1
--fi
--
--dnl Print warning for interactive mode
--if test $ncurses_warn -ne 0; then
-- AC_MSG_WARN(Interactive mode (-i/-I) will NOT be supported.!)
-- AC_MSG_WARN(Install ncurses!)
--fi
-+PKG_CHECK_MODULES(ncurses,ncurses,main,
-+ LIBS="$LIBS $ncurses_LIBS"
-+ echo "#include <ncurses.h>" > sn_curses.h
-+ AC_DEFINE(HAVE_NCURSES_H),
-+ AC_MSG_ERROR([ncurses not found]))
-
- dnl Check Shared Memory support
- AC_CHECK_FUNCS(shmget)
diff --git a/net-analyzer/sniffit/files/sniffit-0.4.0-fno-common.patch b/net-analyzer/sniffit/files/sniffit-0.4.0-fno-common.patch
deleted file mode 100644
index 6a576acf1d2b..000000000000
--- a/net-analyzer/sniffit/files/sniffit-0.4.0-fno-common.patch
+++ /dev/null
@@ -1,181 +0,0 @@
---- a/src/sn_data.h
-+++ b/src/sn_data.h
-@@ -101,7 +101,7 @@
- char IP[256];
- unsigned long SNIFLEN; /* bytes we need to snif */
- short DEST_PORT, SRC_PORT; /* destination port */
--char non_printable, *logging_device;
-+char non_printable;
-
- /**** Global data (packets) *************************************************/
- int PROTO_HEAD; /* Base Protocol head length (ethernet, PPP ,....) */
-@@ -147,43 +147,6 @@
- /**** Global data (plugins) *************************************************/
- char Plugin_Active[10];
-
--/**** Global data (interactive) *********************************************/
--#ifdef INCLUDE_INTERFACE
--
--/**** shared memory pointers ************************************************/
--char *SHARED, *connection_data, *timing, *running_connections,
-- *logged_connections;
--int *LISTlength, *DATAlength, memory_id;
--unsigned int *TCP_nr_of_packets, *ICMP_nr_of_packets, *UDP_nr_of_packets;
--unsigned int *IP_nr_of_packets;
--unsigned long *TCP_bytes_in_packets, *UDP_bytes_in_packets;
--int *DESC_LEN;
--
--/**** data structures *******************************************************/
--struct snif_mask *mask;
--struct shared_logged_conn *log_conn;
--FILE *log_dev_stream;
--struct stat log_dev_stat;
--
--volatile int LOGGING=0, screen_busy=0;
--char PACKET_INFO;
--int POINTpos=0, LISTpos=0;
--unsigned char COLOR_AVAIL=0;
--
--/**** screen **************************************************************/
--int MASK_WINDOW_ROWS, MASK_WINDOW_COLS;
--int MAIN_WINDOW_ROWS, MAIN_WINDOW_COLS;
--int INFO_WINDOW_ROWS, INFO_WINDOW_COLS;
--int DATA_WINDOW_ROWS, DATA_WINDOW_COLS;
--int INFO_WINDOW_X, INFO_WINDOW_Y;
--int MASK_WINDOW_X, MASK_WINDOW_Y;
--int DATA_WINDOW_X, DATA_WINDOW_Y;
--
--WINDOW *menu_window;
--struct box_window data_box, main_box, mask_box, packets_box;
--int Pid=0;
--#endif
--
- /* DEBUG section */
- #ifdef DEBUG
- FILE *debug_dev;
---- a/src/sn_global.h
-+++ b/src/sn_global.h
-@@ -4,7 +4,6 @@
- /* currently some option data */
-
- char SNIFMODE, DUMPMODE, PROTOCOLS, ASC, WILDCARD, CFG_FILE, NO_CHKSUM;
--char INTERACTIVE_EXTEND;
- int LOGPARAM;
- /* All option shit */
-
---- a/src/sn_interface.c
-+++ b/src/sn_interface.c
-@@ -18,37 +18,37 @@
- #include "sn_generation.h"
- #include "sn_resolv.h"
-
--/*** extern stuff ********/
--extern char *SHARED, *connection_data, *timing, *running_connections,
-+/*** global stuff ********/
-+char *SHARED, *connection_data, *timing, *running_connections,
- *logged_connections;
--extern int *LISTlength, *DATAlength, memory_id;
--extern unsigned int *TCP_nr_of_packets, *ICMP_nr_of_packets, *UDP_nr_of_packets; unsigned int *IP_nr_of_packets;
--extern unsigned long *TCP_bytes_in_packets, *UDP_bytes_in_packets;
--extern int *DESC_LEN; /* For the connection desciption */
--
--extern char INTERACTIVE_EXTEND;
--
--extern struct snif_mask *mask;
--extern struct shared_logged_conn *log_conn;
--extern FILE *log_dev_stream;
--extern struct stat log_dev_stat;
--
--extern volatile int LOGGING, screen_busy;
--extern char PACKET_INFO;
--extern int POINTpos, LISTpos;
--extern unsigned char COLOR_AVAIL;
--
--extern WINDOW *menu_window;
--extern struct box_window data_box, main_box, mask_box, packets_box;
--extern int Pid;
--extern char *logging_device;
-+int *LISTlength, *DATAlength, memory_id;
-+unsigned int *TCP_nr_of_packets, *ICMP_nr_of_packets, *UDP_nr_of_packets; unsigned int *IP_nr_of_packets;
-+unsigned long *TCP_bytes_in_packets, *UDP_bytes_in_packets;
-+int *DESC_LEN; /* For the connection desciption */
-+
-+char INTERACTIVE_EXTEND;
-+
-+struct snif_mask *mask;
-+struct shared_logged_conn *log_conn;
-+FILE *log_dev_stream;
-+struct stat log_dev_stat;
-+
-+volatile int LOGGING, screen_busy;
-+char PACKET_INFO;
-+int POINTpos, LISTpos;
-+unsigned char COLOR_AVAIL;
-+
-+WINDOW *menu_window;
-+struct box_window data_box, main_box, mask_box, packets_box;
-+int Pid;
-+char *logging_device;
-
-
- /*** Screen Parameters ***/
--extern int MASK_WINDOW_ROWS, MASK_WINDOW_COLS, MAIN_WINDOW_ROWS, MAIN_WINDOW_COLS;
--extern int INFO_WINDOW_ROWS, INFO_WINDOW_COLS, DATA_WINDOW_ROWS, DATA_WINDOW_COLS;
--extern int INFO_WINDOW_X, INFO_WINDOW_Y, MASK_WINDOW_X, MASK_WINDOW_Y;
--extern int DATA_WINDOW_X, DATA_WINDOW_Y;
-+int MASK_WINDOW_ROWS, MASK_WINDOW_COLS, MAIN_WINDOW_ROWS, MAIN_WINDOW_COLS;
-+int INFO_WINDOW_ROWS, INFO_WINDOW_COLS, DATA_WINDOW_ROWS, DATA_WINDOW_COLS;
-+int INFO_WINDOW_X, INFO_WINDOW_Y, MASK_WINDOW_X, MASK_WINDOW_Y;
-+int DATA_WINDOW_X, DATA_WINDOW_Y;
-
-
- /*** Sreen operations ***/
---- a/src/sn_interface.h
-+++ b/src/sn_interface.h
-@@ -1,9 +1,46 @@
- /* Sniffit Data File */
-
-+#include <sys/types.h>
-+#include <sys/stat.h>
-+#include <unistd.h>
- #include "pcap.h"
-
- typedef void (*sig_hand)(int ); /* sighandler_t gave errors, weird */
-
-+/*** global stuff ********/
-+extern unsigned int *IP_nr_of_packets;
-+extern char *SHARED, *connection_data, *timing, *running_connections,
-+ *logged_connections;
-+extern int *LISTlength, *DATAlength, memory_id;
-+extern unsigned int *TCP_nr_of_packets, *ICMP_nr_of_packets, *UDP_nr_of_packets;
-+extern unsigned int *IP_nr_of_packets;
-+extern unsigned long *TCP_bytes_in_packets, *UDP_bytes_in_packets;
-+extern int *DESC_LEN; /* For the connection desciption */
-+
-+extern char INTERACTIVE_EXTEND;
-+
-+extern struct snif_mask *mask;
-+extern struct shared_logged_conn *log_conn;
-+extern FILE *log_dev_stream;
-+extern struct stat log_dev_stat;
-+
-+extern volatile int LOGGING, screen_busy;
-+extern char PACKET_INFO;
-+extern int POINTpos, LISTpos;
-+extern unsigned char COLOR_AVAIL;
-+
-+extern WINDOW *menu_window;
-+extern struct box_window data_box, main_box, mask_box, packets_box;
-+extern int Pid;
-+extern char *logging_device;
-+
-+
-+/*** Screen Parameters ***/
-+extern int MASK_WINDOW_ROWS, MASK_WINDOW_COLS, MAIN_WINDOW_ROWS, MAIN_WINDOW_COLS;
-+extern int INFO_WINDOW_ROWS, INFO_WINDOW_COLS, DATA_WINDOW_ROWS, DATA_WINDOW_COLS;
-+extern int INFO_WINDOW_X, INFO_WINDOW_Y, MASK_WINDOW_X, MASK_WINDOW_Y;
-+extern int DATA_WINDOW_X, DATA_WINDOW_Y;
-+
- int add_itemlist(char *, char *, char *);
- void child_exit (void);
- void clear_shared_mem(char);