summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/sqlninja
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/sqlninja')
-rw-r--r--net-analyzer/sqlninja/Manifest1
-rw-r--r--net-analyzer/sqlninja/files/sqlninja4
-rw-r--r--net-analyzer/sqlninja/metadata.xml12
-rw-r--r--net-analyzer/sqlninja/sqlninja-0.2.6_p1-r1.ebuild54
4 files changed, 71 insertions, 0 deletions
diff --git a/net-analyzer/sqlninja/Manifest b/net-analyzer/sqlninja/Manifest
new file mode 100644
index 000000000000..b49139c5e608
--- /dev/null
+++ b/net-analyzer/sqlninja/Manifest
@@ -0,0 +1 @@
+DIST sqlninja-0.2.6-r1.tgz 454841 SHA256 7f8e9103d3fe58eb6e6f1476474589f7e5ca501703a82ae5299bd7a708342bc5 SHA512 18f6c8f0f1eca59d9ce6df80267f1f6bf45d151dfcd395b32d349119e1480389ba28f057778349b4276d480f60c41ca03578a1ca9c4e246f3fcb63653bc6ccf9 WHIRLPOOL 03b389d49e1854a16984db7272d391827488ca5004fa75e52e0a7b2708cfeeb1c6371c49ddf57dae332387f1ca0feca06d7b22547e1ed23ea2ba6627f9b8a9ac
diff --git a/net-analyzer/sqlninja/files/sqlninja b/net-analyzer/sqlninja/files/sqlninja
new file mode 100644
index 000000000000..bb0f9e18b747
--- /dev/null
+++ b/net-analyzer/sqlninja/files/sqlninja
@@ -0,0 +1,4 @@
+#!/bin/sh
+
+cd /usr/lib/sqlninja/
+./sqlninja $@
diff --git a/net-analyzer/sqlninja/metadata.xml b/net-analyzer/sqlninja/metadata.xml
new file mode 100644
index 000000000000..0206b2411dee
--- /dev/null
+++ b/net-analyzer/sqlninja/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <maintainer>
+ <email>pinkbyte@gentoo.org</email>
+ <name>Sergey Popov</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="sourceforge">sqlninja</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/sqlninja/sqlninja-0.2.6_p1-r1.ebuild b/net-analyzer/sqlninja/sqlninja-0.2.6_p1-r1.ebuild
new file mode 100644
index 000000000000..8621bda711d6
--- /dev/null
+++ b/net-analyzer/sqlninja/sqlninja-0.2.6_p1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit versionator
+
+MY_PV="$(replace_version_separator 3 '-')"
+MY_PV="${MY_PV/p/r}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="A SQL Server injection & takeover tool"
+HOMEPAGE="http://sqlninja.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tgz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="
+ dev-lang/perl
+ dev-perl/IO-Socket-SSL
+ dev-perl/List-MoreUtils
+ dev-perl/Net-DNS
+ dev-perl/Net-Pcap
+ dev-perl/Net-RawIP
+ dev-perl/NetPacket
+"
+
+S="${WORKDIR}/${MY_P}"
+
+src_install () {
+ dodoc sqlninja-howto.html ChangeLog README
+
+ if use doc; then
+ dodoc -r sources
+ docompress -x /usr/share/doc/"${P}"/sources
+ fi
+
+ insinto /etc/"${PN}"
+ doins sqlninja.conf.example
+
+ rm -r sources sqlninja-howto.html ChangeLog README LICENSE || die
+ rm -r apps || die
+ rm sqlninja.conf.example || die
+
+ dodir /usr/lib/"${PN}"
+ insinto /usr/lib/"${PN}"
+ exeinto /usr/lib/"${PN}"
+ doins -r *
+
+ doexe sqlninja
+ dosbin "${FILESDIR}"/"${PN}"
+}