summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-10 23:02:54 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-11 00:22:38 +0100
commit064af661d0c9a31cecdf348632bc5603333a9149 (patch)
tree2202373a7cafcb8a761d32747d4f62263aed64d5 /net-analyzer/sslsplit
parentdev-python/passlib: keyworded 1.7.1-r2 for hppa, bug #700918 (diff)
downloadgentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.gz
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.tar.bz2
gentoo-064af661d0c9a31cecdf348632bc5603333a9149.zip
*/*: [QA] Fix trivial cases of MissingTestRestrict
The result was achieved via the following pipeline: pkgcheck scan -c RestrictTestCheck -R FormatReporter \ --format '{category}/{package}/{package}-{version}.ebuild' | xargs -n32 grep -L RESTRICT | xargs -n32 sed -i -e '/^IUSE=.*test/aRESTRICT="!test? ( test )"' The resulting metadata was compared before and after the change. Few Go ebuilds had to be fixed manually due to implicit RESTRICT=strip added by the eclass. Two ebuilds have to be fixed because of multiline IUSE. Suggested-by: Robin H. Johnson <robbat2@gentoo.org> Closes: https://github.com/gentoo/gentoo/pull/13942 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'net-analyzer/sslsplit')
-rw-r--r--net-analyzer/sslsplit/sslsplit-0.5.4.ebuild1
-rw-r--r--net-analyzer/sslsplit/sslsplit-0.5.5.ebuild1
-rw-r--r--net-analyzer/sslsplit/sslsplit-9999.ebuild1
3 files changed, 3 insertions, 0 deletions
diff --git a/net-analyzer/sslsplit/sslsplit-0.5.4.ebuild b/net-analyzer/sslsplit/sslsplit-0.5.4.ebuild
index af09469872b6..7960cc011edf 100644
--- a/net-analyzer/sslsplit/sslsplit-0.5.4.ebuild
+++ b/net-analyzer/sslsplit/sslsplit-0.5.4.ebuild
@@ -11,6 +11,7 @@ HOMEPAGE="https://www.roe.ch/SSLsplit"
LICENSE="BSD-2"
SLOT="0"
IUSE="elibc_musl test"
+RESTRICT="!test? ( test )"
if [[ ${PV} == *9999 ]] ; then
inherit git-r3
diff --git a/net-analyzer/sslsplit/sslsplit-0.5.5.ebuild b/net-analyzer/sslsplit/sslsplit-0.5.5.ebuild
index 5ea7c49b62cf..2aa8a7e58600 100644
--- a/net-analyzer/sslsplit/sslsplit-0.5.5.ebuild
+++ b/net-analyzer/sslsplit/sslsplit-0.5.5.ebuild
@@ -11,6 +11,7 @@ HOMEPAGE="https://www.roe.ch/SSLsplit"
LICENSE="BSD-2"
SLOT="0"
IUSE="elibc_musl test"
+RESTRICT="!test? ( test )"
if [[ ${PV} == *9999 ]] ; then
inherit git-r3
diff --git a/net-analyzer/sslsplit/sslsplit-9999.ebuild b/net-analyzer/sslsplit/sslsplit-9999.ebuild
index 5ea7c49b62cf..2aa8a7e58600 100644
--- a/net-analyzer/sslsplit/sslsplit-9999.ebuild
+++ b/net-analyzer/sslsplit/sslsplit-9999.ebuild
@@ -11,6 +11,7 @@ HOMEPAGE="https://www.roe.ch/SSLsplit"
LICENSE="BSD-2"
SLOT="0"
IUSE="elibc_musl test"
+RESTRICT="!test? ( test )"
if [[ ${PV} == *9999 ]] ; then
inherit git-r3