summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/symon
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/symon')
-rw-r--r--net-analyzer/symon/Manifest2
-rw-r--r--net-analyzer/symon/files/symon-2.86-perl-5.18.patch38
-rw-r--r--net-analyzer/symon/files/symon-init.d33
-rw-r--r--net-analyzer/symon/files/symon.conf14
-rw-r--r--net-analyzer/symon/files/symux-init.d33
-rw-r--r--net-analyzer/symon/files/symux.conf35
-rw-r--r--net-analyzer/symon/metadata.xml12
-rw-r--r--net-analyzer/symon/symon-2.86-r1.ebuild110
-rw-r--r--net-analyzer/symon/symon-2.87.ebuild107
9 files changed, 384 insertions, 0 deletions
diff --git a/net-analyzer/symon/Manifest b/net-analyzer/symon/Manifest
new file mode 100644
index 000000000000..b2d2833bb7ab
--- /dev/null
+++ b/net-analyzer/symon/Manifest
@@ -0,0 +1,2 @@
+DIST symon-2.86.tar.gz 106791 SHA256 c36457e53e91cbb478cb57d96bf40c718a8582e0b19bd4cba247002b7a6068b3 SHA512 13f96654ee4569ac0a92fd601962d2610e83d03a59b0772c385788586ee7bcc2639012388b8c123dd6f12368e21e834c5a12c32152fc73e9e87553889962ee46 WHIRLPOOL bc94567f1c7ca36d30afd74f2747cbb239e86b8b7255541ff5ca4e2adafaed794249f455339a04c8291260430279840395e02e3733619f0e3595da2fdbfd7d21
+DIST symon-2.87.tar.gz 107607 SHA256 3c0fa1aa0073f66c45697ffc12bb8da669eb67aeac22041d21235bbc515a8602 SHA512 8fce5cf2312f1d7ba78f693da2df9fea3bbeacae0c1b65f79c5f2444fcf07e07b11a5a7229ba762ac47ce484429a42f37bcbcc9e001fce0e5813a0dffd57a953 WHIRLPOOL ce9277f03198fbfa197aaa3540d6f5226d3f449bf69a2ee083917f4afe2e6439cfcc3289792c1f1ecf727d004d6aec3f470a813700f033fa6d9e13390ed5ce22
diff --git a/net-analyzer/symon/files/symon-2.86-perl-5.18.patch b/net-analyzer/symon/files/symon-2.86-perl-5.18.patch
new file mode 100644
index 000000000000..83ea4b013dad
--- /dev/null
+++ b/net-analyzer/symon/files/symon-2.86-perl-5.18.patch
@@ -0,0 +1,38 @@
+--- a/client/SymuxClient.pm
++++ b/client/SymuxClient.pm
+@@ -267,23 +267,35 @@
+
+ =head2 METHODS
+
++=over 4
++
+ =item getitem (host, stream, item)
+
++=back
++
+ Refresh the measured data and get an item from a stream for a particular
+ host. Note that successive calls for this function deal with successive
+ measurements of B<symon>. Set C<host> to '*' if data about any host is of
+ interest. Any errors are sent out on STDOUT prepended with 'error: '.
+
++=over 4
++
+ =item getcacheditem (host, stream, item)
+
++=back
++
+ Get an item from a stream for a particular host. Returns C<undef> if no data is
+ cached, or if the data cached does not match the B<host>. Can be called
+ multiple times to obtain items from the same measurement. Set C<host> to '*' if
+ data about any host is of interest. Any errors are sent out on STDOUT prepended
+ with 'error: '.
+
++=over 4
++
+ =item getsource ()
+
++=back
++
+ Get the symon source host of the currently cached information. Usefull to see
+ what host's data getcacheditem is working on.
+
diff --git a/net-analyzer/symon/files/symon-init.d b/net-analyzer/symon/files/symon-init.d
new file mode 100644
index 000000000000..2d4cd7afcd85
--- /dev/null
+++ b/net-analyzer/symon/files/symon-init.d
@@ -0,0 +1,33 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the 2-clause BSD license
+# $Id$
+
+extra_started_commands="reload"
+
+depend() {
+ after bootmisc
+ need localmount net
+ use logger
+}
+
+reload() {
+ ebegin "Reloading symon"
+ start-stop-daemon \
+ --pidfile /run/symon.pid \
+ --exec /usr/sbin/symon \
+ --signal HUP
+ eend $?
+}
+
+start() {
+ ebegin "Starting symon"
+ start-stop-daemon --start --exec /usr/sbin/symon -- -u
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping symon"
+ start-stop-daemon --stop --pidfile /run/symon.pid
+ eend $?
+}
diff --git a/net-analyzer/symon/files/symon.conf b/net-analyzer/symon/files/symon.conf
new file mode 100644
index 000000000000..920662185e58
--- /dev/null
+++ b/net-analyzer/symon/files/symon.conf
@@ -0,0 +1,14 @@
+#
+# Demo configuration for symon. See symon(8) for BNF.
+#
+
+monitor { cpu(0), mem,
+ if(lo),
+# cpuiow(0),
+# sensor(fan0), sensor(in0), sensor(temp0),
+# if(eth0), if(eth1), if(eth2),
+# df(sda),
+# smart(sda),
+# io(hda), io(hdb), io(hdc), io(hdd)
+ io(sda)
+} stream to 127.0.0.1 2100
diff --git a/net-analyzer/symon/files/symux-init.d b/net-analyzer/symon/files/symux-init.d
new file mode 100644
index 000000000000..006fba0e6a46
--- /dev/null
+++ b/net-analyzer/symon/files/symux-init.d
@@ -0,0 +1,33 @@
+#!/sbin/runscript
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the 2-clause BSD license
+# $Id$
+
+extra_started_commands="reload"
+
+depend() {
+ after bootmisc
+ need localmount net
+ use logger
+}
+
+reload() {
+ ebegin "Reloading symux"
+ start-stop-daemon \
+ --pidfile /run/symux.pid \
+ --exec /usr/sbin/symux \
+ --signal HUP
+ eend $?
+}
+
+start() {
+ ebegin "Starting symux"
+ start-stop-daemon --start --exec /usr/sbin/symux
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping symux"
+ start-stop-daemon --stop --pidfile /run/symux.pid
+ eend $?
+}
diff --git a/net-analyzer/symon/files/symux.conf b/net-analyzer/symon/files/symux.conf
new file mode 100644
index 000000000000..fa0ed50631d7
--- /dev/null
+++ b/net-analyzer/symon/files/symux.conf
@@ -0,0 +1,35 @@
+#
+# Demo symux configuration. See symux(8) for BNF.
+#
+
+mux 127.0.0.1 2100
+
+source 127.0.0.1 {
+ accept { cpu(0), mem,
+ if(lo),
+# cpuiow(0),
+# sensor(fan0), sensor(in0), sensor(temp0),
+# if(eth0), if(eth1), if(eth2),
+# df(sda),
+# smart(sda),
+# io(hda), io(hdb), io(hdc), io(hdd)
+ io(sda)
+ }
+ datadir "/var/lib/symon/rrds/localhost"
+}
+
+# an example showing the write directive
+#
+# source 10.0.0.2 {
+# accept { cpu(0), mem, if(eth0), if(eth1),
+# if(lo), if(eth2), io(sda)
+# }
+#
+# write cpu(0) in "/var/lib/symon/rrds/<host>/cpu0.rrd"
+# write mem in "/var/lib/symon/rrds/<host>/mem.rrd"
+# write if(eth0) in "/var/lib/symon/rrds/<host>/if_eth0.rrd"
+# write if(eth1) in "/var/lib/symon/rrds/<host>/if_eth1.rrd"
+# write if(lo) in "/var/lib/symon/rrds/<host>/if_lo.rrd"
+# write if(eth2) in "/var/lib/symon/rrds/<host>/if_eth2.rrd"
+# write io(sda) in "/var/lib/symon/rrds/<host>/io_sda.rrd"
+# }
diff --git a/net-analyzer/symon/metadata.xml b/net-analyzer/symon/metadata.xml
new file mode 100644
index 000000000000..00d90d6efcf9
--- /dev/null
+++ b/net-analyzer/symon/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <use>
+ <flag name='perl'>Enables a generic perl symux client</flag>
+ <flag name='symon'>Enables the system monitor. Offers no functionality
+ but monitoring and forwarding of measured data</flag>
+ <flag name='symux'>Enables the multiplexer which stores incoming symon
+ streams on disk in RRD (<pkg>net-analyzer/rrdtool</pkg>) files</flag>
+ </use>
+</pkgmetadata>
diff --git a/net-analyzer/symon/symon-2.86-r1.ebuild b/net-analyzer/symon/symon-2.86-r1.ebuild
new file mode 100644
index 000000000000..597a0ee8ab2d
--- /dev/null
+++ b/net-analyzer/symon/symon-2.86-r1.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils perl-module toolchain-funcs
+
+DESCRIPTION="Performance and information monitoring tool"
+HOMEPAGE="http://www.xs4all.nl/~wpd/symon/"
+SRC_URI="http://www.xs4all.nl/~wpd/symon/philes/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="perl +symon symux"
+
+RDEPEND="perl? ( dev-lang/perl )
+ symux? ( net-analyzer/rrdtool )"
+DEPEND="${RDEPEND}
+ virtual/pmake"
+
+S=${WORKDIR}/${PN}
+
+# Deletes the directory passed as an argument from the internal pmake
+# variable SUBDIR.
+zap_subdir() {
+ sed -i "/^SUBDIR/s|$1||" Makefile || die
+}
+
+pkg_setup() {
+ use symon && USE_SYMON=1 && return
+
+ if ! use perl && ! use symon && ! use symux; then
+ ewarn "You have all available USE flags disabled. Therefore, only the"
+ ewarn "system monitor will be emerged. Please, enable at least one USE"
+ ewarn "flag to avoid this message."
+ USE_SYMON=1
+ fi
+}
+
+src_prepare() {
+ sed -i \
+ -e '/^[ \t]*${CC}.*\${LIBS}/s:\${CC}:$(CC) $(LDFLAGS):' \
+ sym*/Makefile || die
+
+ epatch "${FILESDIR}"/${P}-perl-5.18.patch
+}
+
+src_configure() {
+ # Do some sed magic in accordance with the USE flags.
+ use perl && [[ -z ${USE_SYMON} ]] && ! use symux && zap_subdir lib
+ ! use perl && zap_subdir client
+ ! use symux && zap_subdir symux
+ [[ -z ${USE_SYMON} ]] && zap_subdir symon
+}
+
+src_compile() {
+ pmake CC="$(tc-getCC)" CFLAGS+="${CFLAGS}" STRIP=true || die "pmake failed"
+}
+
+src_install() {
+ if [[ -n ${USE_SYMON} ]]; then
+ insinto /etc
+ doins "${FILESDIR}"/symon.conf
+
+ newinitd "${FILESDIR}"/symon-init.d symon
+
+ dodoc CHANGELOG HACKERS TODO
+
+ doman symon/symon.8
+ dosbin symon/symon
+ fi
+
+ if use perl; then
+ dobin client/getsymonitem.pl
+
+ perl_set_version
+ insinto ${VENDOR_LIB}
+ doins client/SymuxClient.pm
+ fi
+
+ if use symux; then
+ insinto /etc
+ doins "${FILESDIR}"/symux.conf
+
+ newinitd "${FILESDIR}"/symux-init.d symux
+
+ doman symux/symux.8
+ dosbin symux/symux
+
+ dodir /usr/share/symon
+ insinto /usr/share/symon
+ doins symux/c_smrrds.sh
+ fperms a+x /usr/share/symon/c_smrrds.sh
+
+ dodir /var/lib/symon/rrds/localhost
+ fi
+}
+
+pkg_postinst() {
+ if use symux; then
+ elog "The RRDs files can be obtained by running"
+ elog "/usr/share/symon/c_smrrds.sh all."
+ elog "For information about migrating RRDs from a previous"
+ elog "symux version read the LEGACY FORMATS section of symux(8)."
+ elog "To view the rrdtool pictures of the stored data, emerge"
+ elog "net-analyzer/syweb."
+ fi
+}
diff --git a/net-analyzer/symon/symon-2.87.ebuild b/net-analyzer/symon/symon-2.87.ebuild
new file mode 100644
index 000000000000..3ac8f5483f5d
--- /dev/null
+++ b/net-analyzer/symon/symon-2.87.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils perl-module toolchain-funcs
+
+DESCRIPTION="Performance and information monitoring tool"
+HOMEPAGE="http://www.xs4all.nl/~wpd/symon/"
+SRC_URI="http://www.xs4all.nl/~wpd/symon/philes/${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE="perl +symon symux"
+
+RDEPEND="perl? ( dev-lang/perl )
+ symux? ( net-analyzer/rrdtool )"
+DEPEND="${RDEPEND}
+ virtual/pmake"
+
+S=${WORKDIR}/${PN}
+
+# Deletes the directory passed as an argument from the internal pmake
+# variable SUBDIR.
+zap_subdir() {
+ sed -i "/^SUBDIR/s|$1||" Makefile || die
+}
+
+pkg_setup() {
+ use symon && USE_SYMON=1 && return
+
+ if ! use perl && ! use symon && ! use symux; then
+ ewarn "You have all available USE flags disabled. Therefore, only the"
+ ewarn "system monitor will be emerged. Please, enable at least one USE"
+ ewarn "flag to avoid this message."
+ USE_SYMON=1
+ fi
+}
+
+src_prepare() {
+ sed -i \
+ -e '/^[ \t]*${CC}.*\${LIBS}/s:\${CC}:$(CC) $(LDFLAGS):' \
+ sym*/Makefile || die
+}
+
+src_configure() {
+ # Do some sed magic in accordance with the USE flags.
+ use perl && [[ -z ${USE_SYMON} ]] && ! use symux && zap_subdir lib
+ ! use perl && zap_subdir client
+ ! use symux && zap_subdir symux
+ [[ -z ${USE_SYMON} ]] && zap_subdir symon
+}
+
+src_compile() {
+ pmake CC="$(tc-getCC)" CFLAGS+="${CFLAGS}" STRIP=true || die "pmake failed"
+}
+
+src_install() {
+ if [[ -n ${USE_SYMON} ]]; then
+ insinto /etc
+ doins "${FILESDIR}"/symon.conf
+
+ newinitd "${FILESDIR}"/symon-init.d symon
+
+ dodoc CHANGELOG HACKERS TODO
+
+ doman symon/symon.8
+ dosbin symon/symon
+ fi
+
+ if use perl; then
+ dobin client/getsymonitem.pl
+
+ perl_set_version
+ insinto ${VENDOR_LIB}
+ doins client/SymuxClient.pm
+ fi
+
+ if use symux; then
+ insinto /etc
+ doins "${FILESDIR}"/symux.conf
+
+ newinitd "${FILESDIR}"/symux-init.d symux
+
+ doman symux/symux.8
+ dosbin symux/symux
+
+ dodir /usr/share/symon
+ insinto /usr/share/symon
+ doins symux/c_smrrds.sh
+ fperms a+x /usr/share/symon/c_smrrds.sh
+
+ dodir /var/lib/symon/rrds/localhost
+ fi
+}
+
+pkg_postinst() {
+ if use symux; then
+ elog "The RRDs files can be obtained by running"
+ elog "/usr/share/symon/c_smrrds.sh all."
+ elog "For information about migrating RRDs from a previous"
+ elog "symux version read the LEGACY FORMATS section of symux(8)."
+ elog "To view the rrdtool pictures of the stored data, emerge"
+ elog "net-analyzer/syweb."
+ fi
+}