summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHasan ÇALIŞIR <hasan.calisir@psauxit.com>2019-03-20 03:59:43 +0300
committerPatrice Clement <monsieurp@gentoo.org>2019-03-20 22:35:18 +0100
commit06c9d82e1918d3d2fa3c95d66b7a95b50b5240e7 (patch)
treec5093f9c6d3244008b2831e05111bc8efcc3b050 /net-analyzer/synscan/synscan-5.02.ebuild
parentdev-python/dask: version bump to 1.1.3 EAPI bump 7. (diff)
downloadgentoo-06c9d82e1918d3d2fa3c95d66b7a95b50b5240e7.tar.gz
gentoo-06c9d82e1918d3d2fa3c95d66b7a95b50b5240e7.tar.bz2
gentoo-06c9d82e1918d3d2fa3c95d66b7a95b50b5240e7.zip
net-analyzer/synscan: bump to version 5.02, EAPI 7.
Signed-off-by: Hasan ÇALIŞIR <hasan.calisir@psauxit.com> Package-Manager: Portage-2.3.62, Repoman-2.3.11 Closes: https://github.com/gentoo/gentoo/pull/11419 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'net-analyzer/synscan/synscan-5.02.ebuild')
-rw-r--r--net-analyzer/synscan/synscan-5.02.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-analyzer/synscan/synscan-5.02.ebuild b/net-analyzer/synscan/synscan-5.02.ebuild
new file mode 100644
index 000000000000..734a7d101fba
--- /dev/null
+++ b/net-analyzer/synscan/synscan-5.02.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools eutils
+
+DESCRIPTION="A fast asynchronous half-open TCP portscanner"
+HOMEPAGE="http://www.digit-labs.org/files/tools/synscan/"
+SRC_URI="http://www.digit-labs.org/files/tools/${PN}/releases/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="kernel_FreeBSD kernel_linux"
+
+RDEPEND="net-libs/libpcap"
+DEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-destdir.patch"
+)
+
+src_prepare() {
+ default
+ mv "$S"/configure.in "$S"/configure.ac || die
+ eautoconf
+}
+
+src_configure() {
+ econf --prefix="${EPREFIX}"/usr
+}
+
+src_compile() {
+ local _target
+ use kernel_FreeBSD && _target=freebsd
+ use kernel_linux && _target=linux
+
+ emake ${_target}
+}