summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-02 01:50:33 +0100
committerSam James <sam@gentoo.org>2021-04-03 17:10:29 +0100
commit9df4894edb868c80d3e867d5c36af980989aaf39 (patch)
tree9bc3b02a89297e9ae96648d4441975ccb5f8a2f5 /net-analyzer/tcpreplay
parentnet-analyzer/synscan: ~x64-macos keyworded (diff)
downloadgentoo-9df4894edb868c80d3e867d5c36af980989aaf39.tar.gz
gentoo-9df4894edb868c80d3e867d5c36af980989aaf39.tar.bz2
gentoo-9df4894edb868c80d3e867d5c36af980989aaf39.zip
net-analyzer/tcpreplay: EAPI 7, flag-o-matic--
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer/tcpreplay')
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-4.3.3.ebuild29
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-999999.ebuild31
2 files changed, 33 insertions, 27 deletions
diff --git a/net-analyzer/tcpreplay/tcpreplay-4.3.3.ebuild b/net-analyzer/tcpreplay/tcpreplay-4.3.3.ebuild
index a5ce8388372c..3df344d41601 100644
--- a/net-analyzer/tcpreplay/tcpreplay-4.3.3.ebuild
+++ b/net-analyzer/tcpreplay/tcpreplay-4.3.3.ebuild
@@ -1,36 +1,39 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools flag-o-matic
-DESCRIPTION="utilities for editing and replaying previously captured network traffic"
+inherit autotools
+
+DESCRIPTION="Utilities for editing and replaying previously captured network traffic"
HOMEPAGE="http://tcpreplay.appneta.com/ https://github.com/appneta/tcpreplay"
-LICENSE="BSD GPL-3"
SRC_URI="https://github.com/appneta/${PN}/releases/download/v${PV}/${P}.tar.xz"
+S="${WORKDIR}"/${P/_/-}
+LICENSE="BSD GPL-3"
SLOT="0"
KEYWORDS="amd64 ~arm ~sparc x86"
IUSE="debug pcapnav +tcpdump"
-DEPEND="
+# libpcapnav for pcapnav-config
+BDEPEND="
+ net-libs/libpcapnav
>=sys-devel/autogen-5.18.4[libopts]
+"
+DEPEND="
dev-libs/libdnet
>=net-libs/libpcap-0.9
- tcpdump? ( net-analyzer/tcpdump )
pcapnav? ( net-libs/libpcapnav )
+ tcpdump? ( net-analyzer/tcpdump )
"
RDEPEND="${DEPEND}"
-DOCS=(
- docs/{CHANGELOG,CREDIT,HACKING,TODO}
-)
+DOCS=( docs/{CHANGELOG,CREDIT,HACKING,TODO} )
+
PATCHES=(
"${FILESDIR}"/${PN}-4.3.0-enable-pcap_findalldevs.patch
)
-S=${WORKDIR}/${P/_/-}
-
src_prepare() {
default
@@ -50,8 +53,8 @@ src_configure() {
# By default it uses static linking. Avoid that, bug 252940
econf \
$(use_enable debug) \
- $(use_with pcapnav pcapnav-config /usr/bin/pcapnav-config) \
- $(use_with tcpdump tcpdump /usr/sbin/tcpdump) \
+ $(use_with pcapnav pcapnav-config "${BROOT}"/usr/bin/pcapnav-config) \
+ $(use_with tcpdump tcpdump "${ESYSROOT}"/usr/sbin/tcpdump) \
--enable-dynamic-link \
--enable-local-libopts \
--enable-shared \
diff --git a/net-analyzer/tcpreplay/tcpreplay-999999.ebuild b/net-analyzer/tcpreplay/tcpreplay-999999.ebuild
index 9e2776949df2..52407c59ac72 100644
--- a/net-analyzer/tcpreplay/tcpreplay-999999.ebuild
+++ b/net-analyzer/tcpreplay/tcpreplay-999999.ebuild
@@ -1,35 +1,38 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit autotools flag-o-matic git-r3
-DESCRIPTION="utilities for editing and replaying previously captured network traffic"
+inherit autotools git-r3
+
+DESCRIPTION="Utilities for editing and replaying previously captured network traffic"
HOMEPAGE="http://tcpreplay.appneta.com/ https://github.com/appneta/tcpreplay"
-LICENSE="BSD GPL-3"
EGIT_REPO_URI="https://github.com/appneta/tcpreplay"
+S="${WORKDIR}"/${P/_/-}
+LICENSE="BSD GPL-3"
SLOT="0"
-KEYWORDS=""
IUSE="debug pcapnav +tcpdump"
-DEPEND="
+# libpcapnav for pcapnav-config
+BDEPEND="
+ net-libs/libpcapnav
>=sys-devel/autogen-5.18.4[libopts]
+"
+DEPEND="
dev-libs/libdnet
>=net-libs/libpcap-0.9
- tcpdump? ( net-analyzer/tcpdump )
pcapnav? ( net-libs/libpcapnav )
+ tcpdump? ( net-analyzer/tcpdump )
"
RDEPEND="${DEPEND}"
-DOCS=(
- docs/{CHANGELOG,CREDIT,HACKING,TODO}
-)
+
+DOCS=( docs/{CHANGELOG,CREDIT,HACKING,TODO} )
+
PATCHES=(
"${FILESDIR}"/${PN}-4.3.0-enable-pcap_findalldevs.patch
)
-S=${WORKDIR}/${P/_/-}
-
src_prepare() {
default
@@ -49,8 +52,8 @@ src_configure() {
# By default it uses static linking. Avoid that, bug 252940
econf \
$(use_enable debug) \
- $(use_with pcapnav pcapnav-config /usr/bin/pcapnav-config) \
- $(use_with tcpdump tcpdump /usr/sbin/tcpdump) \
+ $(use_with pcapnav pcapnav-config "${BROOT}"/usr/bin/pcapnav-config) \
+ $(use_with tcpdump tcpdump "${ESYSROOT}"/usr/sbin/tcpdump) \
--disable-local-libopts \
--enable-dynamic-link \
--enable-shared \