summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/w3af/w3af-1.1-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/w3af/w3af-1.1-r1.ebuild')
-rw-r--r--net-analyzer/w3af/w3af-1.1-r1.ebuild71
1 files changed, 71 insertions, 0 deletions
diff --git a/net-analyzer/w3af/w3af-1.1-r1.ebuild b/net-analyzer/w3af/w3af-1.1-r1.ebuild
new file mode 100644
index 000000000000..25f30027ca3e
--- /dev/null
+++ b/net-analyzer/w3af/w3af-1.1-r1.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="sqlite"
+
+inherit multilib python-single-r1 versionator
+
+MY_P=${PN}-"$(replace_version_separator 2 '-')"
+
+DESCRIPTION="Web Application Attack and Audit Framework"
+HOMEPAGE="http://w3af.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc gtk"
+
+RDEPEND="
+ >=dev-python/fpconst-0.7.2[${PYTHON_USEDEP}]
+ dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nltk[${PYTHON_USEDEP}]
+ dev-python/pybloomfiltermmap[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyPdf[${PYTHON_USEDEP}]
+ dev-python/python-cluster[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ dev-python/soappy[${PYTHON_USEDEP}]
+ dev-python/pysvn[${PYTHON_USEDEP}]
+ || (
+ net-analyzer/gnu-netcat
+ net-analyzer/netcat
+ net-analyzer/netcat6
+ )
+ >=net-analyzer/scapy-2
+ gtk? (
+ media-gfx/graphviz
+ >dev-python/pygtk-2.0
+ dev-python/pygtksourceview
+ )"
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+S=${WORKDIR}/${PN}
+
+src_prepare(){
+ rm -r extlib/{cluster,fpconst-0.7.2,pyPdf,SOAPpy,yaml} || die
+ sed -i 's,extlib.pyPdf.,,' core/data/parsers/pdfParser.py || die
+ rm readme/{GPL,INSTALL} || die
+ rm plugins/attack/payloads/code/netcat || die #bug 349780
+ esvn_clean
+}
+
+src_install() {
+ insinto /usr/$(get_libdir)/w3af
+ doins -r core extlib locales plugins profiles scripts tools w3af_gui w3af_console
+ fperms +x /usr/$(get_libdir)/w3af/w3af_{gui,console}
+ dobin "${FILESDIR}"/w3af_console
+ use gtk && dobin "${FILESDIR}"/w3af_gui
+ #use flag doc is here because doc is bigger than 3 Mb
+ if use doc ; then
+ insinto /usr/share/doc/${PF}/
+ doins -r readme/*
+ fi
+ python_fix_shebang "${ED}"usr/$(get_libdir)/${PN}
+}