summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2018-12-16 15:45:47 +0100
committerJeroen Roovers <jer@gentoo.org>2018-12-16 15:47:27 +0100
commita5ae2b3242b616030e6b9ad5837f659df7bd899f (patch)
tree04057c8259a78c77322c13e870c2b5e7060f354c /net-analyzer/wireshark
parentapp-editors/ghostwriter: verbump to 1.7.4 (diff)
downloadgentoo-a5ae2b3242b616030e6b9ad5837f659df7bd899f.tar.gz
gentoo-a5ae2b3242b616030e6b9ad5837f659df7bd899f.tar.bz2
gentoo-a5ae2b3242b616030e6b9ad5837f659df7bd899f.zip
net-analyzer/wireshark: "Add home-grown" code to make doins faster
While there, fix tfshark linking in the live ebuild, too. Package-Manager: Portage-2.3.52, Repoman-2.3.12 Fixes: https://bugs.gentoo.org/656834 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/wireshark')
-rw-r--r--net-analyzer/wireshark/wireshark-2.9.0-r1.ebuild41
-rw-r--r--net-analyzer/wireshark/wireshark-99999999.ebuild42
2 files changed, 35 insertions, 48 deletions
diff --git a/net-analyzer/wireshark/wireshark-2.9.0-r1.ebuild b/net-analyzer/wireshark/wireshark-2.9.0-r1.ebuild
index d3a4760a0592..ef9526baa665 100644
--- a/net-analyzer/wireshark/wireshark-2.9.0-r1.ebuild
+++ b/net-analyzer/wireshark/wireshark-2.9.0-r1.ebuild
@@ -167,31 +167,24 @@ src_install() {
dodoc AUTHORS ChangeLog NEWS README* doc/randpkt.txt doc/README*
# install headers
- local wsheader
- for wsheader in \
- epan/*.h \
- epan/crypt/*.h \
- epan/dfilter/*.h \
- epan/dissectors/*.h \
- epan/ftypes/*.h \
- epan/wmem/*.h \
- wiretap/*.h \
- ws_diag_control.h \
- ws_symbol_export.h \
- wsutil/*.h
- do
- echo "Installing ${wsheader}"
- insinto /usr/include/wireshark/$( dirname ${wsheader} )
- doins ${wsheader}
- done
-
- for wsheader in \
- ../${P}_build/config.h \
- ../${P}_build/version.h
+ insinto /usr/include/wireshark
+ doins ws_diag_control.h ws_symbol_export.h \
+ "${BUILD_DIR}"/config.h "${BUILD_DIR}"/version.h
+
+ local dir dirs=(
+ epan
+ epan/crypt
+ epan/dfilter
+ epan/dissectors
+ epan/ftypes
+ epan/wmem
+ wiretap
+ wsutil
+ )
+ for dir in "${dirs[@]}"
do
- echo "Installing ${wsheader}"
- insinto /usr/include/wireshark
- doins ${wsheader}
+ insinto /usr/include/wireshark/${dir}
+ doins ${dir}/*.h
done
#with the above this really shouldn't be needed, but things may be looking
diff --git a/net-analyzer/wireshark/wireshark-99999999.ebuild b/net-analyzer/wireshark/wireshark-99999999.ebuild
index c6adaa7403d0..1971febe690d 100644
--- a/net-analyzer/wireshark/wireshark-99999999.ebuild
+++ b/net-analyzer/wireshark/wireshark-99999999.ebuild
@@ -80,6 +80,7 @@ REQUIRED_USE="${PYTHON_REQUIRED_USE}"
PATCHES=(
"${FILESDIR}"/${PN}-2.4-androiddump.patch
"${FILESDIR}"/${PN}-2.6.0-redhat.patch
+ "${FILESDIR}"/${PN}-2.9.0-tfshark-libm.patch
"${FILESDIR}"/${PN}-99999999-androiddump-wsutil.patch
"${FILESDIR}"/${PN}-99999999-qtsvg.patch
"${FILESDIR}"/${PN}-99999999-ui-needs-wiretap.patch
@@ -166,31 +167,24 @@ src_install() {
dodoc AUTHORS ChangeLog NEWS README* doc/randpkt.txt doc/README*
# install headers
- local wsheader
- for wsheader in \
- epan/*.h \
- epan/crypt/*.h \
- epan/dfilter/*.h \
- epan/dissectors/*.h \
- epan/ftypes/*.h \
- epan/wmem/*.h \
- wiretap/*.h \
- ws_diag_control.h \
- ws_symbol_export.h \
- wsutil/*.h
- do
- echo "Installing ${wsheader}"
- insinto /usr/include/wireshark/$( dirname ${wsheader} )
- doins ${wsheader}
- done
-
- for wsheader in \
- ../${P}_build/config.h \
- ../${P}_build/version.h
+ insinto /usr/include/wireshark
+ doins ws_diag_control.h ws_symbol_export.h \
+ "${BUILD_DIR}"/config.h "${BUILD_DIR}"/version.h
+
+ local dir dirs=(
+ epan
+ epan/crypt
+ epan/dfilter
+ epan/dissectors
+ epan/ftypes
+ epan/wmem
+ wiretap
+ wsutil
+ )
+ for dir in "${dirs[@]}"
do
- echo "Installing ${wsheader}"
- insinto /usr/include/wireshark
- doins ${wsheader}
+ insinto /usr/include/wireshark/${dir}
+ doins ${dir}/*.h
done
#with the above this really shouldn't be needed, but things may be looking