summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-analyzer/xprobe
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-analyzer/xprobe')
-rw-r--r--net-analyzer/xprobe/Manifest1
-rw-r--r--net-analyzer/xprobe/files/xprobe-0.3-gcc43.patch29
-rw-r--r--net-analyzer/xprobe/metadata.xml14
-rw-r--r--net-analyzer/xprobe/xprobe-0.3.ebuild31
4 files changed, 75 insertions, 0 deletions
diff --git a/net-analyzer/xprobe/Manifest b/net-analyzer/xprobe/Manifest
new file mode 100644
index 000000000000..8ba8d21f6579
--- /dev/null
+++ b/net-analyzer/xprobe/Manifest
@@ -0,0 +1 @@
+DIST xprobe2-0.3.tar.gz 533636 SHA256 12a9d0a2f38da8bb74c9e1cd96b2019802632cf55f8948384aafd417bb79a164 SHA512 fd499ada22be5df3e01630948cb72d1a9e648e0c7bfaf2a688386a61c67bb36a326a9e2f3f2b9960a6a49128343010aafe8a3f04ec05e89420a1384215e41f21 WHIRLPOOL 6b5b9ec1b1786c186f63912dcc424b0750bd98acee20ffe729d77ca7c474d5f0a531a6089db5fe791135bb2a584e5ea01f7f06ac4bb4344844f06e11e5ff7bd1
diff --git a/net-analyzer/xprobe/files/xprobe-0.3-gcc43.patch b/net-analyzer/xprobe/files/xprobe-0.3-gcc43.patch
new file mode 100644
index 000000000000..1175631b9a16
--- /dev/null
+++ b/net-analyzer/xprobe/files/xprobe-0.3-gcc43.patch
@@ -0,0 +1,29 @@
+--- a/libs-external/USI++/src/ip.cc
++++ b/libs-external/USI++/src/ip.cc
+@@ -13,6 +13,7 @@
+ #include "usi++/ip.h"
+
+ #include "config.h"
++#include <cstdlib>
+ #include <iostream>
+ #include <string.h>
+ #include <errno.h>
+--- a/libs-external/USI++/src/misc.cc
++++ b/libs-external/USI++/src/misc.cc
+@@ -1,5 +1,6 @@
+ #include "usi++/usi++"
+ #include "usi++/usi-structs.h"
++#include <cstdlib>
+ #include <string.h>
+ #include <unistd.h>
+ #include <sys/ioctl.h>
+--- a/libs-external/USI++/usi++/tcp.h
++++ b/libs-external/USI++/usi++/tcp.h
+@@ -15,6 +15,7 @@
+ #include "usi-structs.h"
+ #include "datalink.h"
+ #include "ip.h"
++#include <cstring>
+
+ namespace usipp {
+
diff --git a/net-analyzer/xprobe/metadata.xml b/net-analyzer/xprobe/metadata.xml
new file mode 100644
index 000000000000..b17f052c15e8
--- /dev/null
+++ b/net-analyzer/xprobe/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>netmon</herd>
+ <longdescription>
+Active OS fingerprinting tool. This is the new xprobe, called xprobe2, due to
+xprobe1 being obsoleted. xprobe2 has a different approach to OS fingerprinting.
+xprobe2 relies on fuzzy signature matching, probabilistic guesses, multiple
+matches simultaneously, and a signature database.
+</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">xprobe</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-analyzer/xprobe/xprobe-0.3.ebuild b/net-analyzer/xprobe/xprobe-0.3.ebuild
new file mode 100644
index 000000000000..f16e943c9ea0
--- /dev/null
+++ b/net-analyzer/xprobe/xprobe-0.3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit eutils
+
+MY_P=${PN}2-${PV}
+
+DESCRIPTION="Active OS fingerprinting tool - this is Xprobe2"
+HOMEPAGE="http://sys-security.com/blog/xprobe2"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc x86"
+
+DEPEND="net-libs/libpcap"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc43.patch
+ sed -i -e 's:strip:true:' src/Makefile.in || die
+}
+
+src_install() {
+ default
+ dodoc AUTHORS CHANGELOG CREDITS README TODO docs/*.{txt,pdf}
+}