summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-01-28 16:37:51 +0100
committerJeroen Roovers <jer@gentoo.org>2020-01-28 16:38:25 +0100
commitd4645a4940923b40d8785e4ea7e6d774f81b0785 (patch)
tree01147fef8e33a9f36093d19ee3f047364a167dc5 /net-analyzer/yersinia
parentnet-analyzer/yersinia: Set CFLAGS=-fcommon (diff)
downloadgentoo-d4645a4940923b40d8785e4ea7e6d774f81b0785.tar.gz
gentoo-d4645a4940923b40d8785e4ea7e6d774f81b0785.tar.bz2
gentoo-d4645a4940923b40d8785e4ea7e6d774f81b0785.zip
net-analyzer/yersinia: Add live ebuild
Package-Manager: Portage-2.3.85, Repoman-2.3.20 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer/yersinia')
-rw-r--r--net-analyzer/yersinia/files/yersinia-9999-tinfo.patch27
-rw-r--r--net-analyzer/yersinia/yersinia-9999.ebuild59
2 files changed, 86 insertions, 0 deletions
diff --git a/net-analyzer/yersinia/files/yersinia-9999-tinfo.patch b/net-analyzer/yersinia/files/yersinia-9999-tinfo.patch
new file mode 100644
index 000000000000..b5bf566c107d
--- /dev/null
+++ b/net-analyzer/yersinia/files/yersinia-9999-tinfo.patch
@@ -0,0 +1,27 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -467,6 +467,7 @@
+ AC_DEFINE(HAVE_REMOTE_ADMIN)
+ fi
+
++PKG_CHECK_MODULES(ncurses,ncurses)
+
+ dnl Curses detection: Munged from Midnight Commander's configure.in
+ dnl
+@@ -616,6 +617,16 @@
+ AC_DEFINE(USE_NCURSES)
+ AC_DEFINE(HAS_CURSES)
+ has_curses=true
++ else
++ if test "$ncurses_LIBS" ; then
++ CURSES_LIBS="$ncurses_LIBS"
++ CURSES_INCLUDEDIR="$ncurses_CFLAGS"
++ search_ncurses=false
++ screen_manager="ncurses"
++ AC_DEFINE(USE_NCURSES)
++ AC_DEFINE(HAS_CURSES)
++ has_curses=true
++ fi
+ fi
+ )
+
diff --git a/net-analyzer/yersinia/yersinia-9999.ebuild b/net-analyzer/yersinia/yersinia-9999.ebuild
new file mode 100644
index 000000000000..f2825d6f6f13
--- /dev/null
+++ b/net-analyzer/yersinia/yersinia-9999.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools flag-o-matic git-r3
+
+DESCRIPTION="A framework for layer 2 attacks"
+HOMEPAGE="https://github.com/tomac/yersinia"
+EGIT_REPO_URI="https://github.com/tomac/yersinia"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="gtk ncurses"
+
+RDEPEND="
+ ncurses? ( >=sys-libs/ncurses-5.5:= )
+ gtk? (
+ dev-libs/glib:2
+ x11-libs/gdk-pixbuf
+ =x11-libs/gtk+-2*
+ )
+ >=net-libs/libnet-1.1.2
+ >=net-libs/libpcap-0.9.4
+"
+DEPEND="
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+DOCS=( AUTHORS ChangeLog FAQ README THANKS TODO )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.7.1-no-ncurses.patch
+ "${FILESDIR}"/${PN}-9999-tinfo.patch
+)
+
+src_prepare() {
+ default
+
+ if ! use gtk; then
+ #bug #514802
+ sed -i -e '/AM_GLIB_GNU_GETTEXT/d' configure.in || die
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ append-cflags -fcommon
+
+ econf \
+ --enable-admin \
+ --with-pcap-includes=/usr/include \
+ $(use_with ncurses) \
+ $(use_enable gtk)
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}