summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-04-26 20:47:59 +0200
committerJustin Lecher <jlec@gentoo.org>2016-04-26 20:48:30 +0200
commit35f2f281e6a5efc3be4624e136facf329bab9bde (patch)
tree08dd268402485ec65cc2e610910767a289e85228 /net-analyzer/zmap/zmap-2.1.1.ebuild
parentxfce-extra/xfce4-sensors-plugin: Adopt to new nvdia-drivers situation (diff)
downloadgentoo-35f2f281e6a5efc3be4624e136facf329bab9bde.tar.gz
gentoo-35f2f281e6a5efc3be4624e136facf329bab9bde.tar.bz2
gentoo-35f2f281e6a5efc3be4624e136facf329bab9bde.zip
net-analyzer/zmap: Version Bump
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=580810 Package-Manager: portage-2.2.28 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'net-analyzer/zmap/zmap-2.1.1.ebuild')
-rw-r--r--net-analyzer/zmap/zmap-2.1.1.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/net-analyzer/zmap/zmap-2.1.1.ebuild b/net-analyzer/zmap/zmap-2.1.1.ebuild
new file mode 100644
index 000000000000..30d206f0734b
--- /dev/null
+++ b/net-analyzer/zmap/zmap-2.1.1.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit cmake-utils fcaps
+
+DESCRIPTION="Fast network scanner designed for Internet-wide network surveys"
+HOMEPAGE="https://zmap.io/"
+SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86"
+IUSE="json mongo redis"
+
+RDEPEND="
+ dev-libs/gmp:0
+ net-libs/libpcap
+ json? ( dev-libs/json-c )
+ mongo? ( dev-db/mongodb )
+ redis? ( dev-libs/hiredis )"
+DEPEND="${RDEPEND}
+ dev-util/gengetopt
+ sys-devel/flex
+ dev-util/byacc"
+
+src_prepare() {
+ sed \
+ -e '/ggo/s:CMAKE_CURRENT_SOURCE_DIR}:CMAKE_BINARY_DIR}/src:g' \
+ -i src/CMakeLists.txt || die
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DENABLE_DEVELOPMENT=OFF
+ -DENABLE_HARDENING=OFF
+ -DWITH_WERROR=OFF
+ -DWITH_json="$(usex json)"
+ -DWITH_json="$(usex mongo)"
+ -DWITH_json="$(usex redis)"
+ )
+ cmake-utils_src_configure
+}
+
+FILECAPS=( cap_net_raw=ep usr/sbin/zmap )