summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2016-05-25 09:25:21 -0400
committerMichael Orlitzky <mjo@gentoo.org>2016-05-25 09:25:38 -0400
commit05cc9dc260cd9098de4bd2d940f3b6bf27541e10 (patch)
tree06c12df2bc1c603b6e5e3e459eae32eebc8ed848 /net-analyzer
parentapp-arch/pdlzip: Bump to 1.7 (diff)
downloadgentoo-05cc9dc260cd9098de4bd2d940f3b6bf27541e10.tar.gz
gentoo-05cc9dc260cd9098de4bd2d940f3b6bf27541e10.tar.bz2
gentoo-05cc9dc260cd9098de4bd2d940f3b6bf27541e10.zip
net-analyzer/nagios-check_rbl: new revision for perl-5.24 compatibility.
The tarball for this package was shipped with a copy of inc/version.pm that was causing problems with perl-5.24. Since v1.3.7 was added to the tree, upstream has moved SRC_URI to github, and re-released v1.3.7 with modified source code. The new tarball does not exhibit the version.pm problem. To fix the issue, this revision uses the new tarball, but renames it to include the -r1 suffix so that users don't see checksum failures. We are also removing inc/version.pm in src_prepare(). Comments have been added to the ebuild so that we can check for an upstream fix at a later time. The new revision also uses EAPI=6. Gentoo-Bug: 583966 Package-Manager: portage-2.2.28
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-check_rbl/Manifest2
-rw-r--r--net-analyzer/nagios-check_rbl/nagios-check_rbl-1.3.7-r1.ebuild (renamed from net-analyzer/nagios-check_rbl/nagios-check_rbl-1.3.7.ebuild)33
2 files changed, 27 insertions, 8 deletions
diff --git a/net-analyzer/nagios-check_rbl/Manifest b/net-analyzer/nagios-check_rbl/Manifest
index 706828e06a06..2c2a627ab52b 100644
--- a/net-analyzer/nagios-check_rbl/Manifest
+++ b/net-analyzer/nagios-check_rbl/Manifest
@@ -1,2 +1,2 @@
DIST check_rbl-1.3.0.tar.gz 32179 SHA256 c713dc226a9d56af6d51863c5f594f34c49227d8af48984085c8b3b137b2d247 SHA512 773610abc1b8521843353f7053e2ce7996fa3178087eb468f628c60d099f4a5658d47fef2b35867363fc9d4de30b849858f2e28f8c70a17baa30d07d7b9ebf2f WHIRLPOOL 7afe3d34333ebb2e79ac4214aefa47d6abe35b1585144ce6395eed686b348543ae4b46d00c9fbc1e0e35f5def8bc87e9b7c90a334600e55fa63bdd07247701a1
-DIST check_rbl-1.3.7.tar.gz 39385 SHA256 b9523db1d0895bb08ac34fb0d20c1a3ff53066fdfcccc62e980e1a9b2e30a9f7 SHA512 ceb00b41ef49ed9cc8f5c7eb8b3a994b59d88f486e5cdb821c842da5d92a091033a2294c642c55b449188fb434585606f024e734c8b7c9f0e655bf4baaba314e WHIRLPOOL 16b0e113f599eed8237423362372dd3afab0a8ab6710fee968586ee0b7b8cbca563b2ecc0fd089edb9e075da1e49ea4a06df74e2601c164fac60961bb47352d1
+DIST check_rbl-1.3.7-r1.tar.gz 38565 SHA256 dbe76bd24ab9404817f74fd895dfeb1c55d296fe9a8264a4c631c5139ea31247 SHA512 a918090b2c1e93095b155215de559b0d7f35c949e9c9d27c7b6dc91e21391b03d716154dd90ea1a68deeabce5afde3c9e5746190910f18bf1d3e08ff20d02431 WHIRLPOOL 31a13de7cfc650deea83d8c7cf148358046260502c34e3d643ad53c1e96854b0194da80fac3d95cf5fa06b01d9224fb9716ce3e281148ce174f89e75bb418023
diff --git a/net-analyzer/nagios-check_rbl/nagios-check_rbl-1.3.7.ebuild b/net-analyzer/nagios-check_rbl/nagios-check_rbl-1.3.7-r1.ebuild
index c4a221771f3f..c75db07605cb 100644
--- a/net-analyzer/nagios-check_rbl/nagios-check_rbl-1.3.7.ebuild
+++ b/net-analyzer/nagios-check_rbl/nagios-check_rbl-1.3.7-r1.ebuild
@@ -1,17 +1,24 @@
-# Copyright 1999-2015 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
-inherit multilib
+# Needed for perl_rm_files in src_prepare() only.
+inherit perl-functions
-DESCRIPTION="check_rbl is a Nagios plugin that fails if a host is blacklisted"
-HOMEPAGE="https://svn.id.ethz.ch/projects/nagios_plugins/wiki/check_rbl"
+DESCRIPTION="Monitor whether or not a host is blacklisted"
+HOMEPAGE="https://github.com/matteocorti/check_rbl"
MY_P="${P/nagios-/}"
-SRC_URI="https://svn.id.ethz.ch/projects/nagios_plugins/downloads/${MY_P}.tar.gz"
+# We rename the tarball here because the upstream source changed without
+# a new release. That change happens to fix bug #583966, so we do want
+# the newer tarball. But I think, without the rename, that user might
+# have gotten a checksum failure.
+SRC_URI="${HOMEPAGE}/releases/download/v${PV}/${MY_P}.tar.gz
+ -> ${MY_P}-r1.tar.gz"
+
LICENSE="GPL-3"
SLOT="0"
@@ -39,6 +46,17 @@ DEPEND="${RDEPEND}"
S="${WORKDIR}/${MY_P}"
+src_prepare() {
+ default
+
+ # The copy of version.pm that upstream ships causes problems and
+ # isn't necessary. They probably shouldn't be shipping it at all.
+ # See bug #583966 for more information. You should check on
+ # https://github.com/matteocorti/check_rbl/issues/6 every once
+ # in a while to see if this can be removed.
+ perl_rm_files inc/version.pm
+}
+
src_configure() {
perl Makefile.PL INSTALLDIRS=vendor || die
}
@@ -47,7 +65,8 @@ src_install() {
default
local nagiosplugindir=/usr/$(get_libdir)/nagios/plugins
- # move this aftertime as it's a bit strange otherwise
+
+ # It's simplest to move this file after it's been installed.
dodir "${nagiosplugindir}"
mv "${D}"/usr/bin/check_rbl "${D}"/"${nagiosplugindir}" || die
}