summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-02-03 20:21:31 +0100
committerJeroen Roovers <jer@gentoo.org>2017-02-03 20:21:47 +0100
commit1040e3744323f8f0ed2b5001a206271bbfe9c274 (patch)
tree697c7c9073ac8e5648b63f39fdb00de7a49a608d /net-analyzer
parentnet-analyzer/cacti: Version bump. (diff)
downloadgentoo-1040e3744323f8f0ed2b5001a206271bbfe9c274.tar.gz
gentoo-1040e3744323f8f0ed2b5001a206271bbfe9c274.tar.bz2
gentoo-1040e3744323f8f0ed2b5001a206271bbfe9c274.zip
net-analyzer/cacti-spine: Version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/cacti-spine/Manifest1
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-1.0.0.ebuild50
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-1.0.0-help2man.patch9
3 files changed, 60 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/Manifest b/net-analyzer/cacti-spine/Manifest
index a2f365d56f58..03adbcd0a763 100644
--- a/net-analyzer/cacti-spine/Manifest
+++ b/net-analyzer/cacti-spine/Manifest
@@ -1 +1,2 @@
DIST cacti-spine-0.8.8h.tar.gz 804951 SHA256 a693136839bd7d03cae5b3ff4614a4d21a2153ffb14d09fc061b843ab0b2bb30 SHA512 6a7147ab645be44de0d330c7801e569705817da10bf6cedba82c712e1701ada8aa8924a6b3b063ea680e6af24f815d6767e8773ad7b8da212abfa082b4211bd4 WHIRLPOOL 36daed4986ca84883e51ab6b02ebb2ade00205c30705cfc94e73835bc2fc427a60a2dba9c7ca3665d0c0b2fca21afab77d94cde63b740f3734f9279c929cccaf
+DIST cacti-spine-1.0.0.tar.gz 800770 SHA256 074528eec16e8a49d535ce96d2347bd2a891a56722b261d744225d9f90b6382f SHA512 458b0050ceff3a9e2d31c54c177d75f8d36ff521204d5f7b52a5fb9ff6082c25ef98f46d80dc6c79816e5a977f5b61decac03b625728fc9dc654170e3ce3e87f WHIRLPOOL 3c24d028606ab382ea61feeecda141c96d6b2a588247656285bbb832e309d1e6acd086a8464c9083cc19c777fcd0e15bff53aad417d8889e3b08a85aa38b5be1
diff --git a/net-analyzer/cacti-spine/cacti-spine-1.0.0.ebuild b/net-analyzer/cacti-spine/cacti-spine-1.0.0.ebuild
new file mode 100644
index 000000000000..a0b1283894be
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-1.0.0.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="http://cacti.net/spine_info.php"
+SRC_URI="http://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+CDEPEND="
+ dev-libs/openssl:*
+ net-analyzer/net-snmp
+ virtual/mysql
+"
+DEPEND="
+ ${CDEPEND}
+ sys-apps/help2man
+"
+RDEPEND="
+ ${CDEPEND}
+ >net-analyzer/cacti-0.8.8
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.8.8d-ping.patch
+ "${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch
+ "${FILESDIR}"/${PN}-1.0.0-help2man.patch
+)
+
+src_prepare() {
+ default
+
+ sed -i -e 's/^bin_PROGRAMS/sbin_PROGRAMS/' Makefile.am
+ AT_M4DIR="config" eautoreconf
+}
+
+src_install() {
+ dosbin spine
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+ dodoc ChangeLog
+}
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-1.0.0-help2man.patch b/net-analyzer/cacti-spine/files/cacti-spine-1.0.0-help2man.patch
new file mode 100644
index 000000000000..7b83fefe6f6e
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-1.0.0-help2man.patch
@@ -0,0 +1,9 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -11,5 +11,5 @@
+
+ man_MANS = spine.1
+
+-spine.1: spine.c
++spine.1: spine
+ $(HELP2MAN) --output=$@ --name='Data Collector for Cacti' --no-info --version-option='--version' ./spine