summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-12-20 03:52:08 +0100
committerJeroen Roovers <jer@gentoo.org>2017-12-20 03:52:08 +0100
commit18a40cacf1bbe85369168bfbbc4d63d5310bff31 (patch)
tree8f58c0f43a5ecb7bea9dbdcdbf0898dd6b45c394 /net-analyzer
parentsci-calculators/units: Add dependency on dev-python/requests. (diff)
downloadgentoo-18a40cacf1bbe85369168bfbbc4d63d5310bff31.tar.gz
gentoo-18a40cacf1bbe85369168bfbbc4d63d5310bff31.tar.bz2
gentoo-18a40cacf1bbe85369168bfbbc4d63d5310bff31.zip
net-analyzer/fail2ban: Fix pkg_postinst() message conditions (bug #543348 again).
Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.9.6.ebuild30
-rw-r--r--net-analyzer/fail2ban/fail2ban-0.9.7.ebuild30
-rw-r--r--net-analyzer/fail2ban/fail2ban-99999999.ebuild30
3 files changed, 42 insertions, 48 deletions
diff --git a/net-analyzer/fail2ban/fail2ban-0.9.6.ebuild b/net-analyzer/fail2ban/fail2ban-0.9.6.ebuild
index 416c743d3f1f..78c4e85f890a 100644
--- a/net-analyzer/fail2ban/fail2ban-0.9.6.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-0.9.6.ebuild
@@ -84,21 +84,19 @@ pkg_postinst() {
elog "You are upgrading from version 0.6.x, please see:"
elog "http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
fi
- if ! has_version ${CATEGORY}/${PN}; then
- if ! has_version dev-python/pyinotify && ! has_version app-admin/gamin; then
- elog "For most jail.conf configurations, it is recommended you install either"
- elog "dev-python/pyinotify or app-admin/gamin (in order of preference)"
- elog "to control how log file modifications are detected"
- fi
-
- if ! has_version dev-lang/python[sqlite]; then
- elog "If you want to use ${PN}'s persistent database, then reinstall"
- elog "dev-lang/python with USE=sqlite"
- fi
-
- if has_version sys-apps/systemd[-python]; then
- elog "If you want to track logins through sys-apps/systemd's"
- elog "journal backend, then reinstall sys-apps/systemd with USE=python"
- fi
+ if ! has_version dev-python/pyinotify && ! has_version app-admin/gamin; then
+ elog "For most jail.conf configurations, it is recommended you install either"
+ elog "dev-python/pyinotify or app-admin/gamin (in order of preference)"
+ elog "to control how log file modifications are detected"
+ fi
+
+ if ! has_version dev-lang/python[sqlite]; then
+ elog "If you want to use ${PN}'s persistent database, then reinstall"
+ elog "dev-lang/python with USE=sqlite"
+ fi
+
+ if has_version sys-apps/systemd[-python]; then
+ elog "If you want to track logins through sys-apps/systemd's"
+ elog "journal backend, then reinstall sys-apps/systemd with USE=python"
fi
}
diff --git a/net-analyzer/fail2ban/fail2ban-0.9.7.ebuild b/net-analyzer/fail2ban/fail2ban-0.9.7.ebuild
index f51e3cf37b7b..eaa1dbd0fc89 100644
--- a/net-analyzer/fail2ban/fail2ban-0.9.7.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-0.9.7.ebuild
@@ -87,21 +87,19 @@ pkg_postinst() {
elog "http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
fi
- if ! has_version ${CATEGORY}/${PN}; then
- if ! has_version dev-python/pyinotify && ! has_version app-admin/gamin; then
- elog "For most jail.conf configurations, it is recommended you install either"
- elog "dev-python/pyinotify or app-admin/gamin (in order of preference)"
- elog "to control how log file modifications are detected"
- fi
-
- if ! has_version dev-lang/python[sqlite]; then
- elog "If you want to use ${PN}'s persistent database, then reinstall"
- elog "dev-lang/python with USE=sqlite"
- fi
-
- if has_version sys-apps/systemd[-python]; then
- elog "If you want to track logins through sys-apps/systemd's"
- elog "journal backend, then reinstall sys-apps/systemd with USE=python"
- fi
+ if ! has_version dev-python/pyinotify && ! has_version app-admin/gamin; then
+ elog "For most jail.conf configurations, it is recommended you install either"
+ elog "dev-python/pyinotify or app-admin/gamin (in order of preference)"
+ elog "to control how log file modifications are detected"
+ fi
+
+ if ! has_version dev-lang/python[sqlite]; then
+ elog "If you want to use ${PN}'s persistent database, then reinstall"
+ elog "dev-lang/python with USE=sqlite"
+ fi
+
+ if has_version sys-apps/systemd[-python]; then
+ elog "If you want to track logins through sys-apps/systemd's"
+ elog "journal backend, then reinstall sys-apps/systemd with USE=python"
fi
}
diff --git a/net-analyzer/fail2ban/fail2ban-99999999.ebuild b/net-analyzer/fail2ban/fail2ban-99999999.ebuild
index b642ecf3d5b3..e847560915e7 100644
--- a/net-analyzer/fail2ban/fail2ban-99999999.ebuild
+++ b/net-analyzer/fail2ban/fail2ban-99999999.ebuild
@@ -87,21 +87,19 @@ pkg_postinst() {
elog "http://www.fail2ban.org/wiki/index.php/HOWTO_Upgrade_from_0.6_to_0.8"
fi
- if ! has_version ${CATEGORY}/${PN}; then
- if ! has_version dev-python/pyinotify && ! has_version app-admin/gamin; then
- elog "For most jail.conf configurations, it is recommended you install either"
- elog "dev-python/pyinotify or app-admin/gamin (in order of preference)"
- elog "to control how log file modifications are detected"
- fi
-
- if ! has_version dev-lang/python[sqlite]; then
- elog "If you want to use ${PN}'s persistent database, then reinstall"
- elog "dev-lang/python with USE=sqlite"
- fi
-
- if has_version sys-apps/systemd[-python]; then
- elog "If you want to track logins through sys-apps/systemd's"
- elog "journal backend, then reinstall sys-apps/systemd with USE=python"
- fi
+ if ! has_version dev-python/pyinotify && ! has_version app-admin/gamin; then
+ elog "For most jail.conf configurations, it is recommended you install either"
+ elog "dev-python/pyinotify or app-admin/gamin (in order of preference)"
+ elog "to control how log file modifications are detected"
+ fi
+
+ if ! has_version dev-lang/python[sqlite]; then
+ elog "If you want to use ${PN}'s persistent database, then reinstall"
+ elog "dev-lang/python with USE=sqlite"
+ fi
+
+ if has_version sys-apps/systemd[-python]; then
+ elog "If you want to track logins through sys-apps/systemd's"
+ elog "journal backend, then reinstall sys-apps/systemd with USE=python"
fi
}