summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2015-11-16 10:04:02 -0600
committerMatthew Thode <prometheanfire@gentoo.org>2015-11-16 10:04:02 -0600
commit310b14952d1b298d861c0e28b234933ccdbf7ad0 (patch)
tree88f6c5f3bc40c961868f38fb2365cea99ef3e2b7 /net-analyzer
parentkde-frameworks/kconfig: restrict tests (diff)
downloadgentoo-310b14952d1b298d861c0e28b234933ccdbf7ad0.tar.gz
gentoo-310b14952d1b298d861c0e28b234933ccdbf7ad0.tar.bz2
gentoo-310b14952d1b298d861c0e28b234933ccdbf7ad0.zip
net-analyzer/icinga2: bup
Package-Manager: portage-2.2.20.1
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/icinga2/Manifest1
-rw-r--r--net-analyzer/icinga2/icinga2-2.4.0.ebuild133
2 files changed, 134 insertions, 0 deletions
diff --git a/net-analyzer/icinga2/Manifest b/net-analyzer/icinga2/Manifest
index bd5eb6902f19..481303c74aea 100644
--- a/net-analyzer/icinga2/Manifest
+++ b/net-analyzer/icinga2/Manifest
@@ -1,2 +1,3 @@
DIST icinga2-2.3.10.tar.gz 830680 SHA256 d29880b1adfd21d650a72e04a36e4dadb899b8452c4917e25e7ec3c5e65582c1 SHA512 14dee2d856f0dd1f2cd7185d68c9f90840acc086cb8c20eaa300585d2b3a491cadc44cb295fe6931a539aa305f4d9e00adb37b3d6cf33805989ff7eec0932630 WHIRLPOOL 98140d95133b01c3428b092dbbc8d9d9e5299e63d922fe07e60be2d0ed56ea3177210f64d6f71eba2bc99bdec0d297729539114266186e63dd2aceab98166914
DIST icinga2-2.3.11.tar.gz 843985 SHA256 b499c46b9371e0046030226f61b9b056bc16e37138f318c88cd9dd2b4edf3152 SHA512 2011b4a8f6aaab90957427dc90c5de49ae7be97ade9f487882c955807e19455a59dc54869c1ca6a0538c6f1e793fc30815438514d78591338af579a50d022dd8 WHIRLPOOL 69622d7848f16c29fb9bba55e8cad09d1d9cb967d4b70941e7df7379d32e85c392be843703255eac884a659fbc46a263ee4e5d6a27659055d72b628d89478277
+DIST icinga2-2.4.0.tar.gz 1338579 SHA256 928d6bfb64078ed4d8223a4b3db67ee8d8fb9d0065a43a10642b628181c52605 SHA512 f81b0eb0e892afeb0a6a673bdf776ba1828638a04e26a0a834204f29b5ee42fa744e1ef3df9c77c4c841580490df3435ceda5f97f826b1b97bcda9c9aa3fe53f WHIRLPOOL ef77641f353954435a5c9c33a97f78307a79e71f450a5e14a81253831e35b1986df39ff366e6dd376843bd2d746bb950f51db971e209601dfca5fd14a5a94203
diff --git a/net-analyzer/icinga2/icinga2-2.4.0.ebuild b/net-analyzer/icinga2/icinga2-2.4.0.ebuild
new file mode 100644
index 000000000000..176442c85146
--- /dev/null
+++ b/net-analyzer/icinga2/icinga2-2.4.0.ebuild
@@ -0,0 +1,133 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit cmake-utils depend.apache eutils systemd toolchain-funcs user
+
+DESCRIPTION="Distributed, general purpose, network monitoring engine"
+HOMEPAGE="http://icinga.org/icinga2"
+SRC_URI="https://github.com/Icinga/icinga2/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+mysql postgres classicui minimal nano-syntax +plugins +vim-syntax"
+
+DEPEND="
+ dev-libs/openssl:0
+ >=dev-libs/boost-1.41
+ sys-devel/bison
+ >=sys-devel/flex-2.5.35
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/postgresql:= )"
+
+RDEPEND="
+ ${DEPEND}
+ plugins? ( || (
+ net-analyzer/monitoring-plugins
+ net-analyzer/nagios-plugins
+ ) )
+ classicui? ( net-analyzer/icinga[web] )"
+
+REQUIRED_USE="!minimal? ( || ( mysql postgres ) )"
+
+want_apache2
+
+pkg_setup() {
+ depend.apache_pkg_setup
+ enewgroup icinga
+ enewgroup icingacmd
+ enewgroup nagios # for plugins
+ enewuser icinga -1 -1 /var/lib/icinga2 "icinga,icingacmd,nagios"
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DICINGA2_UNITY_BUILD=FALSE
+ -DCMAKE_VERBOSE_MAKEFILE=ON
+ -DCMAKE_BUILD_TYPE=None
+ -DCMAKE_INSTALL_PREFIX=/usr
+ -DCMAKE_INSTALL_SYSCONFDIR=/etc
+ -DCMAKE_INSTALL_LOCALSTATEDIR=/var
+ -DICINGA2_SYSCONFIGFILE=/etc/conf.d/icinga2
+ -DICINGA2_USER=icinga
+ -DICINGA2_GROUP=icingacmd
+ -DICINGA2_COMMAND_USER=icinga
+ -DICINGA2_COMMAND_GROUP=icingacmd
+ -DINSTALL_SYSTEMD_SERVICE_AND_INITSCRIPT=yes
+ )
+ # default to off if minimal, allow the flags to be set otherwise
+ if use minimal; then
+ mycmakeargs+=(
+ -DICINGA2_WITH_MYSQL=OFF
+ -DICINGA2_WITH_PGSQL=OFF
+ )
+ else
+ mycmakeargs+=(
+ -DICINGA2_WITH_PGSQL=$(usex postgres ON OFF)
+ -DICINGA2_WITH_MYSQL=$(usex mysql ON OFF)
+ )
+ fi
+ cmake-utils_src_configure
+}
+
+src_install() {
+ BUILDDIR="${WORKDIR}"/icinga2-${PV}_build
+ cd "${BUILDDIR}" || die
+
+ emake DESTDIR="${D}" install
+
+ einstalldocs
+
+ newinitd "${FILESDIR}"/icinga2.initd icinga2
+ newconfd "${FILESDIR}"/icinga2.confd icinga2
+
+ if use mysql ; then
+ docinto schema
+ newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/mysql.sql mysql.sql
+ docinto schema/upgrade
+ dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_mysql/schema/upgrade/*
+ elif use postgres ; then
+ docinto schema
+ newdoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/pgsql.sql pgsql.sql
+ docinto schema/upgrade
+ dodoc "${WORKDIR}"/icinga2-${PV}/lib/db_ido_pgsql/schema/upgrade/*
+ fi
+
+ keepdir /etc/icinga2
+ keepdir /var/lib/icinga2/api/zones
+ keepdir /var/lib/icinga2/api/repository
+ keepdir /var/lib/icinga2/api/log
+ keepdir /var/spool/icinga2/perfdata
+
+ rm -r "${D}/var/run" || die "failed to remove /var/run"
+ rm -r "${D}/var/cache" || die "failed to remove /var/cache"
+
+ fowners icinga:icinga /etc/icinga2
+ fowners icinga:icinga /var/lib/icinga2
+ fowners icinga:icinga /var/spool/icinga2
+ fowners icinga:icinga /var/spool/icinga2/perfdata
+ fowners icinga:icingacmd /var/log/icinga2
+
+ fperms ug+rwX,o-rwx /etc/icinga2
+ fperms ug+rwX,o-rwx /var/lib/icinga2
+ fperms ug+rwX,o-rwx /var/spool/icinga2
+ fperms ug+rwX,o-rwx /var/log/icinga2
+
+ if use vim-syntax; then
+ insinto /usr/share/vim/vimfiles
+ doins -r "${WORKDIR}"/${P}/tools/syntax/vim/ftdetect
+ doins -r "${WORKDIR}"/${P}/tools/syntax/vim/syntax
+ fi
+
+ if use nano-syntax; then
+ insinto /usr/share/nano
+ doins "${WORKDIR}"/${P}/tools/syntax/nano/icinga2.nanorc
+ fi
+}
+
+pkg_postinst() {
+ elog "DB IDO schema upgrade required. http://docs.icinga.org/icinga2/snapshot/chapter-2.html#upgrading-the-mysql-database"
+ elog "You will need to update your configuration files, see https://dev.icinga.org/issues/5909"
+}