summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
committerDavid Seifert <soap@gentoo.org>2019-12-11 13:32:00 +0100
commit398a42634f34afa1979d88ae1d8b38194e911c2d (patch)
treed6a45bdf7b35b71c192602a46e8d98d12a88cb02 /net-analyzer
parentdev-ros/geometric_shapes: Remove old (diff)
downloadgentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.gz
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.tar.bz2
gentoo-398a42634f34afa1979d88ae1d8b38194e911c2d.zip
*/*: [QA] Remove redundant `|| die` guards
* Since all ebuilds in the tree are EAPI>=4, `|| die` on builtin commands is redundant and dead code. Closes: https://github.com/gentoo/gentoo/pull/13940 Reviewed-by: Ulrich Müller <ulm@gentoo.org> Reviewed-by: Michał Górny <mgorny@gentoo.org> Reviewed-by: Andreas K. Hüttel <dilfridge@gentoo.org> Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/openbsd-netcat/openbsd-netcat-1.105-r1.ebuild2
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-4.3.2.ebuild2
-rw-r--r--net-analyzer/tcpreplay/tcpreplay-999999.ebuild2
-rw-r--r--net-analyzer/thrulay/thrulay-0.9-r1.ebuild10
-rw-r--r--net-analyzer/tptest/tptest-3.1.7-r2.ebuild7
-rw-r--r--net-analyzer/tsung/tsung-1.7.0.ebuild4
-rw-r--r--net-analyzer/zabbix/zabbix-2.2.16-r1.ebuild5
-rw-r--r--net-analyzer/zabbix/zabbix-3.0.28.ebuild5
-rw-r--r--net-analyzer/zabbix/zabbix-3.4.15.ebuild5
-rw-r--r--net-analyzer/zabbix/zabbix-4.0.13.ebuild5
-rw-r--r--net-analyzer/zabbix/zabbix-4.2.7.ebuild5
-rw-r--r--net-analyzer/zabbix/zabbix-4.4.0.ebuild5
12 files changed, 25 insertions, 32 deletions
diff --git a/net-analyzer/openbsd-netcat/openbsd-netcat-1.105-r1.ebuild b/net-analyzer/openbsd-netcat/openbsd-netcat-1.105-r1.ebuild
index fbc35796377b..298a47420fd0 100644
--- a/net-analyzer/openbsd-netcat/openbsd-netcat-1.105-r1.ebuild
+++ b/net-analyzer/openbsd-netcat/openbsd-netcat-1.105-r1.ebuild
@@ -34,7 +34,7 @@ src_prepare() {
}
src_compile() {
- emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" || die
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}"
}
src_install() {
diff --git a/net-analyzer/tcpreplay/tcpreplay-4.3.2.ebuild b/net-analyzer/tcpreplay/tcpreplay-4.3.2.ebuild
index 3d0c5b4f1d7a..003400e4ef70 100644
--- a/net-analyzer/tcpreplay/tcpreplay-4.3.2.ebuild
+++ b/net-analyzer/tcpreplay/tcpreplay-4.3.2.ebuild
@@ -65,7 +65,7 @@ src_test() {
ewarn "Some tests were disabled due to FEATURES=userpriv"
ewarn "To run all tests issue the following command as root:"
ewarn " # make -C ${S}/test"
- emake -j1 -C test tcpprep || die "self test failed - see ${S}/test/test.log"
+ emake -j1 -C test tcpprep
else
emake -j1 test || {
ewarn "Note that some tests require eth0 iface to be up." ;
diff --git a/net-analyzer/tcpreplay/tcpreplay-999999.ebuild b/net-analyzer/tcpreplay/tcpreplay-999999.ebuild
index 36c173f66f59..9e2776949df2 100644
--- a/net-analyzer/tcpreplay/tcpreplay-999999.ebuild
+++ b/net-analyzer/tcpreplay/tcpreplay-999999.ebuild
@@ -64,7 +64,7 @@ src_test() {
ewarn "Some tests will be disabled due to FEATURES=userpriv"
ewarn "To run all tests issue the following command as root:"
ewarn " # make -C ${S}/test"
- emake -j1 -C test tcpprep || die "self test failed - see ${S}/test/test.log"
+ emake -j1 -C test tcpprep
else
emake -j1 test || {
ewarn "Note that some tests require eth0 iface to be up." ;
diff --git a/net-analyzer/thrulay/thrulay-0.9-r1.ebuild b/net-analyzer/thrulay/thrulay-0.9-r1.ebuild
index f7e905e1772a..f66426aacee5 100644
--- a/net-analyzer/thrulay/thrulay-0.9-r1.ebuild
+++ b/net-analyzer/thrulay/thrulay-0.9-r1.ebuild
@@ -20,11 +20,11 @@ src_prepare() {
}
src_install() {
- emake install DESTDIR="${D}" || die "emake install failed"
+ emake install DESTDIR="${D}"
#dobin src/thrulay || die "dobin failed"
#dosbin src/thrulayd || die "dosbin failed"
- dodoc LICENSE README TODO doc/thrulay-protocol.txt || die "dodoc failed"
- doman doc/thrulay*.[1-8] || die "doman failed"
- newinitd "${FILESDIR}"/thrulayd-init.d thrulayd || die "newinitd failed"
- newconfd "${FILESDIR}"/thrulayd-conf.d thrulayd || die "newconfd failed"
+ dodoc LICENSE README TODO doc/thrulay-protocol.txt
+ doman doc/thrulay*.[1-8]
+ newinitd "${FILESDIR}"/thrulayd-init.d thrulayd
+ newconfd "${FILESDIR}"/thrulayd-conf.d thrulayd
}
diff --git a/net-analyzer/tptest/tptest-3.1.7-r2.ebuild b/net-analyzer/tptest/tptest-3.1.7-r2.ebuild
index d580934eae8f..709ad3a89a3e 100644
--- a/net-analyzer/tptest/tptest-3.1.7-r2.ebuild
+++ b/net-analyzer/tptest/tptest-3.1.7-r2.ebuild
@@ -26,12 +26,11 @@ src_prepare() {
src_compile() {
emake -C apps/unix/client \
CC=$(tc-getCC) \
- LDFLAGS="${LDFLAGS}" \
- || die
+ LDFLAGS="${LDFLAGS}"
+
emake -C apps/unix/server \
CC=$(tc-getCC) \
- LDFLAGS="${LDFLAGS}" \
- || die
+ LDFLAGS="${LDFLAGS}"
}
src_install() {
diff --git a/net-analyzer/tsung/tsung-1.7.0.ebuild b/net-analyzer/tsung/tsung-1.7.0.ebuild
index d2d90fd44c21..80940ea2f4aa 100644
--- a/net-analyzer/tsung/tsung-1.7.0.ebuild
+++ b/net-analyzer/tsung/tsung-1.7.0.ebuild
@@ -30,9 +30,9 @@ src_configure() {
}
src_compile() {
- emake || die "Failed building"
+ emake
}
src_install() {
- emake -j1 DESTDIR="${D}" install || die "Failed installing"
+ emake -j1 DESTDIR="${D}" install
}
diff --git a/net-analyzer/zabbix/zabbix-2.2.16-r1.ebuild b/net-analyzer/zabbix/zabbix-2.2.16-r1.ebuild
index cd75b8d90b24..26b70005d753 100644
--- a/net-analyzer/zabbix/zabbix-2.2.16-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-2.2.16-r1.ebuild
@@ -135,13 +135,12 @@ src_configure() {
$(use_with openipmi openipmi) \
$(use_with ssh ssh2) \
$(use_with libxml2) \
- $(use_with odbc unixodbc) \
- || die "econf failed"
+ $(use_with odbc unixodbc)
}
src_compile() {
if [ -f Makefile ] || [ -f GNUmakefile ] || [ -f makefile ]; then
- emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" || die "emake failed"
+ emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)"
fi
}
diff --git a/net-analyzer/zabbix/zabbix-3.0.28.ebuild b/net-analyzer/zabbix/zabbix-3.0.28.ebuild
index 64dc6af6ad83..09ba412f2f86 100644
--- a/net-analyzer/zabbix/zabbix-3.0.28.ebuild
+++ b/net-analyzer/zabbix/zabbix-3.0.28.ebuild
@@ -137,13 +137,12 @@ src_configure() {
$(use_with ssh ssh2) \
$(use_with libxml2) \
$(use_with odbc unixodbc) \
- $(use_with ssl openssl) \
- || die "econf failed"
+ $(use_with ssl openssl)
}
src_compile() {
if [ -f Makefile ] || [ -f GNUmakefile ] || [ -f makefile ]; then
- emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" || die "emake failed"
+ emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)"
fi
}
diff --git a/net-analyzer/zabbix/zabbix-3.4.15.ebuild b/net-analyzer/zabbix/zabbix-3.4.15.ebuild
index 4d9f2799daa6..0169c3ac73bf 100644
--- a/net-analyzer/zabbix/zabbix-3.4.15.ebuild
+++ b/net-analyzer/zabbix/zabbix-3.4.15.ebuild
@@ -138,13 +138,12 @@ src_configure() {
$(use_with ssh ssh2) \
$(use_with libxml2) \
$(use_with odbc unixodbc) \
- $(use_with ssl openssl) \
- || die "econf failed"
+ $(use_with ssl openssl)
}
src_compile() {
if [ -f Makefile ] || [ -f GNUmakefile ] || [ -f makefile ]; then
- emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" || die "emake failed"
+ emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)"
fi
}
diff --git a/net-analyzer/zabbix/zabbix-4.0.13.ebuild b/net-analyzer/zabbix/zabbix-4.0.13.ebuild
index 7b8602240625..2e1f7d320991 100644
--- a/net-analyzer/zabbix/zabbix-4.0.13.ebuild
+++ b/net-analyzer/zabbix/zabbix-4.0.13.ebuild
@@ -142,13 +142,12 @@ src_configure() {
$(use_with ssh ssh2) \
$(use_with libxml2) \
$(use_with odbc unixodbc) \
- $(use_with ssl openssl) \
- || die "econf failed"
+ $(use_with ssl openssl)
}
src_compile() {
if [ -f Makefile ] || [ -f GNUmakefile ] || [ -f makefile ]; then
- emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" || die "emake failed"
+ emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)"
fi
}
diff --git a/net-analyzer/zabbix/zabbix-4.2.7.ebuild b/net-analyzer/zabbix/zabbix-4.2.7.ebuild
index ce4694480bfa..190162272899 100644
--- a/net-analyzer/zabbix/zabbix-4.2.7.ebuild
+++ b/net-analyzer/zabbix/zabbix-4.2.7.ebuild
@@ -142,13 +142,12 @@ src_configure() {
$(use_with ssh ssh2) \
$(use_with libxml2) \
$(use_with odbc unixodbc) \
- $(use_with ssl openssl) \
- || die "econf failed"
+ $(use_with ssl openssl)
}
src_compile() {
if [ -f Makefile ] || [ -f GNUmakefile ] || [ -f makefile ]; then
- emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" || die "emake failed"
+ emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)"
fi
}
diff --git a/net-analyzer/zabbix/zabbix-4.4.0.ebuild b/net-analyzer/zabbix/zabbix-4.4.0.ebuild
index ce4694480bfa..190162272899 100644
--- a/net-analyzer/zabbix/zabbix-4.4.0.ebuild
+++ b/net-analyzer/zabbix/zabbix-4.4.0.ebuild
@@ -142,13 +142,12 @@ src_configure() {
$(use_with ssh ssh2) \
$(use_with libxml2) \
$(use_with odbc unixodbc) \
- $(use_with ssl openssl) \
- || die "econf failed"
+ $(use_with ssl openssl)
}
src_compile() {
if [ -f Makefile ] || [ -f GNUmakefile ] || [ -f makefile ]; then
- emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)" || die "emake failed"
+ emake AR="$(tc-getAR)" RANLIB="$(tc-getRANLIB)"
fi
}