summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-02-24 09:41:18 +0100
committerJeroen Roovers <jer@gentoo.org>2016-02-24 09:41:43 +0100
commit5c6f0ca77d32472e5973e8652078beeb2b1bb722 (patch)
treef3105446d94158974cd9a5006507f8b0b0b49a67 /net-analyzer
parentdev-util/debootstrap: Version bump. (diff)
downloadgentoo-5c6f0ca77d32472e5973e8652078beeb2b1bb722.tar.gz
gentoo-5c6f0ca77d32472e5973e8652078beeb2b1bb722.tar.bz2
gentoo-5c6f0ca77d32472e5973e8652078beeb2b1bb722.zip
net-analyzer/wireshark: Update live ebuild patches (bug #575090 by Garri).
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/wireshark/files/wireshark-99999999-androiddump.patch10
-rw-r--r--net-analyzer/wireshark/files/wireshark-99999999-sse4_2.patch20
-rw-r--r--net-analyzer/wireshark/wireshark-99999999.ebuild7
3 files changed, 32 insertions, 5 deletions
diff --git a/net-analyzer/wireshark/files/wireshark-99999999-androiddump.patch b/net-analyzer/wireshark/files/wireshark-99999999-androiddump.patch
new file mode 100644
index 000000000000..7c00d8b13167
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-99999999-androiddump.patch
@@ -0,0 +1,10 @@
+--- a/extcap/Makefile.am
++++ b/extcap/Makefile.am
+@@ -46,6 +46,7 @@
+ ../wiretap/libwiretap.la \
+ ../wsutil/libwsutil.la \
+ @GLIB_LIBS@ \
++ @PCAP_LIBS@ \
+ @SOCKET_LIBS@
+
+ if ENABLE_STATIC
diff --git a/net-analyzer/wireshark/files/wireshark-99999999-sse4_2.patch b/net-analyzer/wireshark/files/wireshark-99999999-sse4_2.patch
new file mode 100644
index 000000000000..daef2a1a7cb0
--- /dev/null
+++ b/net-analyzer/wireshark/files/wireshark-99999999-sse4_2.patch
@@ -0,0 +1,20 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -1101,6 +1101,7 @@
+ AC_SUBST(PIE_CFLAGS)
+ AC_SUBST(PIE_LDFLAGS)
+
++AC_ARG_ENABLE(sse4_2,[ --enable-sse4_2 Support SSE4.2 (Streaming SIMD Extensions 4.2) instructions],[
+ WS_CFLAGS_saved="$WS_CFLAGS"
+ AC_WIRESHARK_COMPILER_FLAGS_CHECK(-msse4.2, C)
+ if test "x$can_add_to_cflags" = "xyes"
+@@ -1128,6 +1129,9 @@
+ fi
+ fi
+ WS_CFLAGS="$WS_CFLAGS_saved"
++],[
++AC_MSG_RESULT(no)
++])
+
+ if test "x$ac_sse4_2_flag" != x; then
+ #
diff --git a/net-analyzer/wireshark/wireshark-99999999.ebuild b/net-analyzer/wireshark/wireshark-99999999.ebuild
index 786f1b1f1169..b0ab8fdf2a0c 100644
--- a/net-analyzer/wireshark/wireshark-99999999.ebuild
+++ b/net-analyzer/wireshark/wireshark-99999999.ebuild
@@ -97,11 +97,10 @@ src_unpack() {
src_prepare() {
epatch \
- "${FILESDIR}"/${PN}-1.6.13-ldflags.patch \
"${FILESDIR}"/${PN}-1.11.0-oldlibs.patch \
- "${FILESDIR}"/${PN}-99999999-pkgconfig.patch \
"${FILESDIR}"/${PN}-1.99.8-qtchooser.patch \
- "${FILESDIR}"/${PN}-2.1.0-sse4_2.patch
+ "${FILESDIR}"/${PN}-99999999-sse4_2.patch \
+ "${FILESDIR}"/${PN}-99999999-androiddump.patch
epatch_user
@@ -155,7 +154,6 @@ src_configure() {
econf \
$(use androiddump && use pcap && echo --enable-androiddump-use-libpcap=yes) \
$(use_enable androiddump) \
- $(use_enable ipv6) \
$(use_enable tfshark) \
$(use_with adns c-ares) \
$(use_with caps libcap) \
@@ -212,7 +210,6 @@ src_install() {
# install headers
local wsheader
for wsheader in \
- color.h \
config.h \
epan/*.h \
epan/crypt/*.h \