summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZero_Chaos <zerochaos@gentoo.org>2018-01-15 11:09:40 -0500
committerZero_Chaos <zerochaos@gentoo.org>2018-01-15 11:12:38 -0500
commit5f7a1bf8836f48d5777ce041e3d25f7056375ced (patch)
treef8020f9563567a586e6e13049bf61feef969b5cc /net-analyzer
parentnet-analyzer/prometheus-alertmanager: Remove old (diff)
downloadgentoo-5f7a1bf8836f48d5777ce041e3d25f7056375ced.tar.gz
gentoo-5f7a1bf8836f48d5777ce041e3d25f7056375ced.tar.bz2
gentoo-5f7a1bf8836f48d5777ce041e3d25f7056375ced.zip
net-analyzer/multimon-ng: bump
cleanup non-sensical qt4 dep, switch to cmake build system Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/multimon-ng/Manifest2
-rw-r--r--net-analyzer/multimon-ng/multimon-ng-1.1.4.ebuild (renamed from net-analyzer/multimon-ng/multimon-ng-1.0.0-r1.ebuild)22
-rw-r--r--net-analyzer/multimon-ng/multimon-ng-9999.ebuild22
3 files changed, 17 insertions, 29 deletions
diff --git a/net-analyzer/multimon-ng/Manifest b/net-analyzer/multimon-ng/Manifest
index 4fdc4679600d..0a05103926c6 100644
--- a/net-analyzer/multimon-ng/Manifest
+++ b/net-analyzer/multimon-ng/Manifest
@@ -1 +1 @@
-DIST multimon-ng-1.0.0.tar.gz 67095 BLAKE2B 4859a03e3b07ebe95232233832dc45d070010c38de8ef687db561d57137d7bcef7b469da618f450954819e21715e00e46df1d51b44ee86f84c4ac105f4cf00c9 SHA512 0fa475c7908bc24a9558c5a7e0aa4737fca117ff323a012b4316ad02840eb97f917a02d1daec50645729c2ca834068467ddc409cbc36af9cd5ffb9e8f6e5e3e9
+DIST multimon-ng-1.1.4.tar.gz 2426821 BLAKE2B 36f5eda463afc08ed6848d86b27ccbe27897327ea585b4b42210b13a2ac17ec8b215f239cc626f3151f6ca029897f40db333285b5442c85112b338c78a854adc SHA512 575e920b3738ab00da2cecdea8a1b1fb809ea7870e0aae7a5f8940ae8eee70af202e062d4a624d9de677135a7561daed60f264c6047b58f348405cb2bd06b21a
diff --git a/net-analyzer/multimon-ng/multimon-ng-1.0.0-r1.ebuild b/net-analyzer/multimon-ng/multimon-ng-1.1.4.ebuild
index 6ba3057182a6..509c0aa1308a 100644
--- a/net-analyzer/multimon-ng/multimon-ng-1.0.0-r1.ebuild
+++ b/net-analyzer/multimon-ng/multimon-ng-1.1.4.ebuild
@@ -1,38 +1,32 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit qt4-r2
+inherit cmake-utils
DESCRIPTION="a fork of multimon, decodes multiple digital transmission modes"
HOMEPAGE="https://github.com/EliasOenal/multimonNG"
if [[ ${PV} == 9999* ]]; then
- inherit git-2
+ inherit git-r3
EGIT_REPO_URI="https://github.com/EliasOenal/multimonNG.git"
KEYWORDS=""
else
SRC_URI="https://github.com/EliasOenal/multimonNG/archive/${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}"/multimonNG-${PV}
KEYWORDS="~amd64 ~arm ~x86"
fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="pulseaudio"
+IUSE="pulseaudio X"
DEPEND="pulseaudio? ( media-sound/pulseaudio )
- dev-qt/qtcore:4
- x11-libs/libX11"
+ X? ( x11-libs/libX11 )"
RDEPEND="${DEPEND}"
src_prepare() {
- if use !pulseaudio; then
- sed -i -e 's/-lpulse-simple//' -e 's/-lpulse//' -e 's/PULSE/DUMMY/' ${PN}.pro || die
- fi
- qt4-r2_src_prepare
-}
-src_install() {
- dobin ${PN}
+ use pulseaudio && sed -i '/find_package( PulseAudio )/d' CMakeLists.txt
+ use X && sed -i '/find_package( X11 )/d' CMakeLists.txt
+ cmake-utils_src_prepare
}
diff --git a/net-analyzer/multimon-ng/multimon-ng-9999.ebuild b/net-analyzer/multimon-ng/multimon-ng-9999.ebuild
index 6ba3057182a6..509c0aa1308a 100644
--- a/net-analyzer/multimon-ng/multimon-ng-9999.ebuild
+++ b/net-analyzer/multimon-ng/multimon-ng-9999.ebuild
@@ -1,38 +1,32 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=5
-inherit qt4-r2
+inherit cmake-utils
DESCRIPTION="a fork of multimon, decodes multiple digital transmission modes"
HOMEPAGE="https://github.com/EliasOenal/multimonNG"
if [[ ${PV} == 9999* ]]; then
- inherit git-2
+ inherit git-r3
EGIT_REPO_URI="https://github.com/EliasOenal/multimonNG.git"
KEYWORDS=""
else
SRC_URI="https://github.com/EliasOenal/multimonNG/archive/${PV}.tar.gz -> ${P}.tar.gz"
- S="${WORKDIR}"/multimonNG-${PV}
KEYWORDS="~amd64 ~arm ~x86"
fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="pulseaudio"
+IUSE="pulseaudio X"
DEPEND="pulseaudio? ( media-sound/pulseaudio )
- dev-qt/qtcore:4
- x11-libs/libX11"
+ X? ( x11-libs/libX11 )"
RDEPEND="${DEPEND}"
src_prepare() {
- if use !pulseaudio; then
- sed -i -e 's/-lpulse-simple//' -e 's/-lpulse//' -e 's/PULSE/DUMMY/' ${PN}.pro || die
- fi
- qt4-r2_src_prepare
-}
-src_install() {
- dobin ${PN}
+ use pulseaudio && sed -i '/find_package( PulseAudio )/d' CMakeLists.txt
+ use X && sed -i '/find_package( X11 )/d' CMakeLists.txt
+ cmake-utils_src_prepare
}