summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-02-24 07:00:28 +0100
committerJeroen Roovers <jer@gentoo.org>2016-02-24 07:00:28 +0100
commit636198c593fc9532c6a4ac3bbdcc66cb65625988 (patch)
tree41edb670ac388227fda2157dff12322dee164265 /net-analyzer
parentnet-analyzer/cacti: Version bump. (diff)
downloadgentoo-636198c593fc9532c6a4ac3bbdcc66cb65625988.tar.gz
gentoo-636198c593fc9532c6a4ac3bbdcc66cb65625988.tar.bz2
gentoo-636198c593fc9532c6a4ac3bbdcc66cb65625988.zip
net-analyzer/cacti-spine: Version bump.
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/cacti-spine/Manifest1
-rw-r--r--net-analyzer/cacti-spine/cacti-spine-0.8.8g.ebuild50
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-0.8.8g-fix-ac-macro.patch11
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-0.8.8g-net-snmp.patch19
-rw-r--r--net-analyzer/cacti-spine/files/cacti-spine-0.8.8g-parallel-make.patch9
5 files changed, 90 insertions, 0 deletions
diff --git a/net-analyzer/cacti-spine/Manifest b/net-analyzer/cacti-spine/Manifest
index f93518e3d521..6024bed5578a 100644
--- a/net-analyzer/cacti-spine/Manifest
+++ b/net-analyzer/cacti-spine/Manifest
@@ -1,2 +1,3 @@
DIST cacti-spine-0.8.8e.tar.gz 757042 SHA256 e014488acffd4dd3a88306c3809e93a89c8538a050c2a58a9666e4c04c004b92 SHA512 165e93d4cce3378e911aec41fcd68fb541d82d849ebf3e2e28e0ddb65027ff2eb77d488acbaa133244091cd02adb58d8f74ea5abc36abed07af9ea72bc104f40 WHIRLPOOL 59442f54fbb8956a945404f374eba848bc21b60d53dacb025132a91dc077115aa65ee30959ba81fb521beb9732c1c5944adb1c555a36ad6ea72898172404970c
DIST cacti-spine-0.8.8f.tar.gz 757078 SHA256 d0599239187f2f5a29f82b809e6941447f18bb7b170cd42e67455633b195e3c7 SHA512 8c5e1713bb1d41227cef6047e5348ef33b90b5591976cf24390abbf1e5c68de6714f785d9517ca9aed21b42b6b8772512af176b9f62bf18d6d74d949a6359a22 WHIRLPOOL 70545057f80d5cc5940059179bc3b72eabf48ff61c5eed5b0b344e995eb1411e3a89359e8c0b6bc3850b029233597d581ece59a99c6653ac7cfd028ef2e24232
+DIST cacti-spine-0.8.8g.tar.gz 805321 SHA256 f7d60d5663f6fe8f730363763f31d110589c725e482c943f0f8287359a6db533 SHA512 24d208b4779e5d04e0206e950c0d49d0453937b3da4a3e3bdbb1a075bdf22db3c6bb6789bab92f6c22a67c39745a36fc98cb28371423469b87a5936b3afb3ba3 WHIRLPOOL d1106b59748ac166c0b44ffdad285c3efefb03fec98318704e16022bf788168603884ee1b4bd22d9ef5fb962c5a60bfda241c6675b987fe9c02c7c4068213ad2
diff --git a/net-analyzer/cacti-spine/cacti-spine-0.8.8g.ebuild b/net-analyzer/cacti-spine/cacti-spine-0.8.8g.ebuild
new file mode 100644
index 000000000000..75f9d645d7dc
--- /dev/null
+++ b/net-analyzer/cacti-spine/cacti-spine-0.8.8g.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit autotools eutils
+
+MY_P=${PN}-${PV/_p/-}
+
+DESCRIPTION="Spine is a fast poller for Cacti (formerly known as Cactid)"
+HOMEPAGE="http://cacti.net/spine_info.php"
+SRC_URI="http://www.cacti.net/downloads/spine/${MY_P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+
+CDEPEND="
+ dev-libs/openssl:*
+ net-analyzer/net-snmp
+ virtual/mysql
+"
+DEPEND="
+ ${CDEPEND}
+ sys-apps/help2man
+"
+RDEPEND="
+ ${CDEPEND}
+ >net-analyzer/cacti-0.8.8
+"
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${PN}-0.8.8g-fix-ac-macro.patch \
+ "${FILESDIR}"/${PN}-0.8.8d-mysql.patch \
+ "${FILESDIR}"/${PN}-0.8.8d-ping.patch \
+ "${FILESDIR}"/${PN}-0.8.8g-net-snmp.patch \
+ "${FILESDIR}"/${PN}-0.8.8g-parallel-make.patch
+
+ sed -i -e 's/^bin_PROGRAMS/sbin_PROGRAMS/' Makefile.am
+ AT_M4DIR="config" eautoreconf
+}
+
+src_install() {
+ dosbin spine
+ insinto /etc/
+ insopts -m0640 -o root
+ newins spine.conf{.dist,}
+ dodoc ChangeLog README
+}
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-0.8.8g-fix-ac-macro.patch b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8g-fix-ac-macro.patch
new file mode 100644
index 000000000000..fa12f1ec4a79
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8g-fix-ac-macro.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -10,7 +10,7 @@
+ AC_LANG(C)
+
+ AM_INIT_AUTOMAKE(spine, 0.8.8g)
+-AM_CONFIG_HEADER(config/config.h)
++AC_CONFIG_HEADERS(config/config.h)
+
+ # static libraries
+ AC_ARG_WITH(static,
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-0.8.8g-net-snmp.patch b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8g-net-snmp.patch
new file mode 100644
index 000000000000..5ee62e2279a0
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8g-net-snmp.patch
@@ -0,0 +1,19 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -251,14 +251,14 @@
+
+ # Net-SNMP includes v3 support and insists on crypto unless compiled --without-openssl
+ AC_MSG_CHECKING([if Net-SNMP needs crypto support])
+-AC_TRY_COMPILE([#include <net-snmp-config.h>], [exit(NETSNMP_USE_OPENSSL != 1);],
++AC_TRY_COMPILE([#include <net-snmp/net-snmp-config.h>], [exit(NETSNMP_USE_OPENSSL != 1);],
+ [ AC_MSG_RESULT(yes)
+ SNMP_SSL=yes
+ ],
+ AC_MSG_RESULT(no)
+ )
+
+-AC_TRY_COMPILE([ #include <net-snmp-config.h>
++AC_TRY_COMPILE([ #include <net-snmp/net-snmp-config.h>
+ #include <net-snmp/utilities.h>
+ #include <net-snmp/net-snmp-includes.h>
+ #include <net-snmp/config_api.h>
diff --git a/net-analyzer/cacti-spine/files/cacti-spine-0.8.8g-parallel-make.patch b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8g-parallel-make.patch
new file mode 100644
index 000000000000..e7983ed759e5
--- /dev/null
+++ b/net-analyzer/cacti-spine/files/cacti-spine-0.8.8g-parallel-make.patch
@@ -0,0 +1,9 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -9,5 +9,5 @@
+
+ man_MANS = spine.1
+
+-spine.1: spine.c
++spine.1: $(sbin_PROGRAMS)
+ $(HELP2MAN) --output=$@ --name='Data Collector for Cacti' --no-info --version-option='--version' ./spine