summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-03-20 18:40:35 +0000
committerSam James <sam@gentoo.org>2022-03-20 18:43:31 +0000
commit6857d6b6b42825eac213df2ee6a920f4f5888818 (patch)
tree6354d6920ef0bd3caeb4595786dbd51586200be5 /net-analyzer
parentnet-analyzer/webfuzzer: [QA] fix tc-get* quoting (diff)
downloadgentoo-6857d6b6b42825eac213df2ee6a920f4f5888818.tar.gz
gentoo-6857d6b6b42825eac213df2ee6a920f4f5888818.tar.bz2
gentoo-6857d6b6b42825eac213df2ee6a920f4f5888818.zip
net-analyzer/nagios-core: [QA] fix tc-get* quoting
This can cause build problems for e.g. 32-bit (gcc -m32 ...) Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-core/nagios-core-4.4.6-r2.ebuild4
-rw-r--r--net-analyzer/nagios-core/nagios-core-4.4.6-r3.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/net-analyzer/nagios-core/nagios-core-4.4.6-r2.ebuild b/net-analyzer/nagios-core/nagios-core-4.4.6-r2.ebuild
index d868bf041bd4..da7044dcdd6a 100644
--- a/net-analyzer/nagios-core/nagios-core-4.4.6-r2.ebuild
+++ b/net-analyzer/nagios-core/nagios-core-4.4.6-r2.ebuild
@@ -136,11 +136,11 @@ src_configure() {
}
src_compile() {
- emake CC=$(tc-getCC) nagios
+ emake CC="$(tc-getCC)" nagios
if use web; then
# Only compile the CGIs/HTML when USE=web is set.
- emake CC=$(tc-getCC) DESTDIR="${D}" cgis html
+ emake CC="$(tc-getCC)" DESTDIR="${D}" cgis html
fi
}
diff --git a/net-analyzer/nagios-core/nagios-core-4.4.6-r3.ebuild b/net-analyzer/nagios-core/nagios-core-4.4.6-r3.ebuild
index 2f3ebaec2193..e0583cea138b 100644
--- a/net-analyzer/nagios-core/nagios-core-4.4.6-r3.ebuild
+++ b/net-analyzer/nagios-core/nagios-core-4.4.6-r3.ebuild
@@ -132,11 +132,11 @@ src_configure() {
}
src_compile() {
- emake CC=$(tc-getCC) nagios
+ emake CC="$(tc-getCC)" nagios
if use web; then
# Only compile the CGIs/HTML when USE=web is set.
- emake CC=$(tc-getCC) cgis html
+ emake CC="$(tc-getCC)" cgis html
fi
}