summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-07-26 15:04:37 +0200
committerJeroen Roovers <jer@gentoo.org>2020-07-26 19:54:41 +0200
commit863dce99366ca9b410ffc81bf25a30e7cc9c1665 (patch)
treee8d80afb8d4fee5ef3afb3a431da0add3db83def /net-analyzer
parentdev-util/github-cli: 0.11.0 bump (diff)
downloadgentoo-863dce99366ca9b410ffc81bf25a30e7cc9c1665.tar.gz
gentoo-863dce99366ca9b410ffc81bf25a30e7cc9c1665.tar.bz2
gentoo-863dce99366ca9b410ffc81bf25a30e7cc9c1665.zip
net-analyzer/scapy: Version 2.4.4_rc2
Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/scapy/Manifest1
-rw-r--r--net-analyzer/scapy/scapy-2.4.4_rc2.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/net-analyzer/scapy/Manifest b/net-analyzer/scapy/Manifest
index 011d63e669ff..dea71e01c8e9 100644
--- a/net-analyzer/scapy/Manifest
+++ b/net-analyzer/scapy/Manifest
@@ -1,3 +1,4 @@
DIST scapy-2.4.2.tar.gz 3330071 BLAKE2B a40074594cd561b33d04364fba743fa5fe741b06b2ad8f8f9ebe9dfb0b9a3bc4f641cd16d99a4ba070fc0763d7cfeb8d3ecd056f162d509070cdd57d55d6ad9c SHA512 980f708a849ae26edca3eb6618a41668818c5883bca699f347f47a8964b3ee44a6ceefe4a12cb7d5fe6c13f5cbe2b7547938e53139f4ec9e6ef384e30c9bb6db
DIST scapy-2.4.3.tar.gz 2969754 BLAKE2B 83ab6500dbc0424b728253661f03391d450f77b19c0059b8a605a19f48b4ddd7344743310a5cb7c741fcf750876ba125daf883d04714981ff81ef4db97519ae0 SHA512 579e3f326f90e10b2839aee805949e14ecab9431f360ef75e60080a971653e1f48a240d812b8ace77754b01b07a2ddb8533d1e6b18ee8804280bf9b2c237cede
DIST scapy-2.4.4_rc1.tar.gz 3222693 BLAKE2B 4b7e29253fd3c67e5bc0e85a01433b9e4b51347e163d26e7ce168d346931aaa5429ebde087cc2d28299fb36f96f3c3755038cc94ffd440ac4b761a3de0fdc4e1 SHA512 c2a0486d650dab2226fc40a7d5e18d5974230d09d1f711a7050c08027125acabb679e99530589bd3806cbd870a970ebefd4141bcac625768f04809e837cc9b1d
+DIST scapy-2.4.4_rc2.tar.gz 3223072 BLAKE2B db70edb6e4137821bb80fc12c3118f9458dbb121507a7e87ba120174529c30be602915f4476ac084ac93dfaab0e0de39ad90e5fe75e0c3c1c15e386dd4d218aa SHA512 16a974d28d8b594d83d71ec7ae56963d7ded394e9c3a046ef7a76e57cfae4d0cf2fedbf682827583b93afe2d02b222cd8e7229a6859747e99fcc018892efbad6
diff --git a/net-analyzer/scapy/scapy-2.4.4_rc2.ebuild b/net-analyzer/scapy/scapy-2.4.4_rc2.ebuild
new file mode 100644
index 000000000000..91851f33d4f4
--- /dev/null
+++ b/net-analyzer/scapy/scapy-2.4.4_rc2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7} )
+inherit distutils-r1 readme.gentoo-r1
+
+DESCRIPTION="A Python interactive packet manipulation program for mastering the network"
+HOMEPAGE="https://scapy.net/ https://github.com/secdev/scapy"
+SRC_URI="https://github.com/secdev/${PN}/archive/v${PV/_/}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RDEPEND="
+ net-analyzer/tcpdump
+"
+S=${WORKDIR}/${P/_/}
+DOC_CONTENTS="
+Scapy has optional support for the following packages:
+
+ dev-python/cryptography
+ dev-python/ipython
+ dev-python/matplotlib
+ dev-python/pyx
+ media-gfx/graphviz
+ net-analyzer/tcpreplay
+ virtual/imagemagick-tools
+
+ See also ""${EPREFIX}/usr/share/doc/${PF}/installation.rst""
+"
+
+src_prepare() {
+ echo ${PV/_/} > ${PN}/VERSION || die
+
+ distutils-r1_src_prepare
+}
+
+src_install() {
+ distutils-r1_src_install
+ dodoc -r doc/${PN}/*
+ DISABLE_AUTOFORMATTING=plz readme.gentoo_create_doc
+}