summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-08-10 17:20:47 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-08-10 17:27:25 +0200
commit8c73e499a7f84932e4b53d85eefc8eaf470603c6 (patch)
tree2d1641183a349a8eb79b152e2aaadbb9cf1496d5 /net-analyzer
parentx11-themes/light-themes: 19.04 + EAPI 7 (diff)
downloadgentoo-8c73e499a7f84932e4b53d85eefc8eaf470603c6.tar.gz
gentoo-8c73e499a7f84932e4b53d85eefc8eaf470603c6.tar.bz2
gentoo-8c73e499a7f84932e4b53d85eefc8eaf470603c6.zip
net-analyzer/nagios-plugins-linux-madrisan: bump to v27
Package-Manager: Portage-3.0.2, Repoman-2.3.23 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/nagios-plugins-linux-madrisan/Manifest1
-rw-r--r--net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-27.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/net-analyzer/nagios-plugins-linux-madrisan/Manifest b/net-analyzer/nagios-plugins-linux-madrisan/Manifest
index 439a712c1182..cb6c6ac7f9a0 100644
--- a/net-analyzer/nagios-plugins-linux-madrisan/Manifest
+++ b/net-analyzer/nagios-plugins-linux-madrisan/Manifest
@@ -1,2 +1,3 @@
DIST nagios-plugins-linux-madrisan-25.tar.xz 371712 BLAKE2B 60637426d9ced289a1acdf61c3e7c5a2b3227afb20079ef93d445057b2127d12a6c76ab5a780571ac8bdd6ac3b55de2761722236d2ed7a057ab84559d97610e9 SHA512 64961a16e24802d66c48d0c33bd63d75aba8492f38dd83a57ee2e7cb728cf6876c7869622256c4249a9e9da39b744a332df6ecad80f6039861887bb5c8d806ec
DIST nagios-plugins-linux-madrisan-26.tar.xz 379480 BLAKE2B e30fa00c029506ffd76e9c16f409f62f00ab481894d6b35dd34470dab5f2a18b2fc18bd06ae5e6a7179ed23f36c785c9a403258b9066e5a08f6a139ab0192088 SHA512 61c523ddf7a98ae01caf543a7e38903478346ce380884a7cd2a2e592db806e73fb996675aa701e2bbf57b31ed062886daba4af70cc2875e1c296537de01c588d
+DIST nagios-plugins-linux-madrisan-27.tar.xz 385324 BLAKE2B ef207e365d044fefa8c0dbef7aae8a50ec9b6c70d60d069574ed423646d1e936e0bd6bbb316070d94f354236f815e508da4ec1b298e89958c8393a041f98a908 SHA512 5d93912f2237449e29e963cca260fbe7a735f47e7c2752402e2f371289e2875e4fea35f191705d7a2f01ac49381e039b720f43c8c794e85ee0bbbb01d212a10a
diff --git a/net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-27.ebuild b/net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-27.ebuild
new file mode 100644
index 000000000000..f76ea708a821
--- /dev/null
+++ b/net-analyzer/nagios-plugins-linux-madrisan/nagios-plugins-linux-madrisan-27.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+MY_PN="nagios-plugins-linux"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Additional and alternative Nagios plugins for Linux"
+HOMEPAGE="https://github.com/madrisan/nagios-plugins-linux"
+SRC_URI="https://github.com/madrisan/${MY_PN}/releases/download/v${PV}/${MY_P}.tar.xz -> ${P}.tar.xz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="curl varlink"
+
+DEPEND="
+ curl? ( net-misc/curl:0= )
+ varlink? ( dev-libs/libvarlink:= )
+"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ default
+ # Avoid collision with net-analyzer/monitoring-plugins
+ # and net-analyzer/nagios-plugins
+ sed -ri "s/check_(load|swap|uptime|users)/&_madrisan/" plugins/Makefile.am || die
+ eautoreconf
+}
+
+src_configure() {
+ local myconf=(
+ --libexecdir="${EPREFIX}/usr/$(get_libdir)/nagios/plugins"
+ # Most options are already defaults for Gentoo
+ --disable-hardening
+ $(use_enable curl libcurl)
+ $(use_enable varlink libvarlink)
+ )
+ econf "${myconf[@]}"
+}
+
+src_test() {
+ emake check VERBOSE=1
+}