summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-07-31 00:02:55 +0100
committerSam James <sam@gentoo.org>2021-07-31 00:29:59 +0100
commitafbf9a0c6207949abd1e601d6d1c26b17df4eae2 (patch)
tree6bedfc796a4dd0245598a696d62d66757b718f54 /net-analyzer
parentnet-analyzer/vnstat: [QA] call tmpfiles_process in pkg_postinst (diff)
downloadgentoo-afbf9a0c6207949abd1e601d6d1c26b17df4eae2.tar.gz
gentoo-afbf9a0c6207949abd1e601d6d1c26b17df4eae2.tar.bz2
gentoo-afbf9a0c6207949abd1e601d6d1c26b17df4eae2.zip
net-analyzer/zabbix: [QA] call tmpfiles_process in pkg_postinst
This is needed to actually apply the tmpfiles configuration we've installed in the ebuild. See tmpfiles.eclass documentation. Package-Manager: Portage-3.0.20, Repoman-3.0.3 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/zabbix/zabbix-4.0.31-r1.ebuild9
-rw-r--r--net-analyzer/zabbix/zabbix-4.0.32.ebuild10
-rw-r--r--net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild14
-rw-r--r--net-analyzer/zabbix/zabbix-5.0.13.ebuild14
-rw-r--r--net-analyzer/zabbix/zabbix-5.0.14.ebuild14
-rw-r--r--net-analyzer/zabbix/zabbix-5.4.1-r1.ebuild14
-rw-r--r--net-analyzer/zabbix/zabbix-5.4.2.ebuild14
-rw-r--r--net-analyzer/zabbix/zabbix-5.4.3.ebuild14
8 files changed, 103 insertions, 0 deletions
diff --git a/net-analyzer/zabbix/zabbix-4.0.31-r1.ebuild b/net-analyzer/zabbix/zabbix-4.0.31-r1.ebuild
index 9aad51163a13..f3cb8a820f0f 100644
--- a/net-analyzer/zabbix/zabbix-4.0.31-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-4.0.31-r1.ebuild
@@ -313,6 +313,7 @@ pkg_postinst() {
fi
if use server; then
+ tmpfiles_process zabbix-server.conf
elog
elog "For distributed monitoring you have to run:"
elog
@@ -323,6 +324,14 @@ pkg_postinst() {
elog
fi
+ if use proxy ; then
+ tmpfiles_process zabbix-proxy.conf
+ fi
+
+ if use agent ; then
+ tmpfiles_process zabbix-agent.conf
+ fi
+
elog "--"
elog
elog "You may need to add these lines to /etc/services:"
diff --git a/net-analyzer/zabbix/zabbix-4.0.32.ebuild b/net-analyzer/zabbix/zabbix-4.0.32.ebuild
index d1235337a343..b4467228139f 100644
--- a/net-analyzer/zabbix/zabbix-4.0.32.ebuild
+++ b/net-analyzer/zabbix/zabbix-4.0.32.ebuild
@@ -313,6 +313,8 @@ pkg_postinst() {
fi
if use server; then
+ tmpfiles_process zabbix-server.conf
+
elog
elog "For distributed monitoring you have to run:"
elog
@@ -323,6 +325,14 @@ pkg_postinst() {
elog
fi
+ if use proxy; then
+ tmpfiles_process zabbix-proxy.conf
+ fi
+
+ if use agent; then
+ tmpfiles_process zabbix-agentd.conf
+ fi
+
elog "--"
elog
elog "You may need to add these lines to /etc/services:"
diff --git a/net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild b/net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild
index c94739cfae13..b8d35f5a7591 100644
--- a/net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.0.12-r1.ebuild
@@ -557,6 +557,8 @@ pkg_postinst() {
fi
if use server; then
+ tmpfiles_process zabbix-server.conf
+
elog
elog "For distributed monitoring you have to run:"
elog
@@ -567,6 +569,18 @@ pkg_postinst() {
elog
fi
+ if use proxy; then
+ tmpfiles_process zabbix-proxy.conf
+ fi
+
+ if use agent; then
+ tmpfiles_process zabbix-agentd.conf
+ fi
+
+ if use agent2; then
+ tmpfiles_process zabbix-agent2.conf
+ fi
+
elog "--"
elog
elog "You may need to add these lines to /etc/services:"
diff --git a/net-analyzer/zabbix/zabbix-5.0.13.ebuild b/net-analyzer/zabbix/zabbix-5.0.13.ebuild
index b921c70a4e01..eba63f9a9e55 100644
--- a/net-analyzer/zabbix/zabbix-5.0.13.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.0.13.ebuild
@@ -557,6 +557,8 @@ pkg_postinst() {
fi
if use server; then
+ tmpfiles_process zabbix-server.conf
+
elog
elog "For distributed monitoring you have to run:"
elog
@@ -567,6 +569,18 @@ pkg_postinst() {
elog
fi
+ if use proxy; then
+ tmpfiles_process zabbix-proxy.conf
+ fi
+
+ if use agent; then
+ tmpfiles_process zabbix-agentd.conf
+ fi
+
+ if use agent2; then
+ tmpfiles_process zabbix-agent2.conf
+ fi
+
elog "--"
elog
elog "You may need to add these lines to /etc/services:"
diff --git a/net-analyzer/zabbix/zabbix-5.0.14.ebuild b/net-analyzer/zabbix/zabbix-5.0.14.ebuild
index b921c70a4e01..eba63f9a9e55 100644
--- a/net-analyzer/zabbix/zabbix-5.0.14.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.0.14.ebuild
@@ -557,6 +557,8 @@ pkg_postinst() {
fi
if use server; then
+ tmpfiles_process zabbix-server.conf
+
elog
elog "For distributed monitoring you have to run:"
elog
@@ -567,6 +569,18 @@ pkg_postinst() {
elog
fi
+ if use proxy; then
+ tmpfiles_process zabbix-proxy.conf
+ fi
+
+ if use agent; then
+ tmpfiles_process zabbix-agentd.conf
+ fi
+
+ if use agent2; then
+ tmpfiles_process zabbix-agent2.conf
+ fi
+
elog "--"
elog
elog "You may need to add these lines to /etc/services:"
diff --git a/net-analyzer/zabbix/zabbix-5.4.1-r1.ebuild b/net-analyzer/zabbix/zabbix-5.4.1-r1.ebuild
index cd6face9be93..73471980e5cb 100644
--- a/net-analyzer/zabbix/zabbix-5.4.1-r1.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.4.1-r1.ebuild
@@ -581,6 +581,8 @@ pkg_postinst() {
fi
if use server; then
+ tmpfiles_process zabbix-server.conf
+
elog
elog "For distributed monitoring you have to run:"
elog
@@ -591,6 +593,18 @@ pkg_postinst() {
elog
fi
+ if use proxy; then
+ tmpfiles_process zabbix-proxy.conf
+ fi
+
+ if use agent; then
+ tmpfiles_process zabbix-agentd.conf
+ fi
+
+ if use agent2; then
+ tmpfiles_process zabbix-agent2.conf
+ fi
+
elog "--"
elog
elog "You may need to add these lines to /etc/services:"
diff --git a/net-analyzer/zabbix/zabbix-5.4.2.ebuild b/net-analyzer/zabbix/zabbix-5.4.2.ebuild
index 8a3157cfa587..21c67e3c16ad 100644
--- a/net-analyzer/zabbix/zabbix-5.4.2.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.4.2.ebuild
@@ -581,6 +581,8 @@ pkg_postinst() {
fi
if use server; then
+ tmpfiles_process zabbix-server.conf
+
elog
elog "For distributed monitoring you have to run:"
elog
@@ -591,6 +593,18 @@ pkg_postinst() {
elog
fi
+ if use proxy; then
+ tmpfiles_process zabbix-proxy.conf
+ fi
+
+ if use agent; then
+ tmpfiles_process zabbix-agentd.conf
+ fi
+
+ if use agent2; then
+ tmpfiles_process zabbix-agent2.conf
+ fi
+
elog "--"
elog
elog "You may need to add these lines to /etc/services:"
diff --git a/net-analyzer/zabbix/zabbix-5.4.3.ebuild b/net-analyzer/zabbix/zabbix-5.4.3.ebuild
index 8a3157cfa587..21c67e3c16ad 100644
--- a/net-analyzer/zabbix/zabbix-5.4.3.ebuild
+++ b/net-analyzer/zabbix/zabbix-5.4.3.ebuild
@@ -581,6 +581,8 @@ pkg_postinst() {
fi
if use server; then
+ tmpfiles_process zabbix-server.conf
+
elog
elog "For distributed monitoring you have to run:"
elog
@@ -591,6 +593,18 @@ pkg_postinst() {
elog
fi
+ if use proxy; then
+ tmpfiles_process zabbix-proxy.conf
+ fi
+
+ if use agent; then
+ tmpfiles_process zabbix-agentd.conf
+ fi
+
+ if use agent2; then
+ tmpfiles_process zabbix-agent2.conf
+ fi
+
elog "--"
elog
elog "You may need to add these lines to /etc/services:"