summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2017-11-05 21:43:47 +0100
committerManuel Rüger <mrueg@gentoo.org>2017-11-05 21:44:25 +0100
commitd4807e70b4e60dd4d7a971b4549a68e7c3161100 (patch)
tree089bc4a96662a79e1f8803a3a5ec7d100e3a2866 /net-analyzer
parentnet-analyzer/prometheus: Version bump to 1.8.2 (diff)
downloadgentoo-d4807e70b4e60dd4d7a971b4549a68e7c3161100.tar.gz
gentoo-d4807e70b4e60dd4d7a971b4549a68e7c3161100.tar.bz2
gentoo-d4807e70b4e60dd4d7a971b4549a68e7c3161100.zip
net-analyzer/prometheus: Version bump to 2.0.0_rc3
Package-Manager: Portage-2.3.12, Repoman-2.3.4
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/prometheus/Manifest1
-rw-r--r--net-analyzer/prometheus/prometheus-2.0.0_rc3.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/net-analyzer/prometheus/Manifest b/net-analyzer/prometheus/Manifest
index 75230ee8160a..7b183a7f3981 100644
--- a/net-analyzer/prometheus/Manifest
+++ b/net-analyzer/prometheus/Manifest
@@ -1,3 +1,4 @@
DIST prometheus-1.8.1.tar.gz 5194859 SHA256 dc2b7bb5b5f1273c131921d3e306fd198f2a5547abc58dcf511b700c62963595 SHA512 936728f51a12a080a0689c17b134f70f747bb2219f750ea5f7df7460169b3e484689d75df319cfae12fc939b556e4f59ed49682731e43405a4a91e4bbcd9cbb7 WHIRLPOOL 755ac91ecfe9234675bac2cee2c63a50c80a5e02267818b1ac7747c669df81e4e267dd884aa1da7463339f5344e8fdbb488c7521d0d7817360bad74ece256a86
DIST prometheus-1.8.2.tar.gz 5238057 SHA256 7c8a9c9756790d1c4eb436bb6ebda49e2f671a6319c06a1c63d5df9eff7da0e2 SHA512 ed52ab494ae565d4787b29cf1800605ac3bfdacee25e833704131d57bad9759a3e2585b96316ad754e6612324e68079d7f670004a86aa12c768a2e03542966d2 WHIRLPOOL c61ed7a9238a86e0cdc1813e0d0f88e9b90567986b61e0e856d34f42d1c5ef5f2c66e6e95be659f00883aec39660536653c2d0f5baaf4573600711929480bd00
DIST prometheus-2.0.0_rc2.tar.gz 5539456 SHA256 99340e1708f9dd216048d0de8ce1a069c70879760d833dfee1ef480966d2d53c SHA512 c895e0a561e89a13cee4cba1f4899ffcb4a8094f72618b9c7c2e48a035ceef3b844c0c8b9603f0886fac3e0d1c43b1e235f784f18d289e47c0e858b5d53ed47b WHIRLPOOL 60070eddcaa06ada89e5612c893c97098c48c6d5953d17e1cfe6b16708c332aa9d855aaecf6aa00c28527b22ad77ce6ff26cbade01ea2e71d1bafc9ece59f655
+DIST prometheus-2.0.0_rc3.tar.gz 5585258 SHA256 3e2eb9f2f24b12cea81b1918caa988ba42f842dba042e6c7ab8fdac54ec6a018 SHA512 4d4ee83bbb8db3738c5c84f5d544d8b3ee25cef528ce15d6e6f02b67349c73a01347a8e22de2de04cce008ff707c6e59988e35dacd0bbaa0ab0b1356bcfabdb7 WHIRLPOOL d0429870bac7e925b023132ae1a046cceeb7ff0354f104c73f2651ae06a90df575261f6a69e112d9fbd1590008418739ac54d3ddda1ab6572aa106f6e8f050c9
diff --git a/net-analyzer/prometheus/prometheus-2.0.0_rc3.ebuild b/net-analyzer/prometheus/prometheus-2.0.0_rc3.ebuild
new file mode 100644
index 000000000000..e08580906149
--- /dev/null
+++ b/net-analyzer/prometheus/prometheus-2.0.0_rc3.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit user golang-build golang-vcs-snapshot
+
+EGO_PN="github.com/prometheus/prometheus"
+MY_PV=${PV/_rc/-rc.}
+EGIT_COMMIT="v${MY_PV}"
+PROMETHEUS_COMMIT="8a9b32d"
+ARCHIVE_URI="https://${EGO_PN}/archive/${EGIT_COMMIT}.tar.gz -> ${P}.tar.gz"
+KEYWORDS="~amd64"
+
+DESCRIPTION="Prometheus monitoring system and time series database"
+HOMEPAGE="https://github.com/prometheus/prometheus"
+SRC_URI="${ARCHIVE_URI}"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE=""
+
+DEPEND="dev-util/promu"
+
+PROMETHEUS_HOME="/var/lib/prometheus"
+
+RESTRICT="test"
+
+pkg_setup() {
+ enewgroup prometheus
+ enewuser prometheus -1 -1 "${PROMETHEUS_HOME}" prometheus
+}
+
+src_prepare() {
+ default
+ sed -i -e "s/{{.Revision}}/${PROMETHEUS_COMMIT}/" src/${EGO_PN}/.promu.yml || die
+}
+
+src_compile() {
+ pushd src/${EGO_PN} || die
+ GOPATH="${S}" promu build -v || die
+ popd || die
+}
+
+src_install() {
+ pushd src/${EGO_PN} || die
+ dobin promtool prometheus
+ dodoc -r {documentation,{README,CHANGELOG,CONTRIBUTING}.md}
+ insinto /etc/prometheus
+ doins documentation/examples/prometheus.yml
+ insinto /usr/share/prometheus
+ doins -r console_libraries consoles
+ dosym ../../usr/share/prometheus/console_libraries /etc/prometheus/console_libraries
+ dosym ../../usr/share/prometheus/consoles /etc/prometheus/consoles
+ popd || die
+
+ newinitd "${FILESDIR}"/prometheus-3.initd prometheus
+ newconfd "${FILESDIR}"/prometheus.confd prometheus
+ keepdir /var/log/prometheus /var/lib/prometheus
+ fowners prometheus:prometheus /var/log/prometheus /var/lib/prometheus
+}
+
+pkg_postinst() {
+ if has_version '<net-analyzer/prometheus-2.0.0_rc0'; then
+ ewarn "Old prometheus 1.x TSDB won't be converted to the new prometheus 2.0 format"
+ ewarn "Be aware that the old data currently cannot be accessed with prometheus 2.0"
+ ewarn "This release requires a clean storage directory and is not compatible with"
+ ewarn "files created by previous beta releases"
+ fi
+}