summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2016-02-23 19:50:07 +0100
committerDavid Seifert <soap@gentoo.org>2016-02-23 19:50:21 +0100
commitdcd30cf750b6cc2207a98baff90e15ce8f305c79 (patch)
tree5224cfbab82b282195e2d1ce7df87613bef775d4 /net-analyzer
parentdev-python/vcstools: add python 3.5 support (diff)
downloadgentoo-dcd30cf750b6cc2207a98baff90e15ce8f305c79.tar.gz
gentoo-dcd30cf750b6cc2207a98baff90e15ce8f305c79.tar.bz2
gentoo-dcd30cf750b6cc2207a98baff90e15ce8f305c79.zip
net-analyzer/bwm-ng: Amend patch to include missing AC_DEFINE
Gentoo-Bug: 561718 Package-Manager: portage-2.2.27
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/bwm-ng/bwm-ng-0.6.1-r1.ebuild (renamed from net-analyzer/bwm-ng/bwm-ng-0.6.1.ebuild)0
-rw-r--r--net-analyzer/bwm-ng/files/bwm-ng-0.6.1-fix-buildsystem.patch13
2 files changed, 12 insertions, 1 deletions
diff --git a/net-analyzer/bwm-ng/bwm-ng-0.6.1.ebuild b/net-analyzer/bwm-ng/bwm-ng-0.6.1-r1.ebuild
index ae30fbd3d4f7..ae30fbd3d4f7 100644
--- a/net-analyzer/bwm-ng/bwm-ng-0.6.1.ebuild
+++ b/net-analyzer/bwm-ng/bwm-ng-0.6.1-r1.ebuild
diff --git a/net-analyzer/bwm-ng/files/bwm-ng-0.6.1-fix-buildsystem.patch b/net-analyzer/bwm-ng/files/bwm-ng-0.6.1-fix-buildsystem.patch
index 85f2819786e2..5e1b22749637 100644
--- a/net-analyzer/bwm-ng/files/bwm-ng-0.6.1-fix-buildsystem.patch
+++ b/net-analyzer/bwm-ng/files/bwm-ng-0.6.1-fix-buildsystem.patch
@@ -48,7 +48,7 @@ https://bugs.gentoo.org/show_bug.cgi?id=561718
- CURSES_CHECKED="1"
-fi
+AS_IF([test "x$enable_ncurses" != "xno"], [
-+ PKG_CHECK_MODULES([NCURSES], [ncurses])
++ PKG_CHECK_MODULES([NCURSES], [ncurses], [AC_DEFINE([HAVE_LIBNCURSES], [1], [Define to 1 if you have the `ncurses' library (-lncurses).])])
])
-fi
-
@@ -80,3 +80,14 @@ https://bugs.gentoo.org/show_bug.cgi?id=561718
noinst_HEADERS = bwm-ng.h process.h output.h options.h help.h curses_tools.h types.h defines.h global_vars.h input/devstat.h input/libkstat.h input/netstat.h input/proc_net_dev.h input/sysctl.h input/ioservice.h input/libstatgrab.h input/proc_diskstats.h input/retrieve.h input/win32.h input/getifaddrs.h
+--- bwm-ng-0.6.1/src/defines.h
++++ bwm-ng-0.6.1/src/defines.h
+@@ -48,7 +48,7 @@
+ #define LIBSTATGRAB
+ #endif
+
+-#if HAVE_LIBCURSES || HAVE_LIBNCURSES
++#if defined(HAVE_LIBCURSES) || defined(HAVE_LIBNCURSES)
+ #define HAVE_CURSES
+ #endif
+