summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2017-02-04 22:15:03 +0100
committerFabian Groffen <grobian@gentoo.org>2017-02-04 22:15:56 +0100
commite5099643edcd981586507f486a885fd797cd7be3 (patch)
tree47eec102bdca5f823e039c656e68858a72dba721 /net-analyzer
parentdev-scheme/guile-json: Initial commit (diff)
downloadgentoo-e5099643edcd981586507f486a885fd797cd7be3.tar.gz
gentoo-e5099643edcd981586507f486a885fd797cd7be3.tar.bz2
gentoo-e5099643edcd981586507f486a885fd797cd7be3.zip
net-analyzer/mtr: fix filecaps problem in Prefix, bug #599604
Package-Manager: portage-2.3.3
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/mtr/mtr-0.87-r1.ebuild60
-rw-r--r--net-analyzer/mtr/mtr-9999.ebuild10
2 files changed, 69 insertions, 1 deletions
diff --git a/net-analyzer/mtr/mtr-0.87-r1.ebuild b/net-analyzer/mtr/mtr-0.87-r1.ebuild
new file mode 100644
index 000000000000..50bfe44956bc
--- /dev/null
+++ b/net-analyzer/mtr/mtr-0.87-r1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools eutils fcaps flag-o-matic
+
+DESCRIPTION="My TraceRoute, an Excellent network diagnostic tool"
+HOMEPAGE="http://www.bitwizard.nl/mtr/"
+SRC_URI="ftp://ftp.bitwizard.nl/mtr/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="gtk ipv6"
+
+RDEPEND="
+ sys-libs/ncurses:0=
+ gtk? (
+ dev-libs/glib:2
+ x11-libs/gtk+:2
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/autoconf
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS FORMATS NEWS README SECURITY TODO )
+FILECAPS=( cap_net_raw usr/sbin/mtr )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.80-impl-dec.patch
+ "${FILESDIR}"/${PN}-0.87-ipv6.patch
+ "${FILESDIR}"/${PN}-0.87-tinfo.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ # In the source's configure script -lresolv is commented out. Apparently it
+ # is needed for 64bit macos still.
+ [[ ${CHOST} == *-darwin* ]] && append-libs -lresolv
+
+ econf \
+ $(use_enable ipv6) \
+ $(use_with gtk) \
+ --disable-gtktest
+}
+
+pkg_postinst() {
+ if use prefix && [[ ${CHOST} == *-darwin* ]] ; then
+ ewarn "mtr needs root privileges to run. To grant them:"
+ ewarn " % sudo chown root ${EPREFIX}/usr/sbin/mtr"
+ ewarn " % sudo chmod u+s ${EPREFIX}/usr/sbin/mtr"
+ fi
+}
diff --git a/net-analyzer/mtr/mtr-9999.ebuild b/net-analyzer/mtr/mtr-9999.ebuild
index 797b07c37320..47d97b07432d 100644
--- a/net-analyzer/mtr/mtr-9999.ebuild
+++ b/net-analyzer/mtr/mtr-9999.ebuild
@@ -29,7 +29,7 @@ DEPEND="
"
DOCS=( AUTHORS FORMATS NEWS README SECURITY TODO )
-FILECAPS=( cap_net_raw /usr/sbin/mtr )
+FILECAPS=( cap_net_raw usr/sbin/mtr )
PATCHES=(
"${FILESDIR}"/${PN}-9999-tinfo.patch
)
@@ -58,3 +58,11 @@ src_configure() {
$(use_with gtk) \
$(use_with ncurses)
}
+
+pkg_postinst() {
+ if use prefix && [[ ${CHOST} == *-darwin* ]] ; then
+ ewarn "mtr needs root privileges to run. To grant them:"
+ ewarn " % sudo chown root ${EPREFIX}/usr/sbin/mtr"
+ ewarn " % sudo chmod u+s ${EPREFIX}/usr/sbin/mtr"
+ fi
+}