summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2016-02-24 06:32:35 +0100
committerJeroen Roovers <jer@gentoo.org>2016-02-24 06:32:35 +0100
commitfb18f46168250ca341ab2ee95f1c3e0891edebd3 (patch)
tree32c971abe6144e7415e0a8727a80148df5904082 /net-analyzer
parentnet-misc/youtube-dl: Old. (diff)
downloadgentoo-fb18f46168250ca341ab2ee95f1c3e0891edebd3.tar.gz
gentoo-fb18f46168250ca341ab2ee95f1c3e0891edebd3.tar.bz2
gentoo-fb18f46168250ca341ab2ee95f1c3e0891edebd3.zip
net-analyzer/fwlogwatch: Version bump.
Package-Manager: portage-2.2.27
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/fwlogwatch/Manifest1
-rw-r--r--net-analyzer/fwlogwatch/fwlogwatch-1.5.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/net-analyzer/fwlogwatch/Manifest b/net-analyzer/fwlogwatch/Manifest
index a1529b7ad61e..2aeebe4a2ea0 100644
--- a/net-analyzer/fwlogwatch/Manifest
+++ b/net-analyzer/fwlogwatch/Manifest
@@ -1 +1,2 @@
DIST fwlogwatch-1.4.tar.bz2 92652 SHA256 0ca67b2f2a36e4f79ac202018d5440809d50a1cb7203e2a02818f2aade112e9a SHA512 0a67c0ae8b096fdf7a06e279a11b0bc71f2d514790c1669f60606b17a7f3f3ec97dedc2005438ce0ec82efcd66a822b62dbb36603f4b02e010f469fb885b87e6 WHIRLPOOL 7dc01a46be44733cab6f69525f704f4ed86802112bfff284480df4d9151174e6d0bb03a6cc7349a77b7c32b6d312dea582627c0e7b71cad4e36073fda46057f9
+DIST fwlogwatch-1.5.tar.bz2 94451 SHA256 0c8c9465b9d6c653b26492028bb040f60987804dfc53e480cb8cfde62cb72b1d SHA512 d4890596859929ddc6adfd7f9e735e0c414bad40eff6732120a522a8bd4fb8d1442c7d1026f0f3c6ac5c4d51b76a2bac486d04f0fbceae67395c585098afef85 WHIRLPOOL 6dd21c08158c2fd99c13ea46e8cbd9ebd7ec7e0612cf21f6cef07efcbe134aec900bae33ecd74f61fa1ddbc799bfd22d37f5c42927a72f02b8298c7851f2e2b0
diff --git a/net-analyzer/fwlogwatch/fwlogwatch-1.5.ebuild b/net-analyzer/fwlogwatch/fwlogwatch-1.5.ebuild
new file mode 100644
index 000000000000..1479b995f8d8
--- /dev/null
+++ b/net-analyzer/fwlogwatch/fwlogwatch-1.5.ebuild
@@ -0,0 +1,87 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit eutils flag-o-matic toolchain-funcs
+
+DESCRIPTION="A packet filter and firewall log analyzer"
+HOMEPAGE="http://fwlogwatch.inside-security.de/"
+SRC_URI="${HOMEPAGE}sw/${P}.tar.bz2"
+
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+LICENSE="GPL-1"
+SLOT="0"
+IUSE="nls zlib"
+
+RDEPEND="
+ zlib? ( sys-libs/zlib )
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/flex
+ nls? ( sys-devel/gettext )
+"
+
+src_prepare() {
+ if use nls; then
+ strip-linguas -i po/
+ local lingua pofile
+ for pofile in po/*.po; do
+ lingua=${pofile/po\/}
+ lingua=${lingua/.po}
+ if ! has ${lingua} ${LINGUAS}; then
+ sed -i \
+ -e "/${lingua}.[mp]o/d" \
+ Makefile po/Makefile || die
+ fi
+ done
+ fi
+
+ sed -i \
+ -e '/^INSTALL_/s|$| -D|g' \
+ -e 's|make|$(MAKE)|g ' \
+ Makefile || die
+}
+
+src_configure() {
+ if ! use zlib; then
+ sed -i Makefile -e '/^LIBS/ s|-lz||g' || die
+ else
+ append-cflags -DHAVE_ZLIB
+ fi
+
+ use nls && append-cflags -DHAVE_GETTEXT
+}
+
+src_compile() {
+ emake \
+ CC=$(tc-getCC) \
+ CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}"
+ use nls && emake -C po
+}
+
+src_install() {
+ emake \
+ LOCALE_DIR="${D}/usr" INSTALL_DIR="${D}/usr" \
+ install
+ use nls && emake \
+ LOCALE_DIR="${D}/usr" INSTALL_DIR="${D}/usr" \
+ install-i18n
+
+ dosbin contrib/fwlw_notify
+ dosbin contrib/fwlw_respond
+
+ dodoc AUTHORS ChangeLog CREDITS README
+
+ insinto /usr/share/fwlogwatch/contrib
+
+ doins contrib/fwlogsummary.cgi
+ doins contrib/fwlogsummary_small.cgi
+ doins contrib/fwlogwatch.php
+
+ insinto /etc
+ doins fwlogwatch.config
+}