summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-02-16 07:57:38 +0100
committerJeroen Roovers <jer@gentoo.org>2017-02-16 07:59:40 +0100
commitfe0d294e3e08d186415a121c1712d0b3ce00bb94 (patch)
treeba1d5ccb558044e2cbd2282c44cff6c74faeb719 /net-analyzer
parentdev-ruby/archive-tar-minitar: add missing minitest dependency, bug 609422 (diff)
downloadgentoo-fe0d294e3e08d186415a121c1712d0b3ce00bb94.tar.gz
gentoo-fe0d294e3e08d186415a121c1712d0b3ce00bb94.tar.bz2
gentoo-fe0d294e3e08d186415a121c1712d0b3ce00bb94.zip
net-analyzer/slurm: Version bump.
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'net-analyzer')
-rw-r--r--net-analyzer/slurm/Manifest1
-rw-r--r--net-analyzer/slurm/files/slurm-0.4.3-tinfo.patch11
-rw-r--r--net-analyzer/slurm/files/slurm-0.4.3-version.patch7
-rw-r--r--net-analyzer/slurm/slurm-0.4.3.ebuild38
4 files changed, 57 insertions, 0 deletions
diff --git a/net-analyzer/slurm/Manifest b/net-analyzer/slurm/Manifest
index 5f06db15c49c..9a0338b03347 100644
--- a/net-analyzer/slurm/Manifest
+++ b/net-analyzer/slurm/Manifest
@@ -1 +1,2 @@
DIST slurm-0.3.3.tar.gz 122839 SHA256 b25889aa1910b1bb48e4eafdac0c810bc02e8b98ddb2ade0aed2ec64672d6834 SHA512 67ffef9d0fc6239e2a742b2020a2a1fa913a6f0d681ffb7fd00611265e60b39f83b18cbd782ce841b6b39ed0db2c40cd6410d7f5d9408bf0eb0361b95949a8a3 WHIRLPOOL a35d3cb726bf390f90c7f095c34b94b48cc0c3f59a8f8b88aa6ce31c033f74542e8ce7cefb1ecc15ea13ad5addecd9c0a321bf1e2834b582ff770fcfe9c4e1e2
+DIST slurm-0.4.3.tar.gz 36076 SHA256 f7092c378f85e473192d0aa3db4801077e0f9e148a7448cc2247cbdf639874aa SHA512 f55005e2e2acebf1b7be0f7106511f83123f4df30305d00495940220f99394ddd48193ee4985c91604f294487c181f6efebe9452137f7df5b9675d2c3388892f WHIRLPOOL be565768c3ac5af46388beba98e0b67c425bab15f934b38f1ef425e18eb18538944fba69fc98222f66cdc20620e9d5947aaf22e08d37c753dba960ce914b579f
diff --git a/net-analyzer/slurm/files/slurm-0.4.3-tinfo.patch b/net-analyzer/slurm/files/slurm-0.4.3-tinfo.patch
new file mode 100644
index 000000000000..c1a1233f177b
--- /dev/null
+++ b/net-analyzer/slurm/files/slurm-0.4.3-tinfo.patch
@@ -0,0 +1,11 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -25,7 +25,7 @@
+
+ add_executable(slurm ${SLURM_SOURCES})
+
+-target_link_libraries(slurm ncurses)
++target_link_libraries(slurm ${CURSES_LIBRARY} ${CURSES_EXTRA_LIBRARY})
+
+ # install
+ install(TARGETS slurm DESTINATION bin)
diff --git a/net-analyzer/slurm/files/slurm-0.4.3-version.patch b/net-analyzer/slurm/files/slurm-0.4.3-version.patch
new file mode 100644
index 000000000000..2266cad19356
--- /dev/null
+++ b/net-analyzer/slurm/files/slurm-0.4.3-version.patch
@@ -0,0 +1,7 @@
+--- a/config.h
++++ b/config.h
+@@ -1,2 +1,2 @@
+-#define PACKAGE_VERSION "0.4.3+git"
+-#define VERSION "0.4.3+git"
++#define PACKAGE_VERSION "0.4.3"
++#define VERSION "0.4.3"
diff --git a/net-analyzer/slurm/slurm-0.4.3.ebuild b/net-analyzer/slurm/slurm-0.4.3.ebuild
new file mode 100644
index 000000000000..9be9e1f13bb8
--- /dev/null
+++ b/net-analyzer/slurm/slurm-0.4.3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit cmake-utils
+
+DESCRIPTION="Realtime network interface monitor based on FreeBSD's pppstatus"
+HOMEPAGE="https://github.com/mattthias/slurm"
+SRC_URI="${HOMEPAGE}/archive/upstream/${PN}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="
+ sys-libs/ncurses
+"
+DEPEND="
+ ${RDEPEND}
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.3.3-overflow.patch
+ "${FILESDIR}"/${P}-tinfo.patch
+ "${FILESDIR}"/${P}-version.patch
+)
+DOCS=(
+ AUTHORS
+ ChangeLog
+ FAQ
+ KEYS
+ README
+ THANKS
+ THEMES.txt
+ TODO
+)
+
+S=${WORKDIR}/${PN}-upstream