summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /net-dialup/capifwd
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'net-dialup/capifwd')
-rw-r--r--net-dialup/capifwd/Manifest1
-rw-r--r--net-dialup/capifwd/capifwd-0.6.3-r1.ebuild42
-rw-r--r--net-dialup/capifwd/files/capifwd-0.6.3-amd64.patch136
-rw-r--r--net-dialup/capifwd/files/capifwd-0.6.3.patch42
-rw-r--r--net-dialup/capifwd/files/capifwd.conf6
-rw-r--r--net-dialup/capifwd/files/capifwd.init22
-rw-r--r--net-dialup/capifwd/metadata.xml9
7 files changed, 258 insertions, 0 deletions
diff --git a/net-dialup/capifwd/Manifest b/net-dialup/capifwd/Manifest
new file mode 100644
index 000000000000..02c73ec283cf
--- /dev/null
+++ b/net-dialup/capifwd/Manifest
@@ -0,0 +1 @@
+DIST capifwd-0.6.3.tar.bz2 82604 SHA256 8c838eeab438cdbf7b70655f984e70833ccf71796ad618b9616fd5dcc517b058
diff --git a/net-dialup/capifwd/capifwd-0.6.3-r1.ebuild b/net-dialup/capifwd/capifwd-0.6.3-r1.ebuild
new file mode 100644
index 000000000000..e7593c5ef9fd
--- /dev/null
+++ b/net-dialup/capifwd/capifwd-0.6.3-r1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit eutils autotools
+
+DESCRIPTION="A daemon forwarding CAPI messages to capi20proxy clients"
+HOMEPAGE="http://capi20proxy.sourceforge.net/"
+SRC_URI="mirror://sourceforge/capi20proxy/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 x86"
+IUSE=""
+
+DEPEND="net-dialup/capi4k-utils"
+
+S="${WORKDIR}/linux-server"
+
+src_unpack() {
+ unpack ${A}
+
+ cd "${S}"
+ epatch "${FILESDIR}/${P}.patch"
+ epatch "${FILESDIR}/${P}-amd64.patch"
+
+ #Replace obsolete sys_errlist with strerror
+ sed -i -e 's:sys_errlist *\[ *errno *\]:strerror(errno):' \
+ src/capifwd.c src/capi/waitforsignal.c src/auth/auth.c || \
+ die "failed to replace sys_errlist"
+
+ eautoreconf
+}
+
+src_install() {
+ einstall || die "einstall failed"
+ dodoc AUTHORS ChangeLog README
+
+ # install init-script
+ newinitd "${FILESDIR}/capifwd.init" capifwd
+ newconfd "${FILESDIR}/capifwd.conf" capifwd
+}
diff --git a/net-dialup/capifwd/files/capifwd-0.6.3-amd64.patch b/net-dialup/capifwd/files/capifwd-0.6.3-amd64.patch
new file mode 100644
index 000000000000..c387b567be5b
--- /dev/null
+++ b/net-dialup/capifwd/files/capifwd-0.6.3-amd64.patch
@@ -0,0 +1,136 @@
+--- src/protocol.h 2002-10-30 16:16:06.000000000 +0100
++++ src/protocol.h 2007-02-03 01:27:40.000000000 +0100
+@@ -53,6 +53,7 @@
+ #ifndef __PROTOCOL_H__
+ #define __PROTOCOL_H__
+ #include <time.h>
++#include <sys/types.h>
+
+ // Operating System types
+
+@@ -109,20 +110,20 @@
+ #define revision "$Revision: 1.1 $"
+
+ struct __version_t {
+- unsigned long major; // major version for incompatible versions
+- unsigned long minor; // minor version for compatible versions
++ uint32_t major; // major version for incompatible versions
++ uint32_t minor; // minor version for compatible versions
+ };
+
+ // CLIENT REQUESTS //
+ // protocol specific
+ struct REQUEST_PROXY_HELO { // type number: 99
+- char name[64]; // name of the client (for logging)
+- int os; // operating system of the client
++ uint8_t name[64]; // name of the client (for logging)
++ uint32_t os; // operating system of the client
+ struct __version_t version; // version of the client
+ };
+
+ struct REQUEST_PROXY_AUTH { // type number: 98
+- unsigned long auth_type; // authentication type desired
++ uint32_t auth_type; // authentication type desired
+ };
+
+ struct REQUEST_PROXY_KEEPALIVE { // type number: 97
+@@ -171,11 +172,11 @@
+
+ // protocol specific
+ struct ANSWER_PROXY_HELO { // type number: 99
+- char name[64]; // some kind of name for the server (zero-terminated)
+- int os; // the operating system of the server
++ int8_t name[64]; // some kind of name for the server (zero-terminated)
++ int32_t os; // the operating system of the server
+ struct __version_t version; // the version of the server
+- unsigned long auth_type; // the server tells the client which auth-methods it supports (each bit represents one method) !changed!
+- int timeout; // in seconds, -1 means no timeout
++ int32_t auth_type; // the server tells the client which auth-methods it supports (each bit represents one method) !changed!
++ int32_t timeout; // in seconds, -1 means no timeout
+ };
+
+ struct ANSWER_PROXY_AUTH { // type number: 98
+@@ -185,7 +186,7 @@
+ };
+
+ struct ANSWER_PROXY_SHUTDOWN { // type number: 96
+- char reason[128];
++ int8_t reason[128];
+ // z.B. "Ich muss dringend aufs Klo!"; :-)
+ // no answer from the client expected
+ };
+@@ -208,7 +209,7 @@
+ };
+
+ struct ANSWER_CAPI_MANUFACTURER { // type number: 6
+- char manufacturer[64];
++ int8_t manufacturer[64];
+ };
+
+ struct ANSWER_CAPI_VERSION { // type number: 7
+@@ -217,11 +218,11 @@
+ };
+
+ struct ANSWER_CAPI_SERIAL { // type number: 8
+- char serial[8];
++ int8_t serial[8];
+ };
+
+ struct ANSWER_CAPI_PROFILE { // type number: 9
+- char profile[64];
++ int8_t profile[64];
+ };
+
+ struct ANSWER_CAPI_INSTALLED { // type number: 10
+@@ -229,30 +230,30 @@
+
+
+ struct REQUEST_HEADER {
+- unsigned message_len;
+- unsigned header_len;
+- unsigned body_len;
+- unsigned data_len;
+-
+- unsigned message_id;
+- unsigned message_type;
+- unsigned long app_id; // must be long!
+- unsigned controller_id;
+- unsigned session_id;
++ int32_t message_len;
++ int32_t header_len;
++ int32_t body_len;
++ int32_t data_len;
++
++ int32_t message_id;
++ int32_t message_type;
++ int32_t app_id;
++ int32_t controller_id;
++ int32_t session_id;
+ };
+
+
+ struct ANSWER_HEADER {
+- unsigned message_len;
+- unsigned header_len;
+- unsigned body_len;
+- unsigned data_len;
+-
+- unsigned message_id;
+- unsigned message_type;
+- unsigned long app_id; // must be long!
+- unsigned session_id;
+- unsigned proxy_error;
+- unsigned long capi_error;
++ int32_t message_len;
++ int32_t header_len;
++ int32_t body_len;
++ int32_t data_len;
++
++ int32_t message_id;
++ int32_t message_type;
++ int32_t app_id;
++ int32_t session_id;
++ int32_t proxy_error;
++ int32_t capi_error;
+ };
+ #endif
diff --git a/net-dialup/capifwd/files/capifwd-0.6.3.patch b/net-dialup/capifwd/files/capifwd-0.6.3.patch
new file mode 100644
index 000000000000..66efa7c07cd0
--- /dev/null
+++ b/net-dialup/capifwd/files/capifwd-0.6.3.patch
@@ -0,0 +1,42 @@
+--- src/config/cmdline.c.orig 2002-12-29 16:41:02.000000000 +0100
++++ src/config/cmdline.c 2004-11-20 02:01:38.821706921 +0100
+@@ -57,17 +57,17 @@
+ else if ( !strcmp("-v",argv[i]) || !strcmp("-h",argv[1]) ||
+ !strcmp("--version", argv[1]) || !strcmp("--help", argv[i]) )
+ {
+- printf("
+-%s version %s
+-Copyright (C) 2002: F. Lindenberg, A. Szalkowski
+-Usage:
+-\t%s [options]\n\n Where options is one of:
+--h --help or
+--v --version\tprint this info and quit.
+--f --file\tdefine the configuration file (makes no
+-\t\tsense without config file support).
+--p --port\tdefine the port number.
+-", _progname_long, _version, argv[0]);
++ printf(
++"%s version %s\n"
++"Copyright (C) 2002: F. Lindenberg, A. Szalkowski\n"
++"Usage:\n"
++"\t%s [options]\n\n Where options is one of:\n"
++"-h --help or\n"
++"-v --version\tprint this info and quit.\n"
++"-f --file\tdefine the configuration file (makes no\n"
++"\t\tsense without config file support).\n"
++"-p --port\tdefine the port number.\n\n",
++_progname_long, _version, argv[0]);
+ exit ( 0 );
+ }
+
+--- src/capifwd.c.orig 2006-09-23 10:39:30.000000000 +0300
++++ src/capifwd.c 2006-09-23 10:41:32.836443500 +0300
+@@ -13,7 +13,7 @@
+ ssize_t n = recv(fd, buf, left, 0);
+ if (n <= 0)
+ return n;
+- (char*)buf += n;
++ buf = (char*)buf + n;
+ left -= n;
+ }
+ return size;
diff --git a/net-dialup/capifwd/files/capifwd.conf b/net-dialup/capifwd/files/capifwd.conf
new file mode 100644
index 000000000000..07a369722024
--- /dev/null
+++ b/net-dialup/capifwd/files/capifwd.conf
@@ -0,0 +1,6 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+# define the port number
+PORT=6674
diff --git a/net-dialup/capifwd/files/capifwd.init b/net-dialup/capifwd/files/capifwd.init
new file mode 100644
index 000000000000..0c339f35eecb
--- /dev/null
+++ b/net-dialup/capifwd/files/capifwd.init
@@ -0,0 +1,22 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+opts="start stop"
+
+depend() {
+ need capi
+}
+
+start() {
+ ebegin "Starting capi forwarding daemon"
+ start-stop-daemon --start --quiet --exec /usr/sbin/capifwd -- -p ${PORT}
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping capi forwarding daemon"
+ start-stop-daemon --stop --quiet --retry 5 --exec /usr/sbin/capifwd
+ eend $?
+}
diff --git a/net-dialup/capifwd/metadata.xml b/net-dialup/capifwd/metadata.xml
new file mode 100644
index 000000000000..dac0bf21fe8b
--- /dev/null
+++ b/net-dialup/capifwd/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>net-dialup</herd>
+ <longdescription>A daemon forwarding CAPI messages to capi20proxy clients</longdescription>
+ <upstream>
+ <remote-id type="sourceforge">capi20proxy</remote-id>
+ </upstream>
+</pkgmetadata>